Windows I need help installing GMS2

Hi, can someone help me install GMS2? I am using Windows 7 OS and I believe I have all the minimum PC specs. After installing GMS2 trial edition, I run the program so it can finish installing online or whatever... but nothing happens. I’m using my hotspot on my phone connected directly to my PC, as that is my only form of internet. I also have closed my anti virus software.

I don’t understand what the issue could be. I also tried reopening a ticket in regards to this, as a few months ago when I previously tried to use GMS2 I ran into this issue and couldn’t move forward. I just don’t know what it could be. I tried reviewing a ‘User Permissions and Internet Access Required’ troubleshooting guide but to no avail.

I’m definitely no computer whiz, wish I had some tech genius to help point me to what’s going on here .. looks like I’m stuck using RPG Maker til I can get a new pc, unless I can work around this problem.
 
What are you PC specs. What graphics card do you have. Is your Windows installation 64 bit?

When you say nothing happens, do you mean when you double-click on the GMS 2 icon to run it, the software doesn't even open?
 
OS is Windows 7, 64 bit processing

RAM is 6gb, (4.87 usable)

Processor is Intel Core 2 CPU, 6400 @2.13GHz

Graphics card chip type is GeForce GT 630

DAC type is Integrated RAMDAC


Yes, that’s exactly what I mean. After installing the software, when I try to run the executable to finish the installation (to get whatever it needs to retrieve online), nothing happens. My mouse cursor has a loading icon momentarily and then nothing happens.

Thanks.
 
Is there anything recorded in your "ui.log" file?

It should be in this folder here for a default installation : C:\ProgramData\GameMakerStudio2\ui.log

There may be also a crash log file. Could you post both of these here. If they are long, wrap them in spoiler tags. [spoiler][/spoiler]

Also check your graphics driver is up to date.

You could try installing the mesa graphics software driver manually, although I read newer versions of GMS 2 will install it automatically for you if you have a crash. Details in this post : https://forum.yoyogames.com/index.php?posts/247389/

Are you installing the latest version of GMS 2 I assume? Are you installing from Steam, or the standalone version you can download from Yoyo's website?

Are you logged in to your computer as administrator? Have you tried disabling your anti-virus when you first try to run GMS 2?
 
Sorry for the long delay. Been busy with work and school and just kinda gave up on GMS2 as I’m a complete amateur in troubleshooting errors like this...

@IndianaBones I can’t even launch the program to do the initial updates when it is supposed to connect to the internet. As far as I can tell there is a ‘ui.log’ file or a crash log file.

I will check if my graphics driver is up to date if I can manage to figure that out next time I’m on my PC (I’m using my phone away from home right now)

@rIKmAN Does my Windows have to have the most recent update? Perhaps that is my issue, if so...
 
Top