• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android / Amazon Fire I have many crashes on Android devices

I have uploaded an application to Google Play I have tried it and I have not found errors on my device, it is a light application, it only weighs 35MB, it is very simple, it uses very few resources, 105 crashes have been presented in a total of 392 devices in the last 7 days.

I have already further optimized the application, I have exported in .aab using Armv7 and Arm64 structures.

I also use the following APIs to build
Api level 29 and minimum SDK 16.

Most of the devices that have these problems are when starting the app it just freezes and the Google Play reports provided thanks to its beta tester program show the following code:

Problem: Native crash of com.rnetstudio.nopor
*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
Build fingerprint: 'samsung / m0xx / m0: 4.3 / JSS15J / I9300XXUGMK6: user / release-keys'
Revision: '12'
pid: 13274, tid: 13312, name: Thread-976 >>> com.rnetstudio.nopor <<<
signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000010

I have seen the video and the user will open the apk and in seconds it crashes.
I have uploaded about 3 updates and the app continues to close on the following device:
Galaxy S3
RAM 1024 MB
Android version Android 4.3

What can I do to avoid these failures and above all not to have negative evaluations?

Thank you :)

The dimensions of the room is 1280 * 720
 

Attachments

Code:
/Users/netares/Library/Android/sdk/platform-tools/adb DONE (0)
OptionsIni
PlatformOptions
/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.5.378/bin/GMAssetCompiler.exe  /c /zpex /iv=0 /rv=0 /bv=0 /j=8  /gn="NOPOR" /td="/var/folders/hn/xt63nv0d6s51yf5jbdpcxjjw0000gn/GameMakerStudio2/GMS2TEMP" /cd="/Users/netares/.config/GameMakerStudio2/Cache/GMS2CACHE/NOPOR_72189278" /zpuf="/Users/netares/.config/GameMakerStudio2/ernestoetzatlan1_125088" /m=llvm-android /tgt=8 /llvmSource="/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.5.378/yyc/"  /nodnd /cfg="default" /fU="/Users/netares/.config/GameMakerStudio2/Cache/GMS2CACHE/NOPOR_72189278/functionsUsed.txt" /o="/var/folders/hn/xt63nv0d6s51yf5jbdpcxjjw0000gn/GameMakerStudio2/GMS2TEMP/NOPOR_5570523F_YYC" /optionsini="/var/folders/hn/xt63nv0d6s51yf5jbdpcxjjw0000gn/GameMakerStudio2/GMS2TEMP/NOPOR_5570523F_YYC/options.ini" /baseproject="/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.5.378/BaseProject/BaseProject.yyp" "/Users/netares/Dropbox/NOPOR/NOPOR.yyp" /arch=18
/bt=exe /rt=yyc
Reading project file..../Users/netares/Dropbox/NOPOR
Reading project file..../Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.5.378/BaseProject
Reading config delta '/Users/netares/Dropbox/NOPOR/options/main/inherited/options_main.inherited.yy'
finished.
Compile Constants...finished.
Remove DnD...finished.
Compile Scripts...finished.
Compile Objects...finished.
Compile Timelines...finished.
Compile Triggers...finished.
Compile Rooms...finished.
Compile Extensions...finished.
Global scripts...finished.
finished.
collapsing enums.
Final Compile...finished.
Writing Chunk... GEN8
option_game_speed=30
Writing Chunk... OPTN
Writing Chunk... LANG
Writing Chunk... EXTN
Writing Chunk... SOND
Writing Chunk... AGRP
Writing Chunk... SPRT
Writing Chunk... BGND
Writing Chunk... PATH
Writing Chunk... SCPT
Writing Chunk... GLOB
Writing Chunk... SHDR
Writing Chunk... FONT
Writing Chunk... TMLN
Writing Chunk... OBJT
Writing Chunk... ROOM
Writing Chunk... DAFL
Writing Chunk... EMBI
Writing Chunk... TPAGE
Texture Group - Default
Texture Group - Finish
Texture Group - Menu
Texture Group - Play
Writing Chunk... TGIN
Writing Chunk... STRG
Writing Chunk... TXTR
0 Compressing texture... writing texture texture_0.png...
1 Compressing texture... writing texture texture_1.png...
2 Compressing texture... writing texture texture_2.png...
3 Compressing texture... writing texture texture_3.png...
4 Compressing texture... writing texture texture_4.png...
5 Compressing texture... writing texture texture_5.png...
6 Compressing texture... writing texture texture_6.png...
7 Compressing texture... writing texture texture_7.png...
8 Compressing texture... writing texture texture_8.png...
9 Compressing texture... writing texture texture_9.png...
10 Compressing texture... writing texture texture_10.png...
11 Compressing texture... writing texture texture_11.png...
12 Compressing texture... writing texture texture_12.png...
13 Compressing texture... writing texture texture_13.png...
14 Compressing texture... writing texture texture_14.png...
15 Compressing texture... writing texture texture_15.png...
Writing Chunk... AUDO
ClangExeLocation=/Users/netares/Downloads/android-ndk-r16b/toolchains/llvm/prebuilt/darwin-x86_64/bin/clang++.exe
Using NDKDir = /Users/netares/Downloads/android-ndk-r16b
Using PlatformDir = /Users/netares/Downloads/android-ndk-r16b/platforms/android-27
Using ARMToolChain = /Users/netares/Downloads/android-ndk-r16b/toolchains/arm-linux-androideabi-4.9/prebuilt/darwin-x86_64
Using ARM64ToolChain = /Users/netares/Downloads/android-ndk-r16b/toolchains/aarch64-linux-android-4.9/prebuilt/darwin-x86_64
saving file /var/folders/hn/xt63nv0d6s51yf5jbdpcxjjw0000gn/GameMakerStudio2/GMS2TEMP/NOPOR_5570523F_YYC/NOPOR.droid
[armeabi-v7a] Compile++ arm  : yoyo <= gml_Object_obj_coinss_Create_0.gml.cpp
[armeabi-v7a] Compile++ arm  : yoyo <= gml_Object_obj_coinss_PreCreate_0.gml.cpp
[armeabi-v7a] Compile++ arm  : yoyo <= gml_Object_obj_ads_Create_0.gml.cpp
make: /Users/netares/Downloads/android-ndk-r16b/toolchains/llvm/prebuilt/darwin-x86_64/bin/clang++: No such file or directory
[armeabi-v7a] Compile++ arm  : yoyo <= gml_Object_obj_ads_PreCreate_0.gml.cpp
make: /Users/netares/Downloads/android-ndk-r16b/toolchains/llvm/prebuilt/darwin-x86_64/bin/clang++: No such file or directory
make: *** [obj/local/armeabi-v7a/objs/yoyo/gml_Object_obj_coinss_Create_0.gml.o] Error 1
make: *** Waiting for unfinished jobs....
make: /Users/netares/Downloads/android-ndk-r16b/toolchains/llvm/prebuilt/darwin-x86_64/bin/clang++: No such file or directory
make: *** [obj/local/armeabi-v7a/objs/yoyo/gml_Object_obj_ads_Create_0.gml.o] Error 1
make: /Users/netares/Downloads/android-ndk-r16b/toolchains/llvm/prebuilt/darwin-x86_64/bin/clang++: No such file or directory
make: *** [obj/local/armeabi-v7a/objs/yoyo/gml_Object_obj_ads_PreCreate_0.gml.o] Error 1
make: *** [obj/local/armeabi-v7a/objs/yoyo/gml_Object_obj_coinss_PreCreate_0.gml.o] Error 1
Stats : GMA : Elapsed=7156.055
Stats : GMA : sp=35,au=8,bk=0,pt=5,sc=1,sh=0,fo=3,tl=0,ob=43,ro=4,da=0,ex=4,ma=54,fm=0xC0B20148FF2AB0



/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono exited with non-zero status (2)

elapsed time 00:00:11.0082400s for command "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono" /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.5.378/bin/Igor.exe -j=8 -options="/var/folders/hn/xt63nv0d6s51yf5jbdpcxjjw0000gn/GameMakerStudio2/GMS2TEMP/build.bff" -v -- Android Package started at 03/21/2020 12:57:20
FAILED: Package Program Complete
For the details of why this build failed, please review the whole log above and also see your Compile Errors window.
It leaves me enough errors that in VM do not appear, for example the first error is this.

make: *** [obj / local / armeabi-v7a / objs / yoyo / gml_Object_obj_coinss_Create_0.gml.o] Error 1

In that object I only have the following code in the create event:

GML:
/// @description Insert description here
// You can write your code in this editor
image_index = obj_ctrl.lenguaje;
image_speed = 0;
PD even delete that create event and keep getting the same error.

I don't see why this could be an error: C
Could you recommend something or give me advice, from a time here I uploaded the crashes on old devices, previously in GM1.4 I ran them without problem: c
 

Mool

Member
go into %appdata%/GameMakerStudio2/Cache/GMS2CACHE/YOUR_PROJECT

and delete that folder. after that also delete cache (inside of gms)

And set up NDK correctly -> u use android-ndk-r16b, but thats not recommended
 
I went through the steps and was able to export to YYC. I was excited, I had never felt like this, I loaded the application in Google Play, and having previously had a failure, I went up to three failures,: C I do not understand why, I tested the application in a low-performance cell phone and it stayed the same it continues to close: c

[CITA = "Mool, publicación: 431380, miembro: 8290"]
ir a% appdata% / GameMakerStudio2 / Cache / GMS2CACHE / YOUR_PROJECT

y eliminar esa carpeta. después de eso también elimine el caché (dentro de gms)

Y configure NDK correctamente -> usa android-ndk-r16b, pero eso no es recomendable
[/ CITAR]
¿Cómo puedo probar mi aplicación en muchos dispositivos?
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Both the device that are shown in the screenshot (Galaxy III and P8 Lite) are - by todays standards - old phones and use versions of android that are pretty much obsolete. I would suspect that the issue is with that rather than GameMaker, ie: the older the version of Android the phone uses the more likely you are to get a crash. While android is supposed to be backwards compatible, it's not 100% especially as phones like Samsung use a custom version of the OS, meaning that it's not stock Android. You could try lowering the minimum API target in the preferences, but I suspect you'd probably be best to raise the minimum API level to 16 or even 18... This will mean that google won't serve the app to devices under the minimum API level and hopefully avoid those crashes and issues.
 
Top