Question - Downloading I can't download a marketplace download!?

Okay, when I open GameMaker, first of all it doesn't find my account when I try to sign in with my email and password. I am putting in the EXACT SAME email and password that works just fine on the Yoyo website and where I purchased an asset! So first of all, how to I sign in to Game Maker Studio (legacy) ??

Secondly, if I try to download an asset off of my marketplace purchases on Yoyo's website, it just opens up a new page and directs me download GM2. All of the assets I have bought are only for Legacy GM1! It won't let me even download items I have purchased right from the website! I have tried downloading it using both Chrome and Firefox. Same result.

Can someone please tell me how I can get my asset into GameMaker? This is way too difficult and shame on Yoyo for making getting and installing a purchased marketplace item a freaking nightmare.
Last edited:


maybe they having some problems with the website.
Maybe, if you using the assets you want in older/other GMS projects, perhaps you can grab them by going through documents? copy & paste into a new folder then import them into your new project. I'm clutching at straws there, but it may work.