1. Hello Guest! It's with a heavy heart that we must announce the removal of the Legacy GMC Archive. If you wish to save anything from it, now's the time! Please see this topic for more information.
    Dismiss Notice

iOS How to make iOS version now?

Discussion in 'GameMaker Studio 2 Community Tech Support' started by bsabiston, Nov 23, 2019.

Tags:
  1. bsabiston

    bsabiston Member

    Joined:
    Jun 21, 2016
    Posts:
    217
    I haven't tested my game on iOS in a while. Now when I try it, the compile fails, and it just says 'linker code failed with exit code 1'. Anyone know what the problem might be?

    Also - are the Global Game Settings gone now?
    Thanks
     
    Last edited: Nov 23, 2019
  2. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,763
    The various platform specific settings can be found under “Options” in the Resource Tree.

    You’ll need to post more information (preferably the full log inside code and spoiler tags) to get much help with the compile error as that isn’t enough to go off.

    Can you compile a fresh empty project to your device.
     
  3. bsabiston

    bsabiston Member

    Joined:
    Jun 21, 2016
    Posts:
    217
    Well that's the thing with iOS -- the gamemaker compile doesn't produce any errors, it just generates the XCode project.

    If I look at the XCode report navigator, there are a ton of warnings, but only one error. It says

    :-1: symbol(s) not found for architecture arm64
    /clang:-1: linker command failed with exit code 1 (use -v to see invocation)

    GMS2 doesn't require XCode 11, does it? Cause I just have High Sierra and can't upgrade to Catalina because of all my old 32 bit apps.
     
    Last edited: Nov 24, 2019
  4. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,763
    From the iOS section of the GMS2 Required SDKs Article:
     
  5. bsabiston

    bsabiston Member

    Joined:
    Jun 21, 2016
    Posts:
    217
  6. TsukaYuriko

    TsukaYuriko Q&A Spawn Camper Forum Staff Moderator

    Joined:
    Apr 21, 2016
    Posts:
    1,764
    The cited article merely says that the article itself is targeted at High Sierra, as well as that you should use the latest versions:
    Please also note that most of these requirements, and their frequent changes, are caused by third parties changing their requirements - so YoYo Games has to follow suit.
     
  7. bsabiston

    bsabiston Member

    Joined:
    Jun 21, 2016
    Posts:
    217
    Okayyy. Idk I think that page is pretty misleading. I think most people reading it would expect that High Sierra is supported. Hell it even says that *older* OS versions may work. They say it depends on the version of XCode supported by the OS.

    So, apparently that has changed, and that’s what I mean when I say their documentation is inconsistent.

    At least Mojave still runs 32 bit apps.
     
  8. spinout

    spinout Member

    Joined:
    Jun 21, 2016
    Posts:
    85
    I've seen that error before. It was a mismatch of versions with extensions.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice