3D how do i get d3d_set_perspective(false) to work?

P

priory

Guest
how do i get d3d_set_perspective(false) to work?
no matter where i put it, i cant get orthographic projection on windows 10.

before or after d3d_start() in step event, draw event nor draw HUD.
projection and models in draw event or draw hud event dont make a difference.

i wonder if its bugged can anyone confirm this isnt broken?
 
P

priory

Guest
no i call it in create lol it was a summary of tries sry. Also ofc i know the ortho function and it doesnt help at all ofcourse.

i need to d3d_set_perspective to work. All alternatives are out of the question. The problem is specifically: how do i get it to work. It doesnt do what the manual says it should no matter where i implement it.
 
just a thing err... I might le overstepping my boundaries but...

Have you tried using:

d3d_set_perspective(true)

(instead of, you know, using 'false')
 
P

priory

Guest
funny indeed i havent tried using true, i have only tried using false. Assuming set perspective means setting the projection and vertices persepectively. Logic suggest you should set it to false to turn off perspective and vertices should be shown orthographic.
 
Top