• Hey! Guest! The 40th (!!!) GMC Jam will take place between February 25th, 12:00 UTC to March 1st 12:00 UTC. Why not join in this very special anniversary jam! Click here to find out more!

GMS 2.3+ How do I change the backgroud color in Code?

Petrik33

Member
Hello Everybody. I am currently making the Illustrations System for my project in GMS 2.3. And it goes well, but what I can't make working is the background, it is grey for no reason. So currently my illustrations are working this way:
The game just draws the 640 x 360 image to the screen in the best possible way, and there are transitions between illustrations with black borders covering and uncovering the screen. SO the problem is that when transitions end, I got the illustration(Which also has some back blackground on sprite) and empty background + black borders from the screen resolution managment. But the problem is that this empty bakcground isn't black and it appears as a grey space between illustration sprite and Resolution Borders. I have attached screenshot for better understanding.

So for some more clearance, when I enter illustration mode, I don't leave the main action room but just deactivate all the objects, set the background layers invisible and then do the illustrations turning it all back in the end.
The problem is that I have even tried to set the black background layer visible before illustrations start to make the background black, but it stil doesn't help.
So what should I do???
(I have also attached the screenshot of the game after illustrations so you get it even more clear)
Edit:
GML:
background_showcolor = c_black;
background_color = c_black;
Also doesn't work
 

Attachments

ThraxxMedia

Member
I'm not 100% sure if this is related or would help you in any way... but please check the following: go to your project's settings (the cogwheel button from the shortcut bar at the top), and under "Main Options -> General" see if you need to set either the "default draw color" or the "default color outside the room region" to anything else, in your case I guess c_black. These colors are not the same as the background layer in your rooms.
 

Petrik33

Member
I'm not 100% sure if this is related or would help you in any way... but please check the following: go to your project's settings (the cogwheel button from the shortcut bar at the top), and under "Main Options -> General" see if you need to set either the "default draw color" or the "default color outside the room region" to anything else, in your case I guess c_black. These colors are not the same as the background layer in your rooms.
Thank you, I will try!
 
Top