how can i resize sprites in game maker

Please do not post in all large letters.

If you increase the size of a sprite you need to do so by increments of 100% (e.g. 200%, 300%, 400%). If you increase the size of a sprite by a different factor (such as by 150%) the program has to interpolate sprites causing the blurring.
 
H

Heropants

Guest
you just need to turn off interpolation. Go to global game settings, then the platform your testing on (probably windows), then go to graphics and click the box for "interpolate colors between pixels" to be off.
 

cdgamedev

Member
game maker
So your resizing them inside the editor? And its creating the blur? Try using something else such as Paint - there's a resize setting that works... Dunno if GameMaker has it
GameMaker does have it... Press Ctrl+Alt+E and select "Excellent" for quality
 
Last edited:
N

NPT

Guest
You went from a resolution of approximately 25x34 to 12x17, of course you are going to lose information, detail and introduce "blurring".
 
Top