Legacy GM Horrible lag when running GameMaker 8 and below made games

Discussion in 'Legacy GameMaker Community Tech Support' started by IGuessIHadTo, Dec 15, 2018.

  1. IGuessIHadTo

    IGuessIHadTo Member

    Joined:
    Aug 15, 2016
    Posts:
    3
    Ok, so whenever i run a game made with the "legacy" 7, 8 and 8.1 versions of GameMaker (whether it be me testing a gmk or just running an executable), the games suffer from heavy framerate drop and run very slowly, this started happening quite a few months back and i have tried everything to fix it and yet no dice. Help would be greatly appreciated, cheers.
     
  2. James222

    James222 Member

    Joined:
    Aug 26, 2016
    Posts:
    53
    What specs are you running out of curiosity. I still use gm 8.1 a fair bit because of nostalgia haha. I know windows 8 and up has issues eith the inbuilt sound system.... but i have never really had the symptoms your talking about. Do you have another machine to test on?
     
  3. TheouAegis

    TheouAegis Member

    Joined:
    Jul 3, 2016
    Posts:
    6,244
    Make sure you have Synchronize to Avoid Tearing disabled in the Global Game Settings. I had a couple projects that on some of my computers this setting would kill the frame-rate as soon as I introduced any surfaces - possibly as soon as I had more than one view. I mean, vsync was nice sometimes, but some hardware configurations just couldn't handle it. (Also check your video driver settings to make sure you didn't tweak something there.)
     
  4. vorgon

    vorgon Member

    Joined:
    Thursday
    Posts:
    1
    Yeah, I noticed that when booting up GM8 for the first time in a while yesterday.
    In my case it seemed to be related to USB devices, and maybe extra monitors, as when I unplugged my tablet monitor (both HDMI and USB) and my USB keyboard things went back to normal.
    Though, when plugging the monitor back in (video only, no USB) it was still able to run normally.
    Likewise, my USB PS2 controller adapter didn't seem to cause any lag, nor does my USB mouse.

    edit: setting Compatibility Mode to XP seems to reduce, but not completely eliminate, the lag. With that on I only have to unplug the USB cable from my Tablet monitor to get things running smoothly again.
     
    Last edited: Mar 19, 2019 at 4:13 AM

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice