• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX Help with GMS2 Open Beta Version on Mac (Game not Running)

Raptor_Guy

Member
So I have a Mac, and have been waiting for GMS to come to the platform for free. So, naturally, I got excited when Yoyo Games announced GMS2 Open Beta for Mac, and downloaded it immediately when it released. And yes, I know it's just a demo version, and that comes with limitations, but I'm having a big problem; my game won't even run. Whenever I click "Run" or hit fn+F5, the output box just says "FAILED: Run Program Complete" and just stops trying to run. I double-checked and found no syntax errors, and even re-downloaded the software. I searched and searched and searched for an answer but couldn't find anyone with the same issue. So I came here to the forums for help. Anyone got any advice??
 
What happens if you just make a new project with a single room and no code and try to run it?

What is your full output window showing?

Did the installer prompt you to install the Mono Framework during installation?

What version of IDE and runtime do you have?

What build target have you selected? VM / YYC?

What version of Mac OS do you have?

What version of xcode have you installed?

Do you have any anti-virus installed?

EDIT: There is a file called ui.log in Users\Shared\GameMakerStudio2 - does it have any errors listed?
 

Raptor_Guy

Member
1. The same thing happens

2. This is what it spits out: Saving project to: /Users/Evan/GameMakerStudio2/Untitled.yyp/Untitled.yyp
Saving 1 resources
"/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono" /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.0.7.110/bin/Igor.exe -options="/var/folders/80/xcpcd8f12znd420zpyjwxjb40000gn/GameMakerStudio2/GMS2TEMP/build.bff" -- Mac Run

FAILED: Run Program Complete

3. No, I don't think so. (sorry if that's not helpful)

4. IDE: v2.0.7.173 Runtime: v2.0.7.110

5. VM (I can change that if necessary)

6. El Capitan v10.11.5

7. I don't think I have that installed... should I?

8. No.

9. This is what it showed me when I searched "error" in the ui.log file:

[13:04:05:149(c486)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='--version', CurrentDirectory='', Native error= Cannot find the specified file
[13:19:32:339(d5f5)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='--version', CurrentDirectory='', Native error= Cannot find the specified file
[13:36:53:515(d5f5)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:36:53:556(d5f5)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:36:53:611(d5f5)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:36:53:671(d5f5)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:36:53:708(d5f5)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:36:53:738(d5f5)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:40:57:591(24fb)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='--version', CurrentDirectory='', Native error= Cannot find the specified file
[13:41:14:49(24fb)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:41:14:105(24fb)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:41:14:141(24fb)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:41:14:204(24fb)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:41:14:241(24fb)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:41:14:285(24fb)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:41:31:159(24fb)] Error: trying to deactivate an unregistered module.(type of YoYoStudio.Plugins.CorePlugins.OutputWindows.DefaultOutputWindow)
[13:41:31:161(24fb)] Error: trying to deactivate an unregistered module.(type of YoYoStudio.Plugins.CorePlugins.OutputWindows.SourceControlOutputWindow)
[13:41:31:164(24fb)] Error: trying to deactivate an unregistered module.(type of YoYoStudio.Plugins.CorePlugins.OutputWindows.SearchOutputWindow)
[13:41:46:118(a446)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='--version', CurrentDirectory='', Native error= Cannot find the specified file
[13:42:35:930(a446)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:42:35:988(a446)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:42:36:25(a446)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:42:36:90(a446)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:42:36:127(a446)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:42:36:172(a446)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[13:42:41:250(a446)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.0.7.110/bin/Igor.exe -options="/var/folders/80/xcpcd8f12znd420zpyjwxjb40000gn/GameMakerStudio2/GMS2TEMP/build.bff" -- Mac Run', CurrentDirectory='', Native error= Cannot find the specified file
[13:45:35:597(a446)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.0.7.110/bin/Igor.exe -options="/var/folders/80/xcpcd8f12znd420zpyjwxjb40000gn/GameMakerStudio2/GMS2TEMP/build.bff" -- Mac Run', CurrentDirectory='', Native error= Cannot find the specified file
[10:19:04:631(22af)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='--version', CurrentDirectory='', Native error= Cannot find the specified file
[10:19:22:800(22af)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[10:19:22:850(22af)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[10:19:22:886(22af)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[10:19:22:952(22af)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[10:19:22:974(22af)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[10:19:23:15(22af)] Caught exception for gadget of type 'window' and style 'window'- Error: An anchor or dimension has been set to percentage with no parent gadget, try using pixel instead
[10:19:33:522(22af)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.0.7.110/bin/Igor.exe -options="/var/folders/80/xcpcd8f12znd420zpyjwxjb40000gn/GameMakerStudio2/GMS2TEMP/build.bff" -- Mac Run', CurrentDirectory='', Native error= Cannot find the specified file
[10:37:44:444(22af)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='/Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.0.7.110/bin/Igor.exe -options="/var/folders/80/xcpcd8f12znd420zpyjwxjb40000gn/GameMakerStudio2/GMS2TEMP/build.bff" -- Mac Run', CurrentDirectory='', Native error= Cannot find the specified file
 
R

RobbSnow

Guest
El Capitan is not supported. From the macOS requirements ...

  • For building projects you need Xcode 8.3 which requires macOS Sierra 10.12
 
Did the installer prompt you to install the Mono Framework during installation?
3. No, I don't think so. (sorry if that's not helpful)
[13:04:05:149(c486)] Unable to launch "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono": System.ComponentModel.Win32Exception (0x80004005): ApplicationName='/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono', CommandLine='--version', CurrentDirectory='', Native error= Cannot find the specified file
That's actually very helpful.

As well as the macOS requirements mentioned by @RobbSnow, you need the Mono framework installed, which it appears that perhaps the installer didn't install for you.

It's supposed to prompt you automatically, but you can download it manually and try.

Although I suspect you may need to upgrade to Sierra and Xcode 8.3 as well.

Requirements:
https://help.yoyogames.com/hc/en-us/articles/227860547

Mono Framework Installer:
https://download.mono-project.com/a...k-MDK-4.8.0.520.macos10.xamarin.universal.pkg
 

Raptor_Guy

Member
Thanks! I'll try installing the mono framework as well as upgrade to sierra and xcode. And I'll get back to you tomorrow! :)
 

Raptor_Guy

Member
Okay! It works now! :D

I upgraded my Mac, installed the mono framework, and Xcode 8.3.3, and I can finally test my game!

Thanks for all the help, guys. I really appreciate it!
 
Top