Windows HELP!! String not found: System.IO.DirectoryNotFoundException: Could not find a part of the path

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Bokkie2988, Aug 3, 2018.

Tags:
  1. Bokkie2988

    Bokkie2988 Member

    Joined:
    Aug 3, 2018
    Posts:
    50
    Hello,

    I've had problems starting up GMS2 lately. I downloaded the newest update, and when I run the program it shows this error message: String not found: System.IO.DirectoryNotFoundException: Could not find a part of the path 'Z:\manifest'.

    Can someone help me please?

    Thanks,
    Bokkie
     
  2. mrclips

    mrclips Member

    Joined:
    Jul 23, 2018
    Posts:
    4
    Same problem.
     

    Attached Files:

  3. Bokkie2988

    Bokkie2988 Member

    Joined:
    Aug 3, 2018
    Posts:
    50
    Anyone have a solution?
     
  4. MarceloP

    MarceloP Member

    Joined:
    Apr 11, 2018
    Posts:
    238
    I'm sorry for asking such a silly question but, have you tried running GMS2 with Administrative rights?

    Have you both any mapped drivers at letter Z: ?
    Have you both tried to restart the computer (if it's something related to a ghost mapped driver)?
     
  5. mrclips

    mrclips Member

    Joined:
    Jul 23, 2018
    Posts:
    4
    There is no driver which is named "Z" and I've tried opening GMS2 with Administrative rights.
    Also I restarted my computer heaps of times. And last thing I did, removed GMS2 studio from my computer and re-installed but still doesn't work.
    I actually downloaded unsteam folder from yoyogames it didn't open too.
     
    Last edited: Aug 6, 2018
  6. Bokkie2988

    Bokkie2988 Member

    Joined:
    Aug 3, 2018
    Posts:
    50
    Tried reinstalling too..
     
  7. Rahub Azeem

    Rahub Azeem Member

    Joined:
    Aug 10, 2018
    Posts:
    1
    I'm also having this problem and it's beginning to irritate me a lot as i have reinstalled GMS2 at least 5 times and restarted my pc at least 5 times as well. I hope YoYo games takes notice of this problem because i'm probably not the only person to experience it. If anybody has a solution please share it as I have a project which i wanted to start with a buddy and we are on hold because of this error.

    Thanks,
    Rahub
     
  8. Shin Kitsune

    Shin Kitsune Member

    Joined:
    May 16, 2017
    Posts:
    5
    I hate to make bump posts like this, but yes, I'm having the same error.
    I'm using the Steam version.
    Tried reinstalling. Tried running with admin rights. Tried deletting the settings folders, and nothing has solved it so far.
     
  9. The Big

    The Big Member

    Joined:
    Aug 5, 2018
    Posts:
    3
    I've found the solution. After filing a bug report a YoYo technician acknowledge the issue and sent me these instructions.
     

    Attached Files:

    MarceloP likes this.
  10. Pedro3051

    Pedro3051 Member

    Joined:
    Aug 17, 2018
    Posts:
    1
    Wanted to try the solution that was given but it appears I had no drivers to disconnect... shame because I really wanted to use the software.
     
  11. Nuroyun

    Nuroyun Member

    Joined:
    Aug 19, 2018
    Posts:
    3
    How can i identify if a drive letter is created by gamemaker studio ?
     
  12. MarceloP

    MarceloP Member

    Joined:
    Apr 11, 2018
    Posts:
    238
    As far as I recall, it's always Z: when it is created by GM and you can't change it on the config or anywhere. Although it is important to note that if you find a Z it still may not have been created by GM. You can setup as many drivers you want and name them any letter.
     
  13. Shin Kitsune

    Shin Kitsune Member

    Joined:
    May 16, 2017
    Posts:
    5
    I have sent them another report with the same response.I constantly checked my "Computer" window, I had even refreshed it and I never saw such Z:\ drive.
    I sent them a response, I've still got to receive a response.
     
  14. Nuroyun

    Nuroyun Member

    Joined:
    Aug 19, 2018
    Posts:
    3
    yeah I dont have a Z: drive too
     
    mrclips likes this.
  15. Jon Mation

    Jon Mation Member

    Joined:
    Sep 6, 2018
    Posts:
    2
    I have the same annoying problem as you all. First everything worked all right but after the Patch it has broken! 99$ for the rubbish?
     
    mrclips likes this.
  16. mrclips

    mrclips Member

    Joined:
    Jul 23, 2018
    Posts:
    4
    I tried to install an older version of Game Maker 2 Studio. It is worked but while I was trying to run a game (I mean press F5) it gives me same error.
     
    Last edited: Sep 9, 2018
  17. TsukaYuriko

    TsukaYuriko Q&A Spawn Camper Forum Staff Moderator

    Joined:
    Apr 21, 2016
    Posts:
    946
    If the problem was not present before updating to the latest version, downloading an older version may offer a temporary fix in the form of a program that is at least usable, even if not fully up to date. 2.1.5 is not a mandatory update, therefore it is possible to download older versions from the release notes and use them instead.

    Some other things to try meanwhile:
    - Ensure that you are using an administrator account and that GMS2 is running with elevated privileges. Failing either of these can and/or will prevent GMS2 from running with elevated privileges, which may be required for mapping the drives.
    - Turn off your firewall and antivirus during installation and usage. They might be blocking the drive mapping. This is not meant to solve the issue, but to isolate the cause. In case this resolves the problem, a bug report should be filed accordingly.

    Bug reports can be filed through the bug report form.
     
  18. Jon Mation

    Jon Mation Member

    Joined:
    Sep 6, 2018
    Posts:
    2
    I downloaded the older version 2.1.4.295 and it’s working without a problem on Windows 7. Thank you! I noticed that the newer version GMS2 is working on another computer (but less powerful) with Windows 10. So it’s maybe an issue around the Windows version.
     
  19. Nuroyun

    Nuroyun Member

    Joined:
    Aug 19, 2018
    Posts:
    3
    Thanks! it worked!
     
  20. Valkuil

    Valkuil Member

    Joined:
    Mar 25, 2018
    Posts:
    2
    It works to get into the program again but I still can't launch my games
     
  21. Valkuil

    Valkuil Member

    Joined:
    Mar 25, 2018
    Posts:
    2
    Ok so my second problem with not being able to launch games is caused by the program not being able to find SUBST.exe (is what I read), the fix didn't work but since this is a similar problem (with the "Z: drive") I think it is also caused by a failure of SUBST.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice