• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX Hanging on Start Page Loading Devices

F

frostypop

Guest
I just purchased GameMaker 2 for Mac, the mobile version. I then downloaded the install file (DMG I believe) for GameMaker 2 and proceeded to successfully install it on my Mac. When it launches however, it simply hangs on the start screen with the loading icon spinning. Any ideas?

Cheers.
 

Attachments

Possibly the gamemaker runtime, or as you are on Mac, possibly the mono package didn't install.

@frostypop Were you prompted to install the mono runtime package when you first installed GMS 2?

If not, uninstall and reinstall GMS 2, let us know what happens?
 
F

frostypop

Guest
@IndianaBones I was not prompted to install the mono runtime package. :-/

I have uninstalled and reinstalled GMS2 I think 3 times now.. same issue.
 
F

frostypop

Guest
PS I used Clean My Mac 3 to complete uninstall all components of GMS2... is it possible it deleted some other file I needed when I reinstalled?
 
EDIT : Ahhh...in that case - you already were using GMS 2 on your Mac - you should have everything installed since the Beta...at least until you uninstalled it.

- Could be a license thing now - Do you remember if you tried logging out and logging back in to GMS 2 after you bought the Mobile license?
- That should have been enough to unlock the Mobile version I believe.


Orginal:
Its possible it could have deleted the runtimes and mono as well, not 100% sure, I think I used a similar program called App Cleaner to remove an older Beta Version of GMS 2, it lets you select what you want to actually remove.

A guess in the dark might be that the Clean program deleted mono, but somewhere on your Mac there is some ini file that says you have the latest version. BUT just theorising here.

Here is a manual download link for Mono :

https://download.mono-project.com/a...k-MDK-4.8.0.520.macos10.xamarin.universal.pkg

You could try uninstall again - then install the Framework, then install GMS 2.

Note: This is not official advice - maybe someone at Yoyo will chip in sooner or later, because GMS 2 is supposed to check and prompt to install Mono Framework as far as I'm aware.
 
F

frostypop

Guest
@IndianaBones Yeah... it was working... until I did a clean wipe before getting the mobile version. :S My MacBook Pro was running slow so I basically did clean build and reinstalled my applications. I'll try and manually download Mono and see if that works.

And yup, already sent issue to YoYo. :)
 
F

frostypop

Guest
Hmmmm... log seems to show missing file... o_O

[20:09:36:47(b221)] File exception 'Could not find file "/Users/faisal/.config/GameMakerStudio2/hello_1201907/git_userpass_authentications.json".'
[20:09:36:47(b221)] File exception 'Could not find file "/Users/faisal/.config/GameMakerStudio2/hello_1201907/git_ssh_authentications.json".'
[20:09:38:527(b221)]
[20:09:38:631(b221)] File exception 'Could not find file "/Users/faisal/.config/GameMakerStudio2/hello_1201907/input.json".'
[20:09:38:632(b221)] Failed to load keyboard definitions file:/Users/faisal/.config/GameMakerStudio2/hello_1201907/input.json
[20:09:38:632(b221)] LoadingState: Devices
[20:09:38:680(b221)] File exception 'Could not find file "/Users/faisal/.config/GameMakerStudio2/hello_1201907/devices.json".'
[20:09:38:680(b221)] Device Manager Load Failed: Could not find file "/Users/faisal/.config/GameMakerStudio2/hello_1201907/devices.json".
[20:09:38:682(b221)] File exception 'Could not find file "/Users/faisal/.config/GameMakerStudio2/hello_1201907/workers.json".'
[20:09:38:682(b221)] LoadingState: WaitOnWelcomePageEnd
 
F

frostypop

Guest
@IndianaBones Oddly, I was able to install it on my MacBook Air, but its not my primary device, and not as fast as the MacBook Pro I need it on.... makes no sense. :-/ Nothing in the log files seems out of whack.
 
Top