GML Gravity is completely ignored

So... I used GM a lot back in the day, 8.1, then I converted from Windows to Mac and that was it. Now after all those years I bought the IDE for macOS and decided to get back at it. First thing I wanted to play with was the new physics engine.

So I made a couple of objects, checked on physics in the room settings, put the objects down with some creation code, but nothing was working. So I tried to simplify the code, and then simplify it even more so that it looks like this (on the Create event):

gravity = 4;
gravity_direction = 270;
I tried changing the direction to every angle, tried setting the gravity to ridiculous values, thinking maybe 4 was just not that strong, but nothing I do makes any difference. The only gravitational pull that works is the one set in the room properties, absolutely nothing else.

Am I missing something? Like is there some other checkbox I need to tick or wtf?

Oh, btw, the objects have checked "use physics" box...


That's not "physics" checkbox physics. That's just old-style physics. If you want to use those variables, uncheck the physics box. If you want to use the new physics engine, read up on it in the Help File.