Android / Amazon Fire Gradle

kirill

Member
Hello everybody. I am from Russia. I have such a problem after updating such an error
-------------------------------------------------- -------------------------------------------
Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.1.1/userguide/command_line_interface.html#sec:command_line_warnings
-------------------------------------------------- --------------------------------------------
How can I update Gradle and where?
I have version 2.2.4.374
 
As a Gradle user on a daily basis (although not on GMS since I don't have the Android export) I have to note that what you mentioned is not usually an error. That text is usually issued when there is a feature that is deprecated in the build, but it usually is only issued as an warning (unless YYG has configured Gradle otherwise). So if the build is actually failing I would check for a potentially different cause.
 

chirpy

Member
If you're upgrading to 2.2.4 for the first time, I'd recommend checking YYG's official release notes and required SDKs FAQ.
Gradle upgrades are done automatically by GMS so it's most likely Android Studio and extensions you use that need updates.
 
Top