• Hey! Guest! The 37th GMC Jam will take place between May 28th, 12:00 UTC and June 1st, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android / Amazon Fire GooglePlayServices error on build, FragmentManager / FragmentActivity

Babaganosch

Member
I can't build for Android after I install Google Play Services into the project. I'm using macOS Mojave 10.14.6, with the IDE v.2.2.4.456 and the runtime v.2.2.4.362.

I've tried cleaning the cache after installing the extension.

This is the error I'm receiving
-------

> Task :info.larsandersson.minecartmaniac:processDebugResources

> Task :info.larsandersson.minecartmaniac:compileDebugJavaWithJavac FAILED
/Users/larsa/.config/GameMakerStudio2/Cache/GMS2CACHE/MinecartMa_FDBE7A28_2A35BA7E/Android/default/info.larsandersson.minecartmaniac/src/main/java/info/larsandersson/minecartmaniac/GooglePlayServicesExtension.java:13: error: cannot find symbol
import android.support.v4.app.FragmentManager;
^
symbol: class FragmentManager
location: package android.support.v4.app
/Users/larsa/.config/GameMakerStudio2/Cache/GMS2CACHE/MinecartMa_FDBE7A28_2A35BA7E/Android/default/info.larsandersson.minecartmaniac/src/main/java/info/larsandersson/minecartmaniac/GooglePlayServicesExtension.java:18: error: cannot find symbol
import android.support.v4.app.FragmentActivity;
^
symbol: class FragmentActivity
location: package android.support.v4.app
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /Users/larsa/.config/GameMakerStudio2/Cache/GMS2CACHE/MinecartMa_FDBE7A28_2A35BA7E/Android/default/info.larsandersson.minecartmaniac/src/main/java/info/larsandersson/minecartmaniac/GooglePlayServicesExtension.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
2 errors

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':info.larsandersson.minecartmaniac:compileDebugJavaWithJavac'.
> Compilation failed; see the compiler error output for details.
 

Babaganosch

Member
Okey, so I recently got a prompt to update IDE to v.2.2.4.458 and runtime to v.2.2.4.364 and this seems to have solved my problem. The project now successfully builds the APK with the Google Play Extension enabled.

The Google Play Extension also seems to have gotten an update, version 3.1.8.
 
Top