• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android Google Play Show Leaderboards Randomly Stopped Working Even though Signed In

GMS 2.2.5.481 (RT 2.2.5.378)
Google Play Services Extension 3.2.0

Has worked fine up until today (or at least between whenever I last tested it and today)
Happens when testing through USB AND for production(dl'd from Google Play) version of my game(s).
Couldn't see error in GMS Output Console.
Weirdly this doesn't happen for showing achievements which works fine.
More weirdly this does Not happen for my Portrait game, only my two Landscape games.

Please let me know if any one else is experiencing this and/or any help you can provide.

When I launch the game I can successfully sign in and I can successfully show the leaderboards for the first time. But after showing the leaderboards once and then closing I guess I am somehow signed out and even though I can sign back in successfully, when I tap the button to show the leaderboards a second (and so on time) it never works again. This also applies when closing the app and reopening it it still doesn't show, I have to uninstall and reinstall or restart my phone for it to restart the process of working the first time. Per below code to show the leaderboards (on Left Pressed) it just becomes a loop of signing in then failing to show the leaderboards then repeat.
GML:
        if (!achievement_login_status()) {
            if (global.sound == 0) {
                audio_play_sound(snd_button,1,0);
            }
            achievement_login();
        }
        else if (achievement_available()) {
            if (global.sound == 0) {
                audio_play_sound(snd_button,1,0);
            }
            achievement_show_leaderboards();
        }
 
Last edited:

SnoutUp

Member
Are you using GPS Save Games by any chance? I had experienced an issue where invalid cloud services implementation would screw with the rest of Google Play Services system and it looked like what you're describing, although things worked fine during USB testing, just not on SOME devices running production version. Fixed by setting up the correct Google Licensing key
 
Top