Question - IDE GMS2 won't run game after restarting IDE

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Barvix, Sep 3, 2019.

  1. Barvix

    Barvix Member

    Joined:
    Jun 21, 2016
    Posts:
    193
    Hi guys, this is an odd issue I've been having for nearly a week now, and I can't seem to figure out why it is happening. So far the most I've managed to do is figure out part of the problem and temporary fixes.

    So whenever I close GMS2 and open it again some time later, my game won't run. And it's not just my game, it's any game I try to build as an exe, build and run, debug, or clean. None of those functions work. So the issue isn't a coding one on my side, it does it to blank projects I've made that only have an object and a room, maybe a line of code here and there.
    Every time I try to build as an exe, build and run, etc. it just says "SAVING PROJECT TO ..."
    In addition it might be important to include the when I try to stop those processes with the Stop button, it just says "STOPPING..." but never really does.

    My first fix was restarting my PC, which worked. At first I thought that fixed the issue since my game could run again, and then I closed GMS2 and opened it later. No success.
    Also I uninstalled and reinstalled GMS2, which did not fix the issue.

    Later I tried seeing if signing out of windows and signing back in again could have an effect, and it did. But it was the same result as when I restart my PC, so long as I don't close GMS2 it works.

    I've cleared out the cache of GMS2 many times before I even considered restarting the PC, so that doesn't work. (I figured it'd be brought up as a suggestion)

    All of this has been happening with 2.2.3.341 as well as 2.2.3.344

    Honestly at this point I'm just lost on how to fix this. My theory is that there might be a leftover/rogue process not fully being terminated when I close GMS2, and that's affecting it when I open it again - but it's just a theory.
     
    Last edited: Sep 3, 2019
  2. curato

    curato Member

    Joined:
    Jun 30, 2016
    Posts:
    384
    I would look to see if any windows updates installed the same time your started having the issue, If, so remove them and reinstall. Also, you make want to try uninstalling and reinstalling gamemaker to eliminate any possibility a file might have been corrupted or something.
     
  3. Barvix

    Barvix Member

    Joined:
    Jun 21, 2016
    Posts:
    193
    I have reinstalled Game Maker, I forgot to mention that in my original post. I'll see if I can downgrade Windows a bit and see if that does anything
     
  4. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,452
    Are you running Windows 10?
    If so I can confirm that GMS2 runs fine on the latest version with all current Windows Updates installed, so I don't think it will be that.

    It's possible it may be a hardware specific thing, but more likely a software issue with something maybe preventing a process closing properly (as you mentioned) or locking files on the hard drive preventing file access or something similar.

    Do you have any AV / system protection software that may be interfering in this regard?
    Sometimes it's installed by default (especially on name brand laptops) without you having to have installed it yourself or having any knowledge of it.

    Also have a look to see that your drivers are up to date for your machine, especially any chipset drivers or IDE/SATA controller drivers.

    Lastly - are you running GMS2 through Steam?
    If so I have seen other reports of Steam reporting that GMS2 is still open even after it has been closed, but that was giving a different error message that you are reporting but might be worth looking into.

    Have a look through the process list after you close GMS2 and see if any remain that should have been closed down, both for the main GMS2 process and the compiler as I have had it before where the compiler gets stuck and I've had to close the process manually to get things running smoothly again.
     
  5. Yal

    Yal GMC Memer GMC Elder

    Joined:
    Jun 20, 2016
    Posts:
    3,556
    If you can't kill a program that refuses to stop with the task manager, you might wanna get the SysInternals Process Explorer, which is basically a better version of the task manager (SysInternals is part of Microsoft and seems to do all those dangerous programs normal users can't be trusted with). It lets you see the actual processes that are run instead of their app front-ends, so you can kill processes that aren't tied to an open window and some other fun stuff. (Just be careful not to accidentally destroy your computer with it)

    And if you do figure out what process (if any) refuses to die, you might wanna write a bug report about it and include that information.
     
  6. Barvix

    Barvix Member

    Joined:
    Jun 21, 2016
    Posts:
    193
    It is running through Steam, I actually didn't even consider that to be related to the issue. Lemme run some tests with that and see where that goes

    Edit: Restarting Steam didn't help, I kinda hoped it would. And Process Explorer isn't showing anything related to GMS2 being open. I'm gonna download GMS2 separate from Steam and see if that helps.

    Edit 2: Installing the non-Steam version helped. At least that version can run the game, even after restarting GMS2. I'd still like to know why the Steam version is messed up, but at least I have a fix. thanks guys!
     
    Last edited: Sep 4, 2019

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice