• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

OFFICIAL GMS2 Version 2.3.1 (Beta Release)

rmanthorp

YoYo Games Staff
Admin
YYG Staff
Release Notes

Runtime Release Notes


This topic is for the discussion of issues relating to the update of GameMaker Studio 2. However, this does not replace our normal bug reporting system and you should report all bugs as normal using https://accounts.yoyogames.com/contact-us


You should post here if:
  • Something has changed between the previous version and this one, breaking your game (ie: code that worked previously now does not)
  • Something reported as fixed in the release notes is not actually fixed
  • You are having IDE or system issues related to something new in this update
  • You are having issues with new features introduced in this version
  • You are having issues updating to this version
  • Everything works and you want to tell us we are great (seriously, let us know if it all works correctly for you)
When reporting issues, please try to add as much information as possible, for example:
  • If the issue is with the IDE, then please give a screenshot if you can to help illustrate the problem
  • If there are error windows, then a link to the "ui.log" file found in the ProgramData folder for GMS2
  • If it is a code issue, then link to or attach a YYZ showing the most basic project possible which exhibits the behaviour
  • If you receive any error dialogues, please screenshot them
  • If it is a system issue (like compiling to a specific target) then please provide details of the PC being used as well as the software versions involved
Again: posting a comment in these release threads is not a replacement for filing a bug!
 

Dan

YoYo Games Staff
YYG Staff
Known Issues (these will also be added into the bug-reporting page tables tomorrow)

  • Renaming a DND script will wipe its contents
  • "Add Existing" and picking any asset which references a sprite will cause GMS2 to go unstable (so that includes rooms, objects which have a sprite assigned, tilesets, etc.)
  • Mac YYC is not working properly, as currently it fails to find provisioning profiles.
  • Desktop browsers are not determining the correct mouse button being clicked, and instead always return that it's the left mouse button version
  • Chrome/Chromium-based desktop browsers are not playing audio, as the audio context does not get triggered properly (other browsers will still play the audio)
  • Should you still have a project which fails to convert and then says files are missing, you will need to restart GMS2 before other projects will open properly - you will see if you don't do this, then you remain on the Start Page as if the good project didn't load properly
  • None of the new translations for 2.3.1 additions are in yet (though you should find that the things new in 2.3.0 which weren't translated are now)
  • In the Mac IDE only, the Debugger doesn't show values for any Watches
  • Same as in 2.3.0, Included Files in subfolders are listed repeatedly in the project file
  • Same as in 2.3.0, instance creation code is not inherited when creating child rooms
  • Same as in 2.3.0, resetting an instance variable override in the room editor doesn't immediately mark the project as needing to be saved, so if you immediately build the game you won't see any change
  • Same as in 2.3.0, following a conflict all source control interactions return exceptions until the conflict is resolved by you outside of GMS2
  • Same as in 2.3.0, some projects may appear to stall on "Found project format 2" line in the output log and write out "Long write request" lines in your ui.log. [Correction from the current release notes!]
  • And I am aware I mistakenly wrote ( in one place in the release notes instead of {
 

Khao

Member
Bezier curve support and improved the dopesheet
Introduced new functions to scale/rotate your sequence
Added a Preference to disable code-folding
Okay what the hell that's literally every single complaint I had from 2.3.

I don't even need further updates. Game Maker is done.

EDIT: Hold-up, x64 out of nowhere?! It really is done omg what the hell.
 

kupo15

Member
Wow we can compile to 64 bit now!?? That is amazing news, RAM now is increased past the 2GB cap now...wow (still capped by your VRAM of course).

I see they fixed the sprite_prefetch_multi bug I mentioned. I hope that also fixes the sprite_flush_multi bug as well.

Also, I didn't see the image_index wrap around bug in the list. Did I miss it somewhere?
 
Last edited:

Mehdi

Member
But my problems did not get solved.
They said they've solved long compiling by pause on "Found Project Format 2". But it's still there and this seems not changing at all! and it keeps me 30 seconds waiting for a single test each time!

BTW, my project doesnt play at all now! It throws an error for one of my global variables. It did work in previous version with no problem.
 

Mehdi

Member
Known Issues (these will also be added into the bug-reporting page tables tomorrow)

  • Renaming a DND script will wipe its contents
  • "Add Existing" and picking any asset which references a sprite will cause GMS2 to go unstable (so that includes rooms, objects which have a sprite assigned, tilesets, etc.)
  • Mac YYC is not working properly, as currently it fails to find provisioning profiles.
  • Desktop browsers are not determining the correct mouse button being clicked, and instead always return that it's the left mouse button version
  • Chrome/Chromium-based desktop browsers are not playing audio, as the audio context does not get triggered properly (other browsers will still play the audio)
  • Should you still have a project which fails to convert and then says files are missing, you will need to restart GMS2 before other projects will open properly - you will see if you don't do this, then you remain on the Start Page as if the good project didn't load properly
  • None of the new translations for 2.3.1 additions are in yet (though you should find that the things new in 2.3.0 which weren't translated are now)
  • In the Mac IDE only, the Debugger doesn't show values for any Watches
  • Same as in 2.3.0, Included Files in subfolders are listed repeatedly in the project file
  • Same as in 2.3.0, instance creation code is not inherited when creating child rooms
  • Same as in 2.3.0, resetting an instance variable override in the room editor doesn't immediately mark the project as needing to be saved, so if you immediately build the game you won't see any change
  • Same as in 2.3.0, following a conflict all source control interactions return exceptions until the conflict is resolved by you outside of GMS2
  • And I am aware I mistakenly wrote ( in one place in the release notes instead of {
Sorry the bug with :"Found project Format 2" is claimed to be fixed. But It seems not being solved yet, at least for me.
 

Giavapps

Member
I've encountered some regressions already:

1) Sequences sounds keeps playing even when they should not: basically I have a few sound in the Giavapps Logo animation I still hear sounds when switching to the next room, the sequence is a non looping sequence so that shouldn't happen.
2) I was also noticing some weird animation issues: Animation End event is not triggered at the end of the last frame anymore I did a quick test by placing this show_debug_message("IMAGE INDEX: " + string(image_index)); and returns 0.07 so it's broken.
 

kupo15

Member
2) I was also noticing some weird animation issues: Animation End event is not triggered at the end of the last frame anymore I did a quick test by placing this show_debug_message("IMAGE INDEX: " + string(image_index)); and returns 0.07 so it's broken.
They didn't fix that image_index bug? Uhg...that was found pretty early with 2.3 and I thought I heard it was on the list. That's strange
 

Giavapps

Member
They didn't fix that image_index bug? Uhg...that was found pretty early with 2.3 and I thought I heard it was on the list. That's strange
I just runned my game that was working fine in the stable release and I discovered the issues... I don't think this problem is related to image_index but mostly related to when is triggered the Animation End event... as the guys worked on the broadcast message functionality for Sprites they could have broken something else...
 

rIKmAN

Member
This will make a lot of peaple very happy😄
As someone who uses Allman Style, I sat for a good minute just folding and unfolding things with a grin on my face.
but mostly related to when is triggered the Animation End event...
What platform are you testing on?
I just did a quick test on Windows and the Animation End Event was fired as expected, but that doesn't mean there isn't an issue on the other targets such as mobile or HTML5 etc.
 

Giavapps

Member
As someone who uses Allman Style, I sat for a good minute just folding and unfolding things with a grin on my face.

What platform are you testing on?
I just did a quick test on Windows and the Animation End Event was fired as expected, but that doesn't mean there isn't an issue on the other targets such as mobile or HTML5 etc.
Windows VM as platform... if you just try to image_speed = 0 in the Animation End event you see it stops to the first frame of the animation which is wrong, it should stop to the last frame... let me know... ;)
 

rIKmAN

Member
Windows VM as platform... if you just try to image_speed = 0 in the Animation End event you see it stops to the first frame of the animation which is wrong, it should stop to the last frame... let me know... ;)
Ah, you didn't mention image_speed in your post, I just checked that the Animation End Event was firing as your post made it sound like it wasn't firing at all.

Not sure if it's a bug though, as for the event to fire it would have to roll over past the last frame, so setting image_speed = 0 at that point would lock it at whatever frame it had rolled over to - the first frame in your case.

If you add image_index = image_number-1 after you set the speed to 0 in the event you should get the result you want of it being stopped on the last frame.

Maybe report it as a bug and see what YYG say though.
 

Giavapps

Member
Ah, you didn't mention image_speed in your post, I just checked that the Animation End Event was firing as your post made it sound like it wasn't firing at all.

Not sure if it's a bug though, as for the event to fire it would have to roll over past the last frame, so setting image_speed = 0 at that point would lock it at whatever frame it had rolled over to - the first frame in your case.

If you add image_index = image_number-1 after you set the speed to 0 in the event you should get the result you want of it being stopped on the last frame.

Maybe report it as a bug and see what YYG say though.
I did like that for now... seems to work that... but the sequence issue really not sure about that... the same problem happens when you drag the game window while playing the sequence... the sounds keeps looping...
 

Amon

Member
Importing a project from 2.3 to 2.31 causes an issue with room ordering. I think. Basically after importing, I'm unable to set room order because none of the rooms imported are available in the room managers room order tab. They all appear in the room inheritance tab. The only way to fix it is to duplicate each room. Is this a bug or am I doing something stupid?

[EDIT] ****** I filed a bug report. I got a quick response that it was a confirmed, reproducible bug and will be fixed next update.
 
Last edited:

FoxyOfJungle

Kazan Games
It would be interesting if in the animation curve editor, in a future update, have some pre-defined ones, like what we have here 🤔
 
Last edited:

gnysek

Member
I see that nobody mentions weak references. But those are ideal for garbage collecting ds structures!

Here's my dirty and fast example (I didn't searched yet that it's possible to use [? "xxx"] syntax this way):

GML:
global.__weak_ds_observer_cnt = 0;
global.__weak_ds_observer = ds_map_create();

function weak_map_gc() { // call this in step event of some global object
    var _arr = [];
    var _keys = ds_map_keys_to_array(global.__weak_ds_observer, _arr);

    for(var i = 0; i < array_length(_keys); i++) {
        if ( !weak_ref_alive(global.__weak_ds_observer[? _keys[i] ][0]) ) {
            ds_map_destroy(global.__weak_ds_observer[? _keys[i] ][1]);
            ds_map_delete(global.__weak_ds_observer, _keys[i]);
        }
    }
}

function ds_map() constructor {
    _dsid = ds_map_create();
    global.__weak_ds_observer[? global.__weak_ds_observer_cnt ++ ] = [weak_ref_create(self), _dsid];

    add = function(key, val) {
        ds_map_add(_dsid, key, val);
    }

    set = function(key, val) {
        return ds_map_set(_dsid, key, val);
    }

    /// @desc return whether key was existing or not
    replace = function(key, val) {
        return ds_map_replace(_dsid, key, val);
    }

    remove = function(key) {
        ds_map_delete(_dsid, key);
    }

    clear = function() { ds_map_clear( _dsid ); }

    empty = function() { ds_map_empty( _dsid ); }

    size = function() { return ds_map_size( _dsid ); }

    toString = function() {
        return json_encode(_dsid);
    }
}
Also, I love array_sort(); array_delete(); array_push(); array_pop(); functions, structs to JSON and JSON to struct conversions (json_stringify(); json_parse();, and I believe that many wanted variable_struct_remove(); :)
 
This beta is immediately crashing (GMS has become unstable and must close) when I attempt to load my project (created in previous beta version). Is it possible to download the previous beta installer?
 

gnysek

Member
This beta is immediately crashing (GMS has become unstable and must close) when I attempt to load my project (created in previous beta version). Is it possible to download the previous beta installer?
Previous beta and stable are same versions (different numbers only).
 
Previous beta and stable are same versions (different numbers only).
The stable and previous beta can't be the same version as I have both the stable 2.3 and the current beta 2.3.1 installed and I've updated the 2.3.1 beta a couple of times. This latest 2.3.1 beta is the one causing the trouble. The previous 2.3.1 beta was fine. I tried opening my project in 2.3 stable but I have the empty room order issue in that version and it seems that the room order is invalid so my project will not compile. Its most frustrating.
 
I was running v23.1.175 IDE with runtime v23.1.1.166. I assumed that translated as 2.3.1. If that's not the case then - my mistake. I've managed to return to this version so that I can keep working on my project until I hear back from yoyo support as to why the IDE crashes when I try to open my project.
 

gnysek

Member
The stable and previous beta can't be the same version as I have both the stable 2.3 and the current beta 2.3.1 installed and I've updated the 2.3.1 beta a couple of times. This latest 2.3.1 beta is the one causing the trouble. The previous 2.3.1 beta was fine. I tried opening my project in 2.3 stable but I have the empty room order issue in that version and it seems that the room order is invalid so my project will not compile. Its most frustrating.
Official beta wasn't updated since 23.1.1.175 (until now) and this version was equal to 2.3.0.529 from what I remember. If you use some internal channel (YYG gives it for some of helpdesk issues) - then of course this is not valid. I'm talking specifically about Stable and NuBeta channels only.
Also, beta is not meant for usage in projects, but for tests only, they mentioned it.
 
Last edited:

Dan

YoYo Games Staff
YYG Staff
They said they've solved long compiling by pause on "Found Project Format 2". But it's still there and this seems not changing at all! and it keeps me 30 seconds waiting for a single test each time!
My apologies - that one is not fixed yet. It was just part of the release notes list and I obviously missed removing that one. (You can see that it's still Reported on the bug-reporting page table.) I will add it to the list at the top of this thread also. Thanks for highlighting.

Was the forum to discuss the Beta release discontinued?
Yes - that was only during the development of 2.3.0. We're now back to the regular "release thread for discussions/feedback and filing tickets if you have bugs with samples".

I'm getting this error when installing Runtime 23.1.1.187 on Mac OS X Mojave, after whch the IDE freezes:

View attachment 34796

It resolved itself after I installed the version from mono-project.com, but please check the Runtime download to avoid needless support requests later.
Thanks - we don't have other reports of this yet, but we will be aware of it and I will also add it as a note onto the Required SDKs FAQ so we can call it out on the bug-reporting page.
 
Last edited:

Mehdi

Member
My apologies - that one is not fixed yet. It was just part of the release notes list and I obviously missed removing that one. (You can see that it's still Reported on the bug-reporting page table.) I will add it to the list at the top of this thread also. Thanks for highlighting.
Thank you Dan. You're Amazing
:)
 

Tornado

Member
@Dan, I filed a report on 30th September (with a sample project) on GC crashing the application, but still no response.
Ticket: 176061
 
Hmm unfortunately we don't have improvements in the autocomplete regarding methods:

1) use JSDoc to deliver information on context
2) handling different functions with same name

BUT...weak references is a huge PLUS ;););)
And those new array functions.. love them.
 
Last edited:
Top