1. Hello Guest! It's with a heavy heart that we must announce the removal of the Legacy GMC Archive. If you wish to save anything from it, now's the time! Please see this topic for more information.
    Dismiss Notice

OFFICIAL GMS2 Version 2.2.1 (FULL RELEASE)

Discussion in 'GameMaker Studio 2 Community Tech Support' started by rmanthorp, Dec 5, 2018.

  1. Thylacine Studios

    Thylacine Studios Member

    Joined:
    Jan 27, 2017
    Posts:
    63
    Everything was working fine for me in 2.2.0, but as of 2.2.1, whenever I change rooms, it seems like my camera is destroyed or something. The view changes to the top-left-most corner of the room and everything is zoomed way out. Anyone else having this issue?

    An example:

    In the first room, __view_set(e__VW.WView, 0, 640) works fine.

    After switching to another room, that compatibility script no longer works because it seems as though that view doesn't exist anymore.

    Also, view_get_camera returns -1 for all index (0-7) after leaving the first room, but it works just fine before that.
     
  2. Chaser

    Chaser Member

    Joined:
    Jul 29, 2016
    Posts:
    122
    Unable to download update, Gamemaker tells me to 'Abort' as file wont open for writing. retry does nothing and dont think i should skip a file?
     

    Attached Files:

  3. BPzeBanshee

    BPzeBanshee Member

    Joined:
    Dec 6, 2016
    Posts:
    9
    I've put in bug reports for two major problems I've seen this release:
    - font_add_sprite spacing seems to be completely broken compared to last release and GMS 1.4.9999
    - YYC compiling includes data.win and barely changes in filesize, the builds work but I'm not convinced it's working as intended

    On the plus side, as someone having issues with all GMS2 apps gamespeed prior to this update I can confirm the fix for that is doing nicely and I am finally seeing fps_real values closer to what I was getting before migrating.

    Here's hoping YoYo get regression fixes in before Christmas.
     
  4. HW.

    HW. Member

    Joined:
    May 21, 2017
    Posts:
    207
    Just installed the 2.2.1 full release!

    IDE v2.2.1.375 and Runtime v2.2.1.287

    Woohoo...... I had been waiting for it to be out of beta, and finally it is :)
    note: i didn't taste the beta so this is my first taste of the 2.2.1.

    SO FAR with my sample testing project (only some square box graphics without sounds btw, and few simple scripts and extension)

    Overall the new IDE and runtime is working good for Android, but with some notes:

    Firstly, the good things:

    1. Many thanks for YYG team, Thank you for the full Adaptive icons on IDE!
    It is working as it should be. (my review for the upload part, i didn't use the "generate" because i don't need it, already prepared all the files outside of ide btw)
    Now it is easier to do it easily compared to doing the manual injection trick as in 2.1.5/2.2.0.
    Well done!

    2. Thank you for making the recommended use of the NDK 18b , upgraded from 17c, which is so far the latest stable release of NDK for the YYC build according to the official Android NDK page.
    (This really matters to me as i never... ever use a VM for the .apk for production release, i always use YYC, that's why!)

    3. Thank you for other improvements and enhancements of other features which i might not know but will be using it.

    And, the minus things i found?

    1. I never ever use gamepad for my Android project (because targeting only for phones and touchscreen),
    in my whole case, i never turn on it on the 2.2.0- version since GMS1 to GMS2, and never want to use it. (i know it can be useful for other Android users that has the needs)
    I read from the release notes that its setting is changed now, which is generally not my business, as i don't use it... BUT..
    BUT...
    when i tick the "Lint report" (i always tick it to know what happens if build failed)
    -- i don't know if unticking it will not produce the following problems or not??:

    Here is the problem: (read below)

    Using the NDK 18b, build tools 28.0.3, and target/compile API 28 and minimum API 16..
    will make the BUILD FAILED in my case!
    with the hints from the lint report saying about "new api use of gamepad bla bla bla that needs API 19, and you use min 16 bla bla bla..."

    so that is the problem: the gamepad things (although i don't use it at all on settings, and it seems it has been disappeared on the usual spot)
    that prevent me to get successful build.

    MY SOLUTION: i follow the Lint suggestion, and change my min API 16 to API 19. Because it seems that YYG now use the newAPI for it , idk.

    Because the API 16 (year 2012) is for the Jelly bean devices and the API 19 (year 2013) is KitKat devices....
    And now it is almost in the end of 2018 (2019 soon) which most new released devices are on API 26+ oreo... 27.. 28.. so on..

    and... almost none of my players use the old API 16 devices anymore...
    so.. I don't mind to change my min API from api 16 to API 19 o_O to have a BUILD SUCCESSFUL result, and grab my .apk file!

    2. Although changing the min API to 19 is successful to bypass the gamepad newApi errors (there are 3 errors stated on the Lint related to that),
    Lint reports still has about other 60 warnings talking about obsolete or outdated implementation of the java codes.
    I hope YYG team want to tweak these things. It has been piling up since GMS1. (Lint reports , severity warnings and some errors like the API16/19 gamepad above, etc)

    so the Recap:

    overall it is better than the 2.2.0- for the YYC build
    (SO FAR, for my simple testing project, don't know for my more complex projects, i'll see next..)

    my YYC android build which has success is... (which is as recommended on the GMS2 required SDKs page , except the min API 16, i use 19 from now)
    uses the following settings:
    - NDK 18b (i upgrade from 17c used on 2.2.0)
    - build tools 28.0.3
    - support 28.0.0
    - API target/compile 28
    - minimum api 19 (up from 16 because of that gamepad problem checking from lint......, idk if turning off will get sucess, but i choose to use 19 instead because 16 is also already too old)
    - abi setting is armv7 and arm64.

    I hope this post is helpful for other Android module users that might have problem similarly to my case! ;)

    Thank you YYG team!

    @Dan thanks for the GMS2 required SDKs page, it is clearer now and has also a new screenshot of the API target/compile/min/support.

    Keep it up the great work guys! :D
     
    Last edited: Dec 10, 2018
    Pushloop, Andrey and Guest like this.
  5. chmod777

    chmod777 Member

    Joined:
    Aug 26, 2016
    Posts:
    217
    Note for HTML5 users that this should also apply to Firefox soon (at least for compressed sounds), as Nightly builds now show this in the console:
    Autoplay is only allowed when approved by the user, the site is activated by the user, or media is muted.
     
  6. Heathenlamb

    Heathenlamb Member

    Joined:
    Jul 14, 2016
    Posts:
    53
    New version has completely f**cked my project. I am pretty sure it is the new save system. I do all my work over a network. After I updated and installed the new version it started throwing errors every time I loaded a project. I didn't think much of it because everything still seemed to work. It would say something like "Problem loading game - Reload or Save" ... I would hit save and continue on. This morning the project has loaded. All the objects are placed in the room but when I compile the game none of the objects appear in the game. The objects menu is greyed out in the IDE and all the objects are listed separately in the IDE ???? I really need help to get this sorted ASAP ... I have a client waiting on the project atm which I was delivering today. I always save multiple backups of projects but they are all doing the same thing.

    [​IMG] [​IMG]


    How do I roll back to a previous version ?
     
  7. Binary Orange Studios

    Binary Orange Studios Member

    Joined:
    Mar 26, 2018
    Posts:
    21
    Looks like you've learned a pretty valuable lesson - never upgrade software if you're working on a client-based project, that needs to be delivered the same day, or even just days away. Always a bad idea!

    Also, please tell me you did not open each and every one of your backups in the new version of the IDE? If you did, I'll bet good money that previous versions of GMS 2 may not be able to read them, since it seems they've been corrupted.

    As for how to roll back the runtime, I found this thread after a quick search.
     
  8. Heathenlamb

    Heathenlamb Member

    Joined:
    Jul 14, 2016
    Posts:
    53
    Unfortunately I am in a permanent cycle of developing for clients so I have to upgrade at some point. I will freely admit I dropped the ball on this one. This was just meant to be a version update for the client so I didn't think it would be an issue. As to rolling back to previous version. I have the previous runtime ... I have uninstalled and purged my system of the current IDE ... however when I install the older run time it still maintains I have installed the current version ... what is that all about ?
     
  9. Binary Orange Studios

    Binary Orange Studios Member

    Joined:
    Mar 26, 2018
    Posts:
    21
    Ah, I see. Apologies if my original response came off harsh, wasn't meant to be but after re-reading it I grew afraid it may be misconstrued.

    Anyway, I'm not sure what more to say or try, as I haven't had to roll GMS 2 back yet... but the only thing I can think of is, did you restart your computer after uninstalling GMS 2 and the runtime? If so, and the problem persists, if you look under programs, is there anything still GMS related there that shouldn't be?
     
  10. IndianaBones

    IndianaBones Member

    Joined:
    Jul 5, 2016
    Posts:
    2,313
    If you haven't tried already, check in Preferences->Runtime Feeds and double-click on the runtime you want to use to enable it.
     
  11. Heathenlamb

    Heathenlamb Member

    Joined:
    Jul 14, 2016
    Posts:
    53
    Thanks for the tips guys, much appreciated. Changed the runtime feed. Makes no difference now. Previous IDE/Runtime ... The project files are doing the same thing now. Objects are not compiling into the room. Object resource tree menu not working. I am going to go through it with a fine tooth comb and see if I can get around whatever the f**k has happened.

    EDIT -------

    I have logged a bug report. But I am at a loss. I have loaded other unrelated projects and they are fine. It appears to have affected only this one project. Doesn't matter if I delete, add, remove or create new objects. None on them appears when I run or compile the game.
     
    Last edited: Dec 11, 2018
  12. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    419
    Did you see this in the release notes, could be the cause:
    • Fixed a number of project-saving and stability issues with the resource tree, especially if you had created custom tree views in your projects
    • Added a new system to detect projects which have been corrupted by this issue and GMS2 will now offer to fix the project for you during a project load
    • Note: We would suggest choosing "No", then immediately closing GMS2 and taking a backup of the project first, then load the project again and say "Yes"
    You would need a back up that you didnt open in the new version...
     
    Last edited: Dec 11, 2018
  13. Erayd

    Erayd Member

    Joined:
    Jun 23, 2016
    Posts:
    135
    I've noticed studio has been crashing a lot lately where it never crashed for me before. I haven't put a lot of time in to debugging this, but this is what has happened so far:

    • My workspace doesn't save the open windows on reload of the program
    • Hitting 'Import' on a sprite crashed/froze the IDE
    • Swapping between another project and my main one, then clicking on 'windows' under 'options' freezes and crashes the IDE
    • When in full screen in a game and pressing Alt+Tab to get out, I can then not select or do anything to the IDE sometimes. After that, every click I do brings a window from the back to the front and it looks like GM start eating up a ton of processing.
    This is all after downloading/installing the latest runtime/update.
     
  14. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    295
    I may be wrong, but I believe that the parsing of the various file formats gm uses, is an IDE thing. If that's the case then your best bet is to open an untouched version of your project (as already mentioned) in the specific IDE version you used to develop it.
     
  15. Heathenlamb

    Heathenlamb Member

    Joined:
    Jul 14, 2016
    Posts:
    53
    Yes ... unfortunately I dropped the ball there and have tainted all my backups. As to the IDE freezing/crashing, I too have started experiencing that since the latest update. Freezes when closing compiled games, freezes when saving projects, freezes when opening projects. I have to force quit a few times a day.
     
  16. kakatoto

    kakatoto Member

    Joined:
    Aug 22, 2017
    Posts:
    36
    Those "updates" of GMS2 are very painfull. That is why I decided to move to Unity.
     
  17. kakatoto

    kakatoto Member

    Joined:
    Aug 22, 2017
    Posts:
    36
    Try this. It worked for me a few months ago when another weird update occured.

    1°) Download GMS2 Ressource importer
    2°) Create a new empty project with the old runtime that worked for you
    3°) Import all your ressources in this new project

    Good luck.
     
  18. Better Nature

    Better Nature Member

    Joined:
    Dec 8, 2016
    Posts:
    21
    Since the update, I'm having an issue related to surfaces similar to Satori, but not quite the same. I get this error immediately when running my game:
    It doesn't give any indication of where this problem is popping up in code (which is kind of useless. Hopefully this can become more specific in a future update).

    I read through the new post on "Using Surfaces" and I don't seem to be violating any of the pitfalls mentioned there. I also tried the solutions suggested so far in this thread without any success. Here's my code.

    This code is in my visual controller object. It handles the day/night cycle and other full-screen visual effects.
    Pre-Draw
    Code:
    application_surface_enable(false);
    
    //Check for Active Shader
    if(global.shader)
        {
        #region //Draw Day/Night Shader
        if(global.rewind != true)
            {
            // Day / Night Shader ON
            var night_cycle_on = obj_nightcycle.night_cycle_on;
            if (night_cycle_on == true)
                {
                var rdiv, gdiv, bdiv;
           
                rdiv = obj_nightcycle.rdiv;
                gdiv = obj_nightcycle.gdiv;
                bdiv = obj_nightcycle.bdiv;
                surface_set_target(application_surface);
                shader_set(shd_night);
                application_surface_draw_enable(true);
                shader_params_r = shader_get_uniform(shd_night,"u_rdiv");
                shader_params_g = shader_get_uniform(shd_night,"u_gdiv");
                shader_params_b = shader_get_uniform(shd_night,"u_bdiv");
                shader_set_uniform_f(shader_params_r,rdiv);
                shader_set_uniform_f(shader_params_g,gdiv);
                shader_set_uniform_f(shader_params_b,bdiv);
                }
            else
            // Day / Night Shader OFF
                {
                application_surface_draw_enable(true);
                }
            }
        #endregion
        #region//Draw Rewind Shader
        else
            {
            surface_set_target(application_surface);
            shader_set(shd_rewind);
            application_surface_draw_enable(true);
            }
        #endregion  
        }
    //No Shader
    else
        {
        application_surface_draw_enable(true);
        }
    Draw End
    Code:
    //End Shader Effects -------------------------------------
    if(global.shader == true)
        {
        shader_reset();
        if(surface_get_target()!=-1) surface_reset_target();
        }
    The below code is in my depth ordering object. It controls the order in which objects and tiles are drawn, and controls effects that don't apply to the entire screen. The effect in question is my water effect.

    Draw
    Code:
    //Draw Water Effects ---------------------------------------------------------
    if(water_on == true)
        {
        //create water surface 1
        if(!surface_exists(surf_water)) surf_water = surface_create(room_width,room_height);
    
        surface_set_target(surf_water);
        draw_sprite(w_depth,0,0,0);
    
        gpu_set_blendmode_ext(bm_dest_alpha, bm_zero);
        draw_sprite_tiled(spr_water_ripples_02,0,w_x,w_y);
        gpu_set_blendmode(bm_normal);
        if(surface_get_target()!=-1) surface_reset_target();
    
        if(surface_exists(surf_water)) draw_surface(surf_water,0,0);
        }
    Room End
    Code:
    if(!surface_exists(surf_water)) surface_free(surf_water);
    if(!surface_exists(surf_water_2)) surface_free(surf_water_2);
    I believe this is all my code that uses surfaces. I will keep looking through my game project, but for now, I'm really not sure what the problem is, or if I am even looking in the right spot. The error message is so non-specific. Any input would be greatly appreciated.
     
  19. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    174
    Anyone else having issues with parents (and possibly collisions but could just be to do with the parents) with Runtime 2.2.1.287?

    My wall objects that all use a single parent object called par_solid were affected. Par_solid itself was fine but objects (like breakable walls) no longer stopped the player walking through (yet sometimes stopped enemies oddly enough) I thought it was something I did in my project and spent hours trying to fix to no avail so I switched to another project that was working absolutely fine before and that was having issues too despite me not having changed a darn thing in it. I switched to Runtime 2.2.1.261 to test and the wall objects in both projects were behaving as they should and the project I had wasted hours on this morning was working perfectly again. :/
     
  20. Thylacine Studios

    Thylacine Studios Member

    Joined:
    Jan 27, 2017
    Posts:
    63
    Same issue for me. I've found that if I place the objects in the room manually via the room editor, they work fine, but if you create them dynamically with code, this issue happens.
     
    Carnivius likes this.
  21. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    174
    Yeah all my solid wall objects are placed down within the game (reading the tile value for which object to place down) but only the main 'par_solid' works and the others like 'par_break' do not. I'm sticking with Runtime 2.2.1.261 til it gets sorted.
     
  22. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    419
    This is not a whole answer but the runtime release notes state status as solide/existance of collision events now influence collisions:

    full notes here: http://gms.yoyogames.com/release-notes-runtime.html
     
  23. Thylacine Studios

    Thylacine Studios Member

    Joined:
    Jan 27, 2017
    Posts:
    63
    I found a solution for now. It's not very clean, but if you nudge all your objects by 1 pixel (x += 1 or something similar) and then nudge it back in a different step (x -= 1), everything will work correctly.
     
  24. gnysek

    gnysek Member

    Joined:
    Jun 20, 2016
    Posts:
    1,313
    Last edited: Dec 19, 2018
    Nettub likes this.
  25. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    174
    Oh great. Game breaking changes. Is there a tutorial that explains how to 'fix' things cos this is beyond me


    Thanks but that's not really a solution. More a bit of sellotape trying to keep it together and I'm getting a headache even trying to think how to apply that to everything and make it not noticable during run-time
     
  26. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    347
    That's runtime 2.2.1.291 released now. This release has a number of important collision fixes, plus implements our workarounds for Android build tools now failing to be found - http://gms.yoyogames.com/release-notes-runtime.html

    You should have a runtime update notification next time you start GMS2. If you're using the IDE just now and want to update asap, File > Preferences > Runtime Feeds > Master, click the refresh button.
     
    Guest likes this.
  27. JeffJ

    JeffJ Member

    Joined:
    Jun 20, 2016
    Posts:
    342
    @Dan Aren't those pretty much exactly the same release notes from 2.2.1.287 released on december 5th?

    The release notes are all messed up right now, claiming that 2.2.1.287 does not exist, and that this one on december 19th is the only runtime update release in december?
     
  28. bluetrack

    bluetrack Member

    Joined:
    Jun 21, 2016
    Posts:
    51
    Hi, Trying to build for Android and geting the error below. (IDE: v.2.2.1.375, runtime v.2.2.1.291)

    FAILURE: Build failed with an exception.

    * What went wrong:
    Execution failed for task ':GameCircleSDK:lint'.
    > Lint found errors in the project; aborting build.

    Fix the issues identified by lint, or add the following to your build script to proceed with errors:
    ...
    android {
    lintOptions {
    abortOnError false
    }
    }
    ...
     
  29. bluetrack

    bluetrack Member

    Joined:
    Jun 21, 2016
    Posts:
    51
    After removing the Amazon extension the problem changed to the following:

    if (Gamepad.msMogaDevice == null) {
    ^
    symbol: variable msMogaDevice
    location: class Gamepad

    I cleared all caches and there is now no tick box for Moga gamepad anyway. How do I fix this? There are several messages all refering to MogaDevice.
    Thanks.
     
  30. DukeSoft

    DukeSoft Member

    Joined:
    Jun 20, 2016
    Posts:
    783
    2.2.1.291 seems to break 144hz support again.

    Game runs at 144fps on 60fps monitor, but random speeds (i've seen 60-65, 120-122) on 144hz monitor.
    Everything lower than 144fps runs fine on both 60hz and 144hz monitor.
     
  31. bluetrack

    bluetrack Member

    Joined:
    Jun 21, 2016
    Posts:
    51
    OK, I just realized there was also the "Moga" extension still installed. I deleted it, cleaned up the cache and now everything is fine. :)
     
  32. ZeDuval

    ZeDuval Member

    Joined:
    Jun 20, 2016
    Posts:
    118
    I'd like to know about this, too. And I've got also one follow-up question: What about the getter counter-counterpart - setter functions?
     
    gnysek and Nettub like this.
  33. gnysek

    gnysek Member

    Joined:
    Jun 20, 2016
    Posts:
    1,313
    I asked on twitter, and:
    - getters are draw_get_font etc.
    - "new export" will be next year
    - "Nintendo matchmaking" seems to be there, but as it's for console users, and this export requires you to have licence from Nintendo, this is internal, so there won't be much info about

    page is now updated: https://help.yoyogames.com/hc/en-us/articles/231719448-RoadMap
     
  34. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    347
    Yes, the bulk of that page is the same - the only change is the new section at the top of the list calling out explicitly what changed in that release and I also took the opportunity to add in a mention that Windows YYC now creates a data.win, as we'd had a number of tickets asking about this change.

    You are correct that we accidentally removed the 287 revision when copying over the release notes for this build. I'll get that looked into.
     
    JeffJ likes this.
  35. sman

    sman Member

    Joined:
    Jun 28, 2016
    Posts:
    121
    Tried to compile YYC Android with last IDE/runtime.

    "System.Exception: Error : The selected Architecture options do not support this device. Please add Armv5"

    But... there is no longer Armv5 in the options! :confused:
     
    etbunce likes this.
  36. SnortySnoopy

    SnortySnoopy Member

    Joined:
    Apr 25, 2018
    Posts:
    219
    Is the steam purchased version still on IDE v.2.2.1.375 and Runtime v.2.2.0.261? Is that new runtime v.2.2.1.291 currently only limited to GMS2 purchased from yoyogames.com?
    Because it's been awhile since I read the update info, and still no offer to update the runtime under preference.

    Edit:
    Does it also resolved the Google removed gradle that was informed sometimes ago?
     
    Last edited: Dec 21, 2018
  37. markfe

    markfe Member

    Joined:
    Jul 13, 2018
    Posts:
    36
    Hi there,
    I'm on v2.2.1 for a while now...
    It fixed all my issues (mostly sound related). Everything else also works like charm.
    I think the new Beta Channel was a great idea.
    Thank you! Great update, great software. Keep up the good work!
     
  38. Cloaked Games

    Cloaked Games Member

    Joined:
    Jul 4, 2016
    Posts:
    819
    Oooh kay. This update did cause my sprite font separation to be wider. Lowering the sep value from what it was before fixed the issue.

    Just glad there's an explanation. I thought I was going mad. It took me 20 hours of working on the project before I even noticed because it was totally possible I made some text a little too long and hadn't noticed before...

    So odd. If it gets fixed to the behavior from before this update, please make sure to note it so I can change it back.

    EDIT: It seems, at least for me, that the behavior has something to do with adding a minimum spacing between characters? I had a sep value of 2 pixels, but after this update there were 4 pixels between. If I set it to 0 it has 2 pixels again.
     
    Last edited: Dec 23, 2018
  39. rnisson

    rnisson Member

    Joined:
    Sep 25, 2017
    Posts:
    34
    I am getting an error with this most recent runtime and the 12/9/2018 runtime while building for Android, it still builds properly with the old runtime from 10/9/2018:

    '
    :com.company.game:incrementalDebugJavaCompilationSafeguard UP-TO-DATE
    :com.company.game:compileDebugJavaWithJavac
    Full recompilation is required because 'RunnerActivity.java' was changed. Analysis took 0.05 secs.
    W:\com.company.game\src\main\java\com\company\game\Gamepad\MogaDevice.java:40: error: cannot find symbol
    Gamepad.msMogaDevice = this;
    ^
    symbol: variable msMogaDevice
    location: class Gamepad
    W:\com.company.game\src\main\java\com\company\game\Gamepad\MogaProDevice.java:43: error: cannot find symbol
    Gamepad.msMogaDevice = this;
    ^
    symbol: variable msMogaDevice
    location: class Gamepad
    Note: Some input files use or override a deprecated API.
    Note: Recompile with -Xlint:deprecation for details.
    2 errors
    :com.company.game:compileDebugJavaWithJavac FAILED
    FAILURE: Build failed with an exception.
    * What went wrong:
    Execution failed for task ':com.company.game:compileDebugJavaWithJavac'.
    > Compilation failed; see the compiler error output for details.
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    BUILD FAILED
    Total time: 12.58 secs
    C:\WINDOWS\system32\cmd.exe DONE (1)
    C:\WINDOWS\system32\subst.exe /d W:
    C:\WINDOWS\system32\subst.exe DONE (0)
    System.Exception: Build Failed
    at Igor.AndroidUtils.(YYDictionary`2 , String , Boolean , String )
    at Igor.AndroidBuilder.Deploy(Boolean _exe)
    at Igor.AndroidBuilder.Run()
    Igor complete.
    elapsed time 00:00:44.6352567s for command "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.1.291/bin/Igor.exe" -options="C:\Users\Rob\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -- Android Run started at 12/27/2018 12:41:51
    "cmd" /c subst Z: /d
    elapsed time 00:00:00.0584234s for command "cmd" /c subst Z: /d started at 12/27/2018 12:42:36
    "cmd" /c subst Y: /d
    elapsed time 00:00:00.0584228s for command "cmd" /c subst Y: /d started at 12/27/2018 12:42:36
    "cmd" /c subst X: /d
    elapsed time 00:00:00.0589227s for command "cmd" /c subst X: /d started at 12/27/2018 12:42:36
    FAILED: Run Program Complete
    '

    any ideas? I tried updating my Android build tools already
     
  40. True Valhalla

    True Valhalla Full-Time Developer GMC Elder

    Joined:
    Jun 20, 2016
    Posts:
    321
    Is there an ETA for the next update? I'm waiting on some important changes to the way fonts are imported from GMS1 projects before fully transitioning to GMS2.
     
    Nettub likes this.
  41. Holger

    Holger Member

    Joined:
    Oct 29, 2018
    Posts:
    1
  42. Heathenlamb

    Heathenlamb Member

    Joined:
    Jul 14, 2016
    Posts:
    53
    GMS is freezing EVERYTIME I click import to replace a sprite. Happens when the existing sprite is PNG format and I want to replace/update sprite. I open the sprite and click import, then GMS just freezes. Have force quit.
     
  43. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    295
    It might be related to this
     
  44. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    419
    I've had explorer crash a few times when inadvertently dragging a large gif (animated) from window across GM 2 IDE (even if not releasing left click). The windows explorer source window freezes and cannot be interacted with. If you wait enough time (several minutes the window may respond again). I know one other who has had same experience with large files. I can't reproduce it consistently so haven't filed a bug. Should I file this?
     
  45. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    295
    Look at the link above, your case might be related too.
    Since this bug can cause crashes/freezes for several reasons, I'm posting the description here in hope that anyone who sees it and feels is affected, doesn't have to file an unnecessary report:

     
  46. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    419
    I guess my question is to YYG - perhaps it is useful to still file so they know the issue (or similar) is affecting more people (bug report says only a single report, clearly is affecting more though...)
     
  47. immortalx

    immortalx Member

    Joined:
    Sep 6, 2018
    Posts:
    295
    It's your call of course, I just wanted to save you some time! However I think you misread "single report". There are a ton of reports about this bug, they just collected them in one. I reported too about a month ago and was told that it will go in there.
     
  48. SnortySnoopy

    SnortySnoopy Member

    Joined:
    Apr 25, 2018
    Posts:
    219
    Curious as to when the runtime 2.2.1.xxx will be made officially available for us using the STEAM purchased IDE?
     
  49. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,763
    Don't know the answer to your question, but in case you aren't aware you are able to use the standalone version even if you purchased on Steam.

    Make sure your Steam account is linked on your profile on the YYG website, download the standalone version and login using your YYG account details.
     
  50. SnortySnoopy

    SnortySnoopy Member

    Joined:
    Apr 25, 2018
    Posts:
    219
    I'm aware that I'm able to download the YYG's source. But wouldn't that mean having more than 1 copy of the software in my hdd needlessly? As is I've to debate daily which to launch for the day; GMS2 mobile icon, or GMS2 desktop icon. Their usage counter displayed in my steam account are differentiated, giving me the impression of owning 2 copies of GMS2 unnecessarily.
     
    Last edited: Jan 20, 2019

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice