OFFICIAL GMS2 Version 2.2.1 (BETA RELEASE)

Discussion in 'GameMaker Studio 2 Community Tech Support' started by rmanthorp, Nov 1, 2018.

Thread Status:
Not open for further replies.
  1. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    165
    Beta IDE Release Notes (Same as Help > Release Notes inside GMS2 once opted-in)
    Beta Runtime Release Notes (Same as Help > Runtime Release Notes inside GMS2 once opted-in)
    Beta Opt-In FAQ (How to get on the Beta Channel)

    This topic is for the discussion of issues relating to the update of GameMaker Studio 2. However, this does not replace our normal bug reporting system and you should report all bugs as normal using http://www.yoyogames.com/bug

    You should post here if:
    • Something has changed between the previous version and this one, breaking your game (i.e.: code that worked previously now does not) and you want to discuss whether this is a bug or not.
    • Something reported as fixed in the release notes is not actually fixed.
    • You are having IDE or system issues related to something new in this update.
    • You are having issues with new features introduced in this version.
    • You are having issues updating to this version.
    • Everything works and you want to tell us we are great (seriously, let us know if it all works correctly for you!)
    Again, posting a comment in these release threads is not a replacement for filing a bug!


    With 2.2.1 beta releases we're especially keen for feedback on the following key areas.

    Runtime Installation Failures:

    • Does 2.2.1 fix the issue your machine had with downloading or installing runtimes in previous releases?

    Project Saving/Loading Issues:

    • Do you find GMS2 more stable to edit and build your projects now?
    • Whilst we still don't recommend it, can you use OneDrive/Dropbox/Google Drive folders for storing your projects and working directly on them?
    • Have any of your projects triggered GMS2's new system to fix projects with certain types of corruption? Did this succeed or fail for your project?

    HTML5 audio changes:

    • Do you now have issues playing your sounds on recent versions of browsers? (We are aware older versions of iOS Safari and Microsoft Edge have issues, but this is the browser, not GMS2.)
    • Is the manual clear on how to implement this new system?

    Game performance:
    • Do you have issues with poor game performance that did not happen in 2.2.0? (We are aware of issues with the show_debug_overlay() FPS value when the game loses focus.)


    Current Release - IDE v2.2.1.374 Runtime v2.2.1.286 (this is identical to 375/287 on the "Stable" channel)

    This update fixes the following:
    0030277: Functions: ds_grid_get() now causes crashes on YYC only when returning strings


    IDE v2.2.1.372 and Runtime v2.2.1.284

    This update fixes the following:
    0030183: Resource Tree: When you clone the default resource view you are unable to see resources in the new view
    0030184: General: buffer_network should be removed from fnames as it's not used currently
    0030204: HTML5: keyboard_string and keyboard_lastchar translate key presses as if the keyboard in use was a UK keyboard
    0030213: UI: After closing the debugger, part of the IDE was blank and refused input / 0028457: UI: Image Editor edit area offset after closing room in next workspace

    And it also introduces the changes to audio initialisation primarily aimed at HTML5, but the events will fire on native platforms also for consistency purposes. This change affects Chrome (including Chromium, Vivaldi, likely Opera), Safari, and Edge. It does not affect Firefox, as that doesn't do the same "permissions" system the others are all now moving to, and instead it just plays all your audio anyway. We're already aware older versions of Edge won't give you any sound and older versions of Safari on iOS stop playing your sounds after a few seconds - all we can suggest here is to update the OS to update those browsers, as this is beyond our control. We're also looking into removing the need to pre-download streamed sounds on iOS and Android for 2.2.2, now that this new browser audio permission system is in place.


    IDE v2.2.1.368 and Runtime v2.2.1.279

    This update fixes the following:
    0030126: Preferences: Spacing for the EULA URL on Beta page is not "clever"
    0030165: General: Release notes pages don't work when viewed using https
    0030180: Importing Projects (2.x): Dragging in a yyz/yyp to import when another project is open can cause "unstable"
    0030181: Resource Tree: Creating Folders sometimes locks the cursor in "reorder" mode
    0030182: General: [Mac IDE] Downloads a Windows .exe when offering Beta Channel IDE updates on startup
    0030215: Variables Window: Specific property on instances in this project don't override their property correctlyFixed the error message shown by surface_resize() when that surface is on the stack to make this coding issue clearer


    IDE v2.2.1.366 and Runtime v2.2.1.277

    This update fixes the following:
    Added in a lot more logging to catch startup crashes and runtime installation crashes - if you have runtime installation issues, please try this version and send us your ui.log file (and the ui_crash.log if you have one)
    Added a system to now attempt the runtime drive mapping and catch if you can't perform this command, this is then logged and GMS2 then fall back to the older non-mapped installation file path method - however, some platforms (typically Android) might have issues, as the file paths for Google's tools can get very long and so exceed Windows' limits.
    We've extended the changed saving system so it will now retry the save/load multiple times over a few seconds if we detect a file is currently locked.
    Fixed the missing manual pages for the new gamepad functions and the new sprite bounding box modification functions. (Bunch of other manual fixes also.)
    Fixed a number of localisation strings being missing or incorrect.
    Fixed that the constant "of_challenge_lose" was broken in the code editor's autocomplete
    Fixed a startup error which meant Microsoft Edge couldn't run debug versions of HTML5 games
    Fixed an issue with the Game Option checkbox value for HTML5's new in-built font system not behaving as expected
    Fixed string_width() and string_height() when using the new in-built font system - note we also made these functions return 1, not 0, when no font has been set
    Added Switch Pro Controller support to Ubuntu as well


    IDE v2.2.1.361 and Runtime v2.2.1.273 - Initial 2.2.1 beta
     
    Last edited by a moderator: Dec 5, 2018 at 4:10 PM
  2. Bruchpilot

    Bruchpilot Member

    Joined:
    Dec 15, 2017
    Posts:
    39
    There is something that may be added to the beta opt-in help document here: https://help.yoyogames.com/hc/en-us/articles/360018353352
    After downloading the Beta IDE and installing it and starting it one needs to explicitly log out (of the yoyo account) and back in again. Otherwise the Beta Channel option in the Preferences won't show up.
     
    Amon likes this.
  3. RichHopelessComposer

    RichHopelessComposer Member

    Joined:
    Jun 20, 2016
    Posts:
    1,278
    Whoa, so many stability fixes! I'm looking forward to those - saving has been a little dicey for me lately for some reason, and GM wasn't recognizing one of my scripts. Had some project corruption going on a few weeks ago, so I'm glad YoYo is on top of this stuff. Good work, guys!
     
    kupo15 likes this.
  4. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
    To be clear, that should not actually be required, as the IDE is meant to detect your license on our server is different to the one you have on disk and silently get the new copy, but we did mass-change (almost) everyone's licenses today to enable beta access, so this might be a temporary hang-up from that. I'll add it to the FAQ anyway as a "If at first you don't succeed, try, try again" thing. Thanks.
     
  5. TheSpydog

    TheSpydog Member

    Joined:
    Jun 20, 2016
    Posts:
    50
    I'd love to experiment with the new gamepad mapping functions, but they don't appear to be documented in the manual. Am I missing something?
     
  6. Marcus12321

    Marcus12321 Member

    Joined:
    Aug 29, 2018
    Posts:
    90
    I was also wondering about the whole check the manual for changes thing. Does the online manual have the Beta changes in it already, or is there a separate beta manual we need a link to?
     
    kupo15 likes this.
  7. gnysek

    gnysek Member

    Joined:
    Jun 20, 2016
    Posts:
    1,226
    In "Runtime release notes" link to "IDE release notes" points to normal one, instead of beta.
     
  8. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
    No, you're not. Sorry - the manual changes were not in when this first beta was made. It will be added in the next one.

    The manual ships with the IDE each time, so Help inside the IDE already has the updated info. docs2.yoyogames.com will only be updated when we do the "stable" releases, not for Betas.

    Yeah, this is known/intentional - saves us having to do a final GMS2 build just to change release notes links when we want to do a release to non-beta users. Help > Release Notes and Help > Runtime Release Notes will take you to the beta versions if you're opted-in.
     
  9. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    156
    Crashing even more than the previous version (of which I had sent bug report details of very shortly before trying this one). Took several attempts of loading to even get past the project select screen just now.
     
  10. Bruchpilot

    Bruchpilot Member

    Joined:
    Dec 15, 2017
    Posts:
    39
    I have a question regarding the new sync mechanism (according to the release notes there were changes regarding gsync/freesync and (what I guess) remedies for the old 40fps-problem on laptops).
    I'm referring to the fps output the debug overlay produces, which I invoke like this:
    Code:
    show_debug_overlay()
    My test playground always ran at about 300fps. Room speed is set to 60, vsync is off.
    After the update to the current Beta, it starts about the same, but after a while (a few seconds) the fps drop to 53 - 60, without a workload change. This also reflects in the log output:

    Code:
    minFPS, maxFPS, avgFPS
    53, 515, 274
    The 500 are about a tick or two when the room starts, the 275 are the usual workload and correct, the 53 are new (and wrong). Before min fps would have been at 250 or so.
    Interestingly, when I grab the window and move it, the fps go back up to 300, until after a few seconds of letting it simmer, it will go back down.

    This is a fatass (albeit older) development desktop, so no power saving, no integrated graphics or any of the usual suspects, and I'm not using one of the new freesync monitors. Note that the actual workload does not change during the occurrence.

    Is the sync still being worked on? Is there a "natural" way to explain this? Because the fps-display was always a perfect headroom indicator, now it's.. less perfect.
     
    Last edited: Nov 5, 2018
    ph101 and gnysek like this.
  11. gnysek

    gnysek Member

    Joined:
    Jun 20, 2016
    Posts:
    1,226
    You can still run older Runtime from same IDE (probably still on disk), and double-check results without reinstalling IDE.
     
    Bruchpilot likes this.
  12. Bruchpilot

    Bruchpilot Member

    Joined:
    Dec 15, 2017
    Posts:
    39
    Oh, I'm aware. I also don't use the beta on the productive branch of any project. My question was more along the lines of "is it worth to make a minimal bug-report example or are there 10 overnight commits already concerning this that will show up on the next beta" ;)
     
  13. gnysek

    gnysek Member

    Joined:
    Jun 20, 2016
    Posts:
    1,226
    I'm 99% sure, that this beta won't break projects yet (in any other way that stable would normally do it :D), as it's only contains bugfixes mainly, but the next one, which may have Sequences feature - they need to save in *.yyg files, so they gonna left some changes forever (and IDE will have a lot of new features too!). This release is rather a "preparing" for real beta, with some fixes included.
     
  14. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
    Actually, this beta is nothing to do with Sequences.

    It's because of all the runner optimisations in this 2.2.1 release - we wanted to get feedback on if people's games now behave differently (in a bad way - they *should* behave differently in a good way! ;) ) and for them to be able to send us sample projects sooner.

    We then changed the saving system to prevent against a number of issues people were seeing with files being locked externally, and so we wanted feedback on this also.

    As you can see from the amount of features and fixes in the change log, 2.2.1 is massive, so where many people asked in the 2.2.0 release thread for a beta system to return, it made a lot of sense for us to implement it for this release.
     
  15. TheSnidr

    TheSnidr Heavy metal viking dentist GMC Elder

    Joined:
    Jun 21, 2016
    Posts:
    408
    There's a bug I often get when renaming resources - the IDE thinks I want to move the resource, but won't let me place it anywhere. Nothing happens when pressing the mouse buttons or any keys that I've found. I've had to shut down the program several times because of this:
    [​IMG]
     
  16. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    375
    In the beta, my project now intermittently produces an error
    "ERROR!!! :: Unbalanced surface stack. you are trying to pop a surface that has not been set."
    when opening menus when it never did so before.

    Ok I have looked into this more. I understand that 2.2.1 now has new behaviour in that it will now throw this error due to an unbalancing of
    Code:
    surface_set_target
    and
    Code:
    surface_reset_target
    I found in my code I do not actually have said mismatch though. However I do, for better or worse, find myself occasionaly resizing the surface from within a surface_set_target code block.

    in draw gui:

    Code:
    surface_set_target(pop_surface)
    
    //if you need to resize the surface
    surface_resize(pop_surface, window_width, area_height); //or resize it
    
    surface_reset_target();
    
    This causes the error. If I remove the middle code, it doesnt crash. I filed this with a sample project.
     
    Last edited: Nov 6, 2018
  17. gnysek

    gnysek Member

    Joined:
    Jun 20, 2016
    Posts:
    1,226
    Functions which takes surface_id as argument, shouldn't have set/reset target around it, as it's for drawing on surface only.

    So leaving middle code alone should be ok.

    Also, as draw event is performed every step - you probably shouldn't resize surface every step. If you want to draw it extended, use draw_surface_xxx functions.
     
  18. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
    "If I remove the middle code, it doesnt crash. I filed this with a sample project." < the surface_resize() frees the original and unsets it, then makes a new surface at the new size. This isn't reflected in the manual, so we'll add in info about this behaviour.

    As Piotr says above, don't wrap this resize in set/reset and you'll be fine.
     
  19. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    375
    Thanks, yeah I moved it out of course, and no problems.

    I don't resize it every step... Only when I need too ;) I meant it as psuedo code (note the if comment above it..) I mean otherwise ... if you take that code snippet literally.. there's not much point setting surface target at all as there is nothing being drawn on it :D
     
  20. spinout

    spinout Member

    Joined:
    Jun 21, 2016
    Posts:
    44
    Found an issue with the new iOS push notification setup.

    If I unchecked the use push notifications box everything build and runs fine. Soon as I check off to use push notifications on iOS everything stops working. There will be an invalid file yoyo.notifications.a or something like that. If I delete it out of XCode it builds fine but crashes soon as it launches.
     
  21. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    375
    I've also noticed the show_debug_overlay showing seemingly arbitrary drops and (sometimes rises) and possibly false results vs actual running speeds after testing for a while. It seems to be caused (possibly) when switching focus from game to another monitor and then using the task bar to go back to the game. fps real can be reset and to returned to normal by alt tabbing back to game, or sometimes (possibly?) when you change surfaces in game without doing that, it will switch back to normal speeds on its own.

    edit. I reproduced this in a blank project with only full screen and debug overlay. The first time the game loses focus (alt tab/click off monitor), when you return to the game the real fps seems to have halved or thereabouts. After some time it drops to 60. If you repeat that process it will go back to normal and further repeating will not cause this to happen again I find.

    This video shows the effect and description may help in replicating:



    edit. Another weird behaviour. Only happens sometimes or in certain rooms. After I lose focus via another monitor as described, then go back to game, real fps via overlay is unchanged/normal. If I click on menu to go to new room, it then shows 60 fps when normallly it is 1000 odd if I didnt do step 1. Then if I do nothing and just wait, that fps very gradually increases.... moving higher and higher. I left it and it went up to 300, it may have continued. Maybe it is showing an averaged value that is not reset somewhere? Also not certain if its just the overlay value being misreported or an actual fps change.

    edit. final point. Basically the values shown in the overlay will change depending on when you first enable it. Regardless of any focus change. If i enable overlay only in full gameplay room it shows high values (call this baseline). However if I restart game and enable it in the menu screen, then change room to campaign screen they then drop to 60. If i then enter full game, they are far below baseline, around 60, but then gradually increase over time. Possibly changing room or alt tabbing/changing focus with the overlay enabled seems to be at the heart of this?

    Hope this info makes some sense and is of some use! :)
     
    Last edited: Nov 9, 2018
    Bruchpilot likes this.
  22. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
    We've now put out an updated Beta release to fix some issues:

    Added in a lot more logging to catch startup crashes and runtime installation crashes - if you have runtime installation issues, please try this version and send us your ui.log file (and the ui_crash.log if you have one)
    Added a system to now attempt the runtime drive mapping and catch if you can't perform this command, this is then logged and GMS2 then fall back to the older non-mapped installation file path method - however, some platforms (typically Android) might have issues, as the file paths for Google's tools can get very long and so exceed Windows' limits.
    We've extended the changed saving system so it will now retry the save/load multiple times over a few seconds if we detect a file is currently locked.
    Fixed the missing manual pages for the new gamepad functions and the new sprite bounding box modification functions. (Bunch of other manual fixes also.)
    Fixed a number of localisation strings being missing or incorrect.
    Fixed that the constant "of_challenge_lose" was broken in the code editor's autocomplete
    Fixed a startup error which meant Microsoft Edge couldn't run debug versions of HTML5 games
    Fixed an issue with the Game Option checkbox value for HTML5's new in-built font system not behaving as expected
    Fixed string_width() and string_height() when using the new in-built font system - note we also made these functions return 1, not 0, when no font has been set
    Added Switch Pro Controller support to Ubuntu as well

    The issue about surface_resize() mentioned above has been fixed internally so you get a more appropriate error message, but that's not in this new release. Will be in the next one.

    We're looking into an issue with dragging a yyz/yyp onto the IDE when you have another project open already can cause a "GMS2 has become unstable" crash message.

    We're also investigating the issue mentioned above about the Push Notifications change on iOS and the debug overlay giving odd FPS values after losing focus.


    @TheSnidr If you haven't already, can you file a Helpdesk ticket about that issue, please. Not something I have seen before, so please give as much info as you can and reproduction steps, if possible (sorry, but that gif above is not explaining the issue to me or showing me how you're getting this, btw).
     
    FrostyCat and ph101 like this.
  23. Dog Slobber

    Dog Slobber Member

    Joined:
    May 20, 2017
    Posts:
    251
    • Running Beta 2.2.1.361 on a Mac
    • Prompted to install 2.2.1.366
    • Click Download now
    • Provided Windows' exe instead of Mac OS dmg

    Downloaded dmg from release notes link.



    upload_2018-11-9_11-31-33.png
     
    Last edited: Nov 9, 2018
    TheSpydog likes this.
  24. Yazuka

    Yazuka YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    53
  25. Bruchpilot

    Bruchpilot Member

    Joined:
    Dec 15, 2017
    Posts:
    39
    Somehow my IDE (on Windows) didn't notify of the new Beta IDE. I manually downloaded .366, works so far, but should there be a new runtime, too? The Beta channel still says .273
     
  26. Andrey

    Andrey Member

    Joined:
    Jun 21, 2016
    Posts:
    237
    Please note Request #151241
    It seems that there are some problems with loading audio groups and emitters.
     
  27. Andrey

    Andrey Member

    Joined:
    Jun 21, 2016
    Posts:
    237
    And only one of the scales can be displayed at a time? Is this normal or is it a bug?
    I didn't find any information about it in the documentation.

    In example #1, only overlay.
    In example #2, only the audio.

    Code:
    #1
    audio_debug(true);
    show_debug_overlay(true);
    
    Code:
    #2
    show_debug_overlay(true);
    audio_debug(true);
    
     
  28. Bruchpilot

    Bruchpilot Member

    Joined:
    Dec 15, 2017
    Posts:
    39
    This has been resolved, the feed now correctly announces runtime .277
     
  29. TheSnidr

    TheSnidr Heavy metal viking dentist GMC Elder

    Joined:
    Jun 21, 2016
    Posts:
    408
    Here's a better gif, @Dan:
    [​IMG]
    This happens every time I rename a resource and then click a different resource to stop writing. I will report it as a bug as well.
     
  30. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    156
    This was happening to me too yesterday. I couldn't figure out how to stop it and I had seventeen files to rename. :/

    Also still have the new issue I've had with last couple versions of GMS2 where the IDE crashes a LOT with fatal exception window thingies and such. Sometimes I need to try loading it up several times before i can even get to work on a project and eventually it crashes again. I've never had these sorts of stability issues with any GM before and everything else on my PC is running fine.
     
  31. Elevory

    Elevory Member

    Joined:
    Aug 27, 2016
    Posts:
    42
    I'm very happy to see that the >60hz framerate bug has been fixed! However, my application now freezes for 3-4 seconds when switching to fullscreen. Here's what the console has to say about this:

    "Vsync wait times out of bounds - reverting to sleep based timing"

    I'm using a Gsync monitor at 144hz.

    Anyone else experiencing a similar issue?
     
  32. DukeSoft

    DukeSoft Member

    Joined:
    Jun 20, 2016
    Posts:
    717
    Also 144hz GSync here - haven't really noticed it, will test again today :)
     
  33. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
    Any chance you have an Nvidia graphics card? We're investigating a recent change in their Optimus drivers. which is causing issues for GMS2 on startup: https://bugs.yoyogames.com/view.php?id=30145
     
  34. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
  35. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    156

    no. just whatever came in the PC.
    dxdiag thingy says this:
    Imaggfgfgfgfe1.png
     
  36. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    169
    Can you send us a Helpdesk ticket with that DXDiag report and your ui.log file, please? (ui_crash.log also if you have one)
     
  37. Steevo

    Steevo Member

    Joined:
    Nov 6, 2018
    Posts:
    57
    That's not much video RAM by today's standards. Wonder if the IDE is tripping out over that?

    Can you allocate more RAM in the BIOS for that model? Wonder if that would stop the issue? Complete guess of course.
     
  38. DukeSoft

    DukeSoft Member

    Joined:
    Jun 20, 2016
    Posts:
    717
    Oh wow yeah, 128mb VRAM might be too little for the IDE to run. Cards from 2007 usually have over 1Gb. LIike Steevo said, you might want to up your shared VRAM for your card.
     
  39. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    156
    Already did send bug report thing for the version before the first BETA which also did the exact same thing. Every other version before the last couple of non-betas were fine.

    Does seem oddly low doesn't it? I thought it had more. I don't really get into all the techy PC stuffs. I just like to have a PC and for it to just work. I don't play large video games or anything like that on it (that's what my PS4 is for) and this machine does everything I need absolutely fine (even plays Gamecube/Dreamcast/Wii games perfectly via emulation so it's not super crud) How do I allocate stuff? Don't remember ever seeing that option the few times I've even had to go into the BIOS.

    Ok yeah i looked in the BIOS options (which itself I had to look up how to do since F2 or whatever doesn't do it anymore) and yeah I see no options about VRAM or memory or anything like that.

    EDIT: did some reg-edit thing i found online since there was no option my BIOS. Don't know if it actually did anything but GMS loaded successfully first time this time so I'm hoping it's ok but obviously will have to use it for a few days or so to get a proper testing.
     
    Last edited: Nov 12, 2018
  40. DukeSoft

    DukeSoft Member

    Joined:
    Jun 20, 2016
    Posts:
    717
    You should look for "Shared memory" or "Video memory" in your BIOS somewhere :)
     
  41. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    156
    Yeah I did that. I went through every menu option several times over in case I missed it but there's absolutely nothing there about it. Only video related option in my BIOS is what is the primary monitor. And when I googled about it (which led me to the reg edit possible workaround I mentioned above) it confirms that there are many BIOS menus that lack the function. :/ GM:S still hasn't crashed yet during usage yet this afternoon but I haven't closed and reloaded it yet so who knows. More testing will be done in time. :p
     
  42. DukeSoft

    DukeSoft Member

    Joined:
    Jun 20, 2016
    Posts:
    717
    You found information about a primary monitor in your BIOS? :p That doesn't sound like BIOS.. This is what it should look like:
     
  43. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    156
    I did what the instructions (where you have to get there from a special Windows restart function 'Select UEFI Firmware Settings' since there's no way to jump into anything during Windows boot up time anymore on Windows 10) and the computer reset and ended up at a non-Windows screen where i could set system clock and whether the USB ports are active or not or all sorts of other bits. I know the old BIOS screens looked like that blue thing and i remember that from my previous computer but I cannot find anything like that on here and just the one I told you about.

    Here's bits from a site explaining BIOS and UEFI
     
  44. Justice

    Justice Member

    Joined:
    May 8, 2017
    Posts:
    393
    Some manufacturers, particularly for things like laptops and ultrabooks, simply don't provide many options through the BIOS/UEFI. My laptop, for example, allows almost no configuration beyond setting an admin password and changing boot options. By contrast, the desktop I just built has an ASRock motherboard directed at techies who'll want to overclock, etc., and it provides incredibly granular configuration options down to voltage and fan speeds.
     
  45. DukeSoft

    DukeSoft Member

    Joined:
    Jun 20, 2016
    Posts:
    717
    Maybe try ramming the following buttons on boot;

    Delete
    Tab
    F11
    F12
    F2
    F1

    F8 (this might also trigger Windows' boot option thingie)

    I usually ram all of those just after the laptop is turned on. And yeah, the newer laptops usually have UEFI - but you _should_ be able to change some settings there :/
     
  46. Elevory

    Elevory Member

    Joined:
    Aug 27, 2016
    Posts:
    42
    Thanks! Let me know what you find.

    I'll see if I can recreate the problem with a fresh project soon.
     
  47. Justice

    Justice Member

    Joined:
    May 8, 2017
    Posts:
    393
    Nevermind; I've experimented some more and I think this is intended behavior.

    With Preferences -> Text Editors -> Open object events in a full screen editor ENABLED: When double-clicking or Ctrl-T accessing an object, for some objects the focus will be brought to the object node in the workspace rather than to a new tab in the code editor with all the object's events. This happens with objects who only have events inherited from their parent and no additional events of their own. For objects that have some inherited events and one or more of their own events, double-clicking or Ctrl-T accessing acts as it should, i.e., shows a new tab in the code editor with all the object's events.

    If someone else can verify this, I'll submit the bug report.
     
    Last edited: Nov 16, 2018
  48. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    3,405
    @Dan @rmanthorp

    Are there any plans to allow side by side installs of Stable / Beta versions of GMS2 on the same system without having to run one through Steam?

    I really liked the fact you could do this with 1.4 (and a third through Steam if needed for testing).
     
  49. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    165
    Currently not possible as it reflects the beta/stable choice in the single install of 1.4. The multiple installs we had there was for a separate early access build of 1.4 which we have not yet decided if we are going to have in the future as it is a lot of extra work.
     
    rIKmAN likes this.
  50. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    3,405
    Ah I see, thanks for the reply.

    Running Stable via standalone and Beta via Steam (or vice versa) is still possible though?
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice