OFFICIAL GMS2 Version 2.1.4

Discussion in 'GameMaker Studio 2 Community Tech Support' started by rmanthorp, Apr 4, 2018.

Thread Status:
Not open for further replies.
  1. Andrey

    Andrey Member

    Joined:
    Jun 21, 2016
    Posts:
    237
    OK, sorry!
    It is simply not clear whether the error is taken into operation or not. I filed a report. In the bug list it hasn't come out.
     
  2. Matthew-T

    Matthew-T Member

    Joined:
    Aug 19, 2017
    Posts:
    22
    Is anyone else experiencing high CPU use and a really laggy IDE in v2.1.4.288 (laggy it the sense of click and it's unusable)? I'm seeing the same issue on multiple computers.

    To add, when I load a project, the CPU jumps from 60% to 80%.

    Hope someone can advise...



    Thanks,
    Matthew.
     
    Last edited: Apr 28, 2018
    Storyteller and slojanko like this.
  3. BHARDVAJ

    BHARDVAJ Member

    Joined:
    Apr 29, 2018
    Posts:
    2
    I just updated Game maker studio and after that game maker start installing runtime 2.1.4.203 and it just stuck at this point and after that Game maker just close by itself. Please, someone, help me
     
  4. slojanko

    slojanko Member

    Joined:
    Jun 20, 2016
    Posts:
    113
    I've had this for 1-2 years now, just restart it up to 10 times till it decides to cooperate. I've sent a bug report years ago and they haven't responded to my last reply in months, terrible support
     
    Last edited: Apr 29, 2018
    Matthew-T likes this.
  5. Justice

    Justice Member

    Joined:
    May 8, 2017
    Posts:
    393
    I get that; I've seen others making the same complaint, elsewhere. Before 2.1.4, it would get to 50%, after, it's worse, getting to 80%. This is intermittent. It normally hangs out at 2-5%. I theorize that it runs better in offline mode, but I haven't set it up for a proper test yet.
     
    Matthew-T likes this.
  6. Matthew-T

    Matthew-T Member

    Joined:
    Aug 19, 2017
    Posts:
    22
    ...Good call, I didn't think of trying that.
     
  7. vdweller

    vdweller Member

    Joined:
    Jun 24, 2016
    Posts:
    63
    In GM:S 1.4, if I checked the Fast Collision System, my game's (Gleaner Heights) large area's collisions would be broken. After moving around a bit, you would simply pass through objects, as if their collision masks were discarded altogether.

    The room where this happens is a 4496x3000 room with lots of instances counting as obstacles. Instance activation/deactivation code is present.

    Upon importing my project to GM:S 2, the very same problem exists. In 1.4 there was an option to leave the collision system as it is. In 2 apparently someone was too certain the new system would work...

    I didn't modify a single line after importing my project to Studio 2.

    Let me recap:

    For a fully developed, fully functional and released on Steam game:

    Game Maker 1.4:
    Legacy Collision system: Everything OK
    New Collision System: Missing collisions

    Imported to Game Maker 2:
    Missing collisions, same as 1.4's New Collision System

    I tried removing a bunch of map instances in case they were too many for the new collision system to handle. There was no change.


    BONUS ROUND:
    It's quite fascinating to see that on every step this new version of Game Maker springs to bite you in the ass. After the fabled
    Code:
    depth=-y
    producing sprite flicker, while the otherwise perfectly equivalent
    Code:
    depth=y
    depth=-depth
    eliminates that problem, I am waiting anxiously to see what other tantrums the program is going to throw at me. I think for me now Game Maker Studio 2 is the Dark Souls of game development software.
     
    Last edited: May 6, 2018
    Old Bit likes this.
  8. Juju

    Juju Member

    Joined:
    Jun 20, 2016
    Posts:
    376
    Did you report the glitch in an official bug report, @vdweller ?
     
  9. vdweller

    vdweller Member

    Joined:
    Jun 24, 2016
    Posts:
    63
    I want to re-create it in a new project and attach it. I am just trying to find the mental strength to do so.

    Also, the fact that every 2nd time I try to run the game, the program gets infinitely stuck in "Building" or randomly exits doesn't help either.

    Right now the "My Computer" window is full of fake X, Y, Z, W drives due to the aforementioned problem. Disabling antivirus didn't do anything. Runtime is 2.1.4.212
     
    Last edited: May 6, 2018
  10. Juju

    Juju Member

    Joined:
    Jun 20, 2016
    Posts:
    376
    YYG aren't going to be able to fix collision bugs in a new collision system if they're not reported by people using the software as intensively as you and I.

    I didn't run into this one when I started the GMS2 port for HLD - though we did have other collision issues in GMS1&2 and they were fixed promptly. Your problem is just as important, but apparently not many people have had the same issue (otherwise it would have been reported and, hopefully, fixed). Gotta work with YYG or else nowt gets done.
     
  11. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    165
    New 2.1.4 Runtime Release (and IDE to go with for compatibility) http://gms.yoyogames.com/release-notes-runtime.html
    • Fixed 0029360: HTML5: Audio doesn't play on iOS Safari, iOS Chrome or Android Chrome
    • NOTE 1: Fix is for iOS and Android only - Windows Chrome betas currently exhibit this also, but Chrome are not yet committed to keeping the change on desktops
    • NOTE 2: This change does mean initial loading times for HTML5 will now be longer while the audio files in your game are downloaded
    • Fixed 0029333: iOS: Playing audio externally before your game starts crashes the game on startup and causes issues if resuming
    • Fixed iOS audio issue where recieving a phone call, alarm or other system audio during a game would crash the game
    • Fixed 0029276: Audio: [GMS2] Sounds pop when stopped if another sound is played directly afterwards
    • NOTE 1: We are aware that Ubuntu 14 still has some "popping" issues with audio_stop(), as do Android when using Bluetooth headsets and UWP when using Gsync/Freesync monitors
    • Fixed 0029206: Audio: Audio Listener seems to be stuck at the bottom left of the screen, cannot change its position (actually a fix to support sounds set to be stereo but then used in positional audio)
    • Fixed 0028596: HTML5: Attached project has mouse offset when running in HTML5
    • Fixed 0029373: HTML5: Projects that use Viewports do not render correctly
    • Fixed 0025210: Windows: [GMS2] collision_rectangle() crashes runner
    • Fixed 0029355: Variables: Changing room_persistent between true and false causes collision issues to occur
    • Fixed 0029427: Windows: Runner fails to launch correctly when no audio devices enabled
     
    Last edited: May 22, 2018
    Justice and DukeSoft like this.
  12. Dani

    Dani Member

    Joined:
    Jun 21, 2016
    Posts:
    90
    Since today's update (IDE v2.1.4.295, Runtime 2.1.4.218), the audio resource playback preview on the IDE is not working. A noise is played instead for any audio resource.
     
  13. HW.

    HW. Member

    Joined:
    May 21, 2017
    Posts:
    198
    Anyone else confirm this? I downloaded the new installer, but by reading this, and i don't see any benefits for Android module i am using for this release by reading the release notes, so i prefer pending the update for now.....because i will need a stable IDE for the next few days. Oh so hectic days lately :confused:
     
  14. IndianaBones

    IndianaBones Member

    Joined:
    Jul 5, 2016
    Posts:
    1,768
    I can confirm it works ok for me, however this is on the Mac IDE. I haven't installed the Windows version yet.
     
    HW. likes this.
  15. Dani

    Dani Member

    Joined:
    Jun 21, 2016
    Posts:
    90
    I want to clarify that the audio issue happens only within the IDE, when you try to play a sound resource. The audio playback is correct when running the game.
     
  16. sylvain_l

    sylvain_l Member

    Joined:
    Sep 18, 2016
    Posts:
    704
    confirmed. (edit: I'm on win 10, IDE v2.1.4.295 Runtime v2.1.4.218; just tested with a basic music file)
    for me too, in IDE music is just an awfull noise, but when test-running (F5) the game, music plays like it should.
     
    Last edited: May 23, 2018
  17. IndianaBones

    IndianaBones Member

    Joined:
    Jul 5, 2016
    Posts:
    1,768
    Confirmed.

    Windows 7, SP1. Audio Playback within the IDE produces a bunch of white noise / static over the top of what seems like traces of the original sound.

    We should probably log bugs for this.
     
  18. PurpleFreezer

    PurpleFreezer Member

    Joined:
    Jun 13, 2017
    Posts:
    14
    I can't get the software to work after updating it. This is what happens:
    I click on the icon to open GMS2
    It loads with the Making Games is for Everyone splashscreen thing
    It infinitely brings this popup "String not found: the selected runtime could not fully install"
    I answer with "ok", the only available option
    and it brings up another popup with the same message
    and the light blue loading bar on the top right just kinda goes wild while this happens.

    help?? I began installing the updater by clicking "okay" when it offered a new update version of GMS2, and throughout the install process it asked to delete the old version of GMS2 to replace it with the new one, which I let it do. And now I can't get past the loading screen.

    Thanks for reading.
     
  19. Miradur

    Miradur Member

    Joined:
    Jan 16, 2018
    Posts:
    96
    No mutated vowel(Umlaute in German) will be displayed after the update:

    draw_text(x, y, "Für länger fehlt mir die Zeit") --> turns into (x, y, "Fr lnger fehlt mir die Zeit")

    My IDE is English and my help is set to German. Apparently the default font-set has been changed.
    Can anyone confirm that?

    Miradur
     
  20. Storyteller

    Storyteller Member

    Joined:
    Jul 19, 2016
    Posts:
    237
    gms2 now sucks up CPU when running, even in background, with no assets in an empty project. it renders my computer sluggish and unsable.
    why?
     
  21. Nettub

    Nettub Member

    Joined:
    May 11, 2017
    Posts:
    9
    Something is wrong starting up GM2 , looks like is something on your login side: [18:16:36:345(be38)] ProcessLoginResponse exception System.Runtime.Serialization.SerializationException: There was an error deserializing the object of type YoYoStudio.User.LoginResponse. Encountered unexpected character '<'. ---> System.Xml.XmlException: Encountered unexpected character '<'.

    Fixed: Just tried again ,and is working :)
     
  22. snowgames

    snowgames Member

    Joined:
    Oct 23, 2017
    Posts:
    10
    iOS YYC build Game Crashes on the launch randomly after this update update (IDE v2.1.4.295, Runtime 2.1.4.218)....
    Audio issue is definitely there in sound resource as well
    Also you can't roll back after this runtime update because it will throw missing build tools error if you try to build it with older runtime....
     
    Last edited: May 26, 2018
  23. Lenchantin

    Lenchantin Member

    Joined:
    Nov 25, 2017
    Posts:
    19
    APK and apk-assets.zip are not combining in a YYC build compile, ergo app freezes at splash screen. Was working fine before 2.1.4, but I can't roll back to 2.1.3 now or a get an error: Missing or corrupt GameMaker build tools : 0x4F030002

    Posted another thread about this in the support forum and sent up a bug report.

    **EDIT** THIS HAS BEEN SOLVED.
     
    Last edited: Jun 13, 2018
  24. Storyteller

    Storyteller Member

    Joined:
    Jul 19, 2016
    Posts:
    237
    update:
    New
    Im freezing up, using 60-90% cpu, locked screen, even in other apps if gms2 is running. had to kill it twice with task manager, on the same freeze, it wouldnt even kill correctly. This is unusable. Worked fine before update.
     
  25. djrain

    djrain Member

    Joined:
    Aug 13, 2017
    Posts:
    139
    Running on iOS 11.3.1 from the IDE doesn't seem to be supported. Will this be fixed in the next update?
     
  26. Andrey

    Andrey Member

    Joined:
    Jun 21, 2016
    Posts:
    237
    Yes, just the sound quality is still bad, the crackle remains.
     
  27. Zombie381

    Zombie381 Member

    Joined:
    Jun 2, 2018
    Posts:
    4
    I can login fine on yo-yos website, and not in the actual gms2(legally paid license). I searched for EVER last night and someone told me to turn steam on, which worked at my brothers house where there is WiFi (I didn’t buy this software on steam??) however after getting home (I don’t have WiFi, I use my hotspot here) it’s giving the same message I got when I first updated even with steam open now “unable to login - no network connection”. Before this update I was able to programm for a long time before I had to login again. And now I can’t even login AGAIN. Can someone help me out? I’m getting so frustrated
     
    Porkogougoul likes this.
  28. Ian Baker

    Ian Baker Member

    Joined:
    Jun 16, 2018
    Posts:
    4
    Any news on the collion problems and when we can expect a fix ?

    Were can we follow the work being done on it ?
    Is there a way to download IDE 2.1.3.189 ?
     
    Last edited: Jun 16, 2018
  29. Dog Slobber

    Dog Slobber Member

    Joined:
    May 20, 2017
    Posts:
    251
    The developers typically don't release news on bugs.

    You can follow progress on bugs at https://bugs.yoyogames.com/view_all_bug_page.php

    This site doesn't indicate if resolved bugs will make it into the next patch or when patches are released.
     
  30. Forgets

    Forgets Member

    Joined:
    Jun 16, 2018
    Posts:
    1
    upload_2018-6-16_15-50-48.png
    I am trying to run my game to see if everything is fine, but I am having problems when I try to run it, the error is present in the image, could you help me?
     

    Attached Files:

  31. Ian Baker

    Ian Baker Member

    Joined:
    Jun 16, 2018
    Posts:
    4
    Thank you Dog Slobber, been trying to stay patient in background .. waiting for salvation .
     
  32. Fiskyfisko

    Fiskyfisko Member

    Joined:
    Apr 21, 2018
    Posts:
    9
    So when can we expect the collision bugs to be fixed? I was forced to update to 2.1.4 and can't roll back to 2.1.3 now.
     
  33. Dog Slobber

    Dog Slobber Member

    Joined:
    May 20, 2017
    Posts:
    251
    What runtime are you on? Make sure that you are on 2.1.4.218, there were a lot of collision issues in the early 2.1.4.x runtimes. You can also consider rolling back to the final 2.1.3.x runtime.

    Bug fixes and patch timeframes are typically never announced.
     
  34. Fiskyfisko

    Fiskyfisko Member

    Joined:
    Apr 21, 2018
    Posts:
    9
    Running on 2.1.4.218 right now. Where can I download 2.1.3.x ? It's not super horrible but the collisions are behaving differently, for example if I'm running against a wall downwards it starts pushing the player object slightly to right and that's something that doesn't happen in 2.1.3.x.
     
    Last edited: Jun 17, 2018
  35. Dog Slobber

    Dog Slobber Member

    Joined:
    May 20, 2017
    Posts:
    251
  36. Fiskyfisko

    Fiskyfisko Member

    Joined:
    Apr 21, 2018
    Posts:
    9
  37. Dog Slobber

    Dog Slobber Member

    Joined:
    May 20, 2017
    Posts:
    251
    I guess runtimes older than 2.1.4.200 are no longer compatible.

    I guess your only solution is to file help tickets for your particular bugs and wait for an update.
     
  38. rwkay

    rwkay YoYo Games Staff YYG Staff

    Joined:
    Apr 12, 2016
    Posts:
    1,048
    Please file any collision issues you have as bugs, we have addressed all known issues so far, but we cannot fix if we do not know about them.

    Russell
     
    Ian Baker likes this.
  39. Fiskyfisko

    Fiskyfisko Member

    Joined:
    Apr 21, 2018
    Posts:
    9
    Okay so the problem was with how place_meeting works. It works now for me but please yoyo staphh
     
  40. Ian Baker

    Ian Baker Member

    Joined:
    Jun 16, 2018
    Posts:
    4
    How was your problem fixed cause I may have the same problem
     
  41. Fiskyfisko

    Fiskyfisko Member

    Joined:
    Apr 21, 2018
    Posts:
    9
    try swapping place_meeting for place_meeting_rounded , that fixed the problem for me.
     
  42. Ian Baker

    Ian Baker Member

    Joined:
    Jun 16, 2018
    Posts:
    4
    This worked in 2.1.3.x IDE and does not work on late
    Don't have the place_meeting_rounded function in my IDE , also seems my problem is with position_meeting :


    This worked in 2.1.3.x IDE and does not work on latest version of IDE, the code prevented user/player from placing a new instance of a object on other objects.


    Now user can place unlimited amount of object on same location or on locations he/she is not suppose to if he/she has enough money to do so. (Not using Phycics enabled room or objects)

    if (!position_meeting(xPlace,yPlace,all))
    {
    instance_create_layer(xPlace,yPlace,"Instances",argument[1]);
    money -= argument[0];
    }
     
    Last edited: Jun 19, 2018
  43. Curried-Cat

    Curried-Cat Member

    Joined:
    Jun 24, 2018
    Posts:
    3
    It's now unusable since updating to IDE v2.1.4.295 runtime 2.4.1.218. It's taking 60+% of the CPU and
     
  44. ryu666

    ryu666 Member

    Joined:
    Jun 18, 2018
    Posts:
    5
    I was checking things out about the UI and clicked edit and replace then X to close the replace window and the game froze
     
  45. meltypixel

    meltypixel Member

    Joined:
    Mar 13, 2017
    Posts:
    10
    I'm getting audio crackling when using audio_emitter_velocity in my project. This has been a problem for a few months now, and previously I was staying on an older runtime that didn't have this issue.

    Unfortunately, it seems I can't revert to older runtimes now. GMS2 fails to build on anything but the latest, it seems.

    This isn't a time-sensitive issue for me at the moment, but it does make me concerned for the future. For example, I was prepping to show my game at a conference when the physics bug got pushed out, and rolling back the runtime saved me from disaster. If I can't roll back this audio crackle or any future game-breaking issues, that makes me very nervous.
     
    JeffJ likes this.
  46. cidwel

    cidwel Member

    Joined:
    Jun 30, 2016
    Posts:
    113
    Happened to me too. It seems the version wasn't updating (yeah!) so I had to remove gamemaker, clean all the gamemaker related directorioes in appData and Roaming. Test it again, it solved to me
     
  47. meltypixel

    meltypixel Member

    Joined:
    Mar 13, 2017
    Posts:
    10
    Well, that worked, but unfortunately it seems I can't roll back any further than 2.1.4.200, which is when my audio issues started.

    I've submitted a bug report.
     
  48. Andrey

    Andrey Member

    Joined:
    Jun 21, 2016
    Posts:
    237
    It sounds just crackling and not only with audio_emitter_velocity
    This topic has already been raised, including this >>>
     
  49. Dev225

    Dev225 Member

    Joined:
    Dec 8, 2017
    Posts:
    2
    I have been dealing with a progressively slower GMS2 experience since April of last year when I first decided to give 2.0 a spin.

    upload_2018-7-14_17-26-15.png

    My project file is currently sitting at 1,390kb. I have an i7-4790k and 16GB of RAM, and my project is hosted on an SSD. And it runs horribly. I also run it on my MacBook Pro 13" 2017 and you can imagine how much worse it is there.

    When the IDE first runs it's not bad. But it immediately starts down a steep slope of performance degradation that, after a few hours, results in either a crash or me angrily closing it to start it up again because it literally cannot keep up with my typing because of how often it lags or freezes.

    Just loading my project currently takes 3:24, 10 seconds to load it followed by another 3:14 of "Saving". I am intimately familiar with this number because of how often the IDE crashes.

    The GMS2 IDE seems to crash when the following events occur:
    • Just switching into the IDE from another window. This is the most common but most randomly triggered, and it's the most fun because the IDE will constantly freeze for seconds at a time so I never know if it's just a regular freeze or a crash.

    • Dragging items from Windows explorer into the Resource Tree - especially multiple items.

    • It ran out of space because it creates insane cache files, crashes constantly, and then fails to clean these things up properly forcing me to periodically go spelunking to clean up the several gigabytes of droppings YoYo has left for me.

    • A molecule of air strikes the side of my case
    The Resource Tree - please fix it. Please. I'll pay you money. I just want it to WORK PROPERLY. I don't know what's wrong with it but it seems to be the cause of 90% of my performance problems in the IDE. If I kill the resource tree entirely performance isn't horrid, but that makes working in the IDE irritating.

    All of my problems are multiplied by the fact that I foolishly decided to enable Source Control (Git) support in GMS which is terribly slow. Frankly I'd disable it in the IDE and tell people to use Github Desktop or something until you have time to properly implement it.

    I put up with all this because my project is fairly entrenched in GMS2 at the moment and I'd rather not commit to a rebuild elsewhere. And there are features of GMS2 I genuinely enjoy! It could be really great with some serious focus on performance issues. I'm hoping that it gets a lot better in the near future.
     

    Attached Files:

    PsychoDelph likes this.
  50. Mick

    Mick Member

    Joined:
    Jun 30, 2016
    Posts:
    678
    The steep slope of performance degradation sounds like an "old" problem when having built in source control enabled, maybe that problem hasn't yet been fixed. Can't you disable built in source control and use external source control instead?

    EDIT: I somehow thought this was a newer thread, sorry for necroposting.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice