• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

OFFICIAL GMS2 tvOS Export 2.2.3

rmanthorp

YoYo Games Staff
Admin
YYG Staff
Beta IDE Release Notes
Beta Runtime Release Notes
Beta Opt-In FAQ
 (How to get on the Beta Channel)

This topic is for the discussion of issues relating to tvOS Export. However, this does not replace our normal bug reporting system and you should report all bugs as normal using https://accounts.yoyogames.com/contact-us#studio2

Goal: Feedback for the tvOS Export. Projects running on tvOS. Any issues with the options. Platform fixes.

• Added tvOS as a new supported target platform
• Also adds support for the Siri gamepad/remote
• See the manual and our setup guides on Zendesk for more info
• Note: Requires 2.2.3+ IDE also

NOTE 1: Development was completed before Apple released all their new beta Xcode/iOS/iPadOS/tvOS tools recently, so whilst we have quickly reviewed and all seems to be okay with these beta SDKs, we are still confirming that sending store builds is okay, etc., and so if anyone has feedback on this we're super-keen to hear it.

NOTE 2: Please be aware that all versions of the IDE from 2.1.5 onwards have known about tvOS, so the target will now appear in those IDEs. However, you should only test tvOS using the 2.2.3 IDE and runtimes, as this is the only version which is aware of the current Xcode/tvOS SDK versions.
 
Last edited by a moderator:

TheSpydog

Member
In the "What's New in 2.2.3" announcement, none of the tvOS Helpdesk articles seem to be publicly viewable. When I click the links, I get kicked to an error screen that reads: "oops. You're not allowed to access this page."
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
In the "What's New in 2.2.3" announcement, none of the tvOS Helpdesk articles seem to be publicly viewable. When I click the links, I get kicked to an error screen that reads: "oops. You're not allowed to access this page."
Thanks for pointing this out! There was a minor issue with permissions which should now be fixed. Could you check again and let me know if they are visible now please?
 

Anuj Raghav

Member
updated the gms2 to latest version 2.2.3
updated the runtimes to latest beta , still no tvOS option showing in targets or in platform settings

gms issues.png
 

Anuj Raghav

Member
i cleaned the run-times , opted out of beta , logged out , logged back in , opted in for beta
updated run-times... but no use , still no tvOS option
 

Dan

YoYo Games Staff
YYG Staff
That's tvOS enabled for everyone now. We needed a bit of time to make sure that the beta went out okay yesterday before we turned everything on - you guys are just super-eager! ;) (Which is great...)

You will definitely need to restart GMS2 to see the change and you might find you need to log out and in again, depending on which version of GMS2 you're using.

Please be aware that all versions of the IDE from 2.1.5 onwards have known about tvOS, so the target will now appear in those IDEs. However, you should only test tvOS using the 2.2.3 IDE and runtimes, as this is the only version which is aware of the current Xcode/tvOS SDK versions.
 

tjuven

Member
If I have an universal app that I want to export for Apple TV is it then possible to detect the os with os_type?
 
I can't seem to get my export on to the Apple Tv. This error keeps occurring. I created just a simple test app and it works fine. But not any of my other projects. Some of them did work a few days ago but not anymore. Any ideas?


/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono DONE (0)
The given key (copyToTargets) was not present in the dictionary.
Igor complete.

elapsed time 00:00:18.4676500s for command "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono" /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.3.337/bin/Igor.exe -j=8 -options="/var/folders/74/bwwp4chd6z5d75w42k_fq52m0000gn/GameMakerStudio2/GMS2TEMP/build.bff" -v -- tvos Run started at 06/09/2019 17:27:13
FAILED: Run Program Complete
 
I found that i had Mono 5.x and uninstalled from my mac. Followed the link you gave and reinstalled Mono. Now I'm getting this. Do I need to downgrade my tvOS version?

cp DONE (0)
Device is on os 12.3
tvOS SDK is 12.2
Missing or corrupt GameMaker build tools : 0x4F030001

elapsed time 00:00:10.8498380s for command "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono" /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2.2.3.337/bin/Igor.exe -j=8 -options="/var/folders/74/bwwp4chd6z5d75w42k_fq52m0000gn/GameMakerStudio2/GMS2TEMP/build.bff" -v -- tvos Run started at 06/09/2019 17:50:36
FAILED: Run Program Complete
 

chorrus

Member
I'm getting this in Xcode
This Apple TV (4th generation) is running tvOS 12.3 , which may not be supported by this version of Xcode.
I'm running the latest version of Xcode so I believe the problem is somewhere else. Has anyone been able to build an app in tvOS 12.3?
 

chorrus

Member
Okay, after some more testing I've noticed that scaling isn't working fine I'll try it some different TVs to see if I can understand better the issue. I've also noticed .ini files aren't being saved something that completely breaks games(hopefully I'm doing something wrong and has an easy fix but everything works in every other platform)
 

siread

Member
Sorry for posting this issue twice - I didn't realise there was a dedicated tvOS thread. I'm getting an error when I attempt to archive my app:
Bitcode bundle could not be generated because 'Buoyant/Supporting Files/libyoyo_yyc.a(ALCdevice.o)' was built without full bitcode. All object files and libraries for bitcode must be generated from Xcode Archive or Install build file 'Buoyant/Supporting Files/libyoyo_yyc.a' for architecture arm64
I'm guessing that YY will need to update this lib?

Also, I'm seeing the save issue that chorrus mentioned.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
I found that i had Mono 5.x and uninstalled from my mac. Followed the link you gave and reinstalled Mono. Now I'm getting this. Do I need to downgrade my tvOS version?
Update Xcode to the new beta and try again please!

Okay, after some more testing I've noticed that scaling isn't working fine I'll try it some different TVs to see if I can understand better the issue. I've also noticed .ini files aren't being saved something that completely breaks games(hopefully I'm doing something wrong and has an easy fix but everything works in every other platform)
Could you file bug reports for both issues?

@siread : I can't reproduce the issue you're having, and so I'd ask that you too file a bug report and include a link to the project as well as the full output with the error message. Thanks!
 
Last edited:

chorrus

Member
Hey @Nocturne I have already filed a bug, I sent them a test project so they are probably working in it now. I'm also having the problem @siread has, what Xcode and macOS version are you using? Might be related with having Mojave, I've been having many problems lately and it's been since I updated so it might be related.
 

Dan

YoYo Games Staff
YYG Staff
As mentioned above, a few bugs are being fixed at the moment for this feature. They won't make the second beta release, but they will be in the third, which we aim to follow behind pretty soon after.
 

Dan

YoYo Games Staff
YYG Staff
We would strongly advise updating to Mojave if you can, as that's the one current versions of Xcode state as a minimum, so not sure how successful you would be actually getting a package to publish on the AppStore using the older tools now.

High Sierra *should* still work as long as you haven't updated your tvOS device much recently - https://en.wikipedia.org/wiki/Xcode

Xcode 10.1

10B61 October 30, 2018 10.14.1 (18B71) iOS 12.1 (16B91) watchOS 5.1 (16R591) tvOS 12.1 (16J602)
 

Samuel Venable

Time Killer
Thanks for the info. Fortunately I am working with another developer to get this done, and they happen to have access to Mojave.
 

Dan

YoYo Games Staff
YYG Staff
Just make sure your Xcode (and therefore macOS) are all also suitably updated so they match that tvOS version and you'll be fine. We have even tried the current Xcode/tvOS beta versions and found these work with GMS2 also. It's only older tools which *might* have an issue.
 

Carnivius

Member
For many months, almost a year on many versions of GMS2 I was getting constant start up crashes with many error windows (and some crashes during the program usage too). A couple of workarounds worked for a few days or so but things got bad again. Well, I been using 2.2.3 for about a week and haven't had one single crash so far despite constant use of the program and booting up (cos been in and out of my home quite a bit so the computer's been switched on and off and such). I feel like I may be jinxing things and likely to see a crash error after posting this but yeah this past week has been a frickin' joy to use Gamemaker again. I don't understand what you folk have done but thank you.

(and now i await the jinxing I have probably inflicted on myself)

:p
 

Samuel Venable

Time Killer
A new beta version is currently rolling out, so you should see the update available notification at some point today - https://forum.yoyogames.com/index.php?threads/gms2-version-2-2-3-beta-release.64003/ for the summary of changes.

This one has the fixes for making archives and writing ini files.
I don't see the bug regarding ini's listed. Was it not saving to the correct directory? Using the Win32 api for writing ini you need to use an absolute path, otherwise it'll save to the Windows installation folder as explained in the Microsoft docs. So you'd need to convert relative to absolute path for the filename internally using GetFullPathNameW. :D
 

chorrus

Member
A new beta version is currently rolling out, so you should see the update available notification at some point today - https://forum.yoyogames.com/index.php?threads/gms2-version-2-2-3-beta-release.64003/ for the summary of changes.

This one has the fixes for making archives and writing ini files.
Awesome! At least in my TV the game isn't scaling correctly(nor using my own scaling system nor using the full scale system), I did send a bug report about this but I think you didn't add it, maybe it wasn't happening to you. It would be awesome if you could check it out.

Oh, and thanks for solving the bugs, can't wait to test it :D
 

Dan

YoYo Games Staff
YYG Staff
I don't see the bug regarding ini's listed. Was it not saving to the correct directory? Using the Win32 api for writing ini you need to use an absolute path, otherwise it'll save to the Windows installation folder as explained in the Microsoft docs. So you'd need to convert relative to absolute path for the filename internally using GetFullPathNameW. :D
?? It's definitely in the list of changes on that post. "New in runtime 341" section.

You ARE talking about the bug with tvOS not able to write out at ini file, right? ;)
 

Dan

YoYo Games Staff
YYG Staff
Awesome! At least in my TV the game isn't scaling correctly(nor using my own scaling system nor using the full scale system), I did send a bug report about this but I think you didn't add it, maybe it wasn't happening to you. It would be awesome if you could check it out.

Oh, and thanks for solving the bugs, can't wait to test it :D
Your scaling issue was checked as part of your ticket which included the ini issue and a couple of other points. We could not reproduce the scaling part of your ticket, and from the deafening silence it doesn't sound like others have that issue either, so if you're able to nail down what's causing it on your Apple TV, then send us a fresh ticket and sample project, plus your compiler log as a .txt file. Thanks.
 

Samuel Venable

Time Killer
?? It's definitely in the list of changes on that post. "New in runtime 341" section.

You ARE talking about the bug with tvOS not able to write out at ini file, right? ;)
Yeah.. I kinda forgot this topic was about tvOS and my mind went to a common issue people run into on Windows with ini reading and writing. Silly me.
 
Ahhh that's how you do that. I haven't used my Mac mini in over a year for builds and forgot that the icon is actually the entire program it's not a shortcut and pop it into the application folder for it to be the default program.

Thank you
 
Top