Question - Code GMS2 tiles jitter on camera movement

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Petr Skornok, Oct 26, 2017.

  1. Petr Skornok

    Petr Skornok Member

    Joined:
    Sep 13, 2017
    Posts:
    44
    Hi,

    I've stumbled upon a problem that while a camera is moving with the player the tiles display with a glitch. I've recorded this issue in slow motion on my phone to capture the moment when the jitter happens.



    This happens only on Mac (PC seems fine), the game speed is set to 60 and the macOS settings are following:
    [​IMG]

    The camera position is always an Integer number to avoid any sub-pixel movement. I have also tried changing multiple macOS settings but it didn't change anything.

    Thanks for the help.
     
  2. MarvelousWombat

    MarvelousWombat Member

    Joined:
    Jun 10, 2019
    Posts:
    2
    Hey, I have the exact same problem, did you ever happen to solve this?
     
  3. Mick

    Mick Member

    Joined:
    Jun 30, 2016
    Posts:
    725
    Looks just like when vertical sync is disabled, but the OP had it enabled (use synchronization to avoid tearing).
     
  4. Andy

    Andy Member

    Joined:
    Jun 20, 2016
    Posts:
    185
    Amon and Nocturne like this.
  5. apertureless

    apertureless Member

    Joined:
    Jan 12, 2019
    Posts:
    8
    I experienced the same.
     
  6. MarvelousWombat

    MarvelousWombat Member

    Joined:
    Jun 10, 2019
    Posts:
    2
    Solved! thank you so much!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice