• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX GMS2 stops working after 5 days

Non.A

Member
Hi, new here. I was trying to avoid posting but couldn't find a clear answer.

My GM worked fine for 5 days and now won't move past "installing runtime" during start up. I've found a number of "go to this website and download this" or "call your ISP" or "download it to your usb and ask your favorite god to bless it" responses, but I'm not literate enough in this arena to follow. I paid for it and it should just start when I open it. I've spent hours trying to figure this out. if anyone has the solution I wold be so grateful. I have a Mac. I'm using v2.3.0.529 and it stalls at "installing runtime 2.3.0.410".

I've tried visiting the website and downloading it directly but it doesn't work.

please and very thank.
 

Attachments

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
I would try a clean install and also ensure any anti-virus you have are disconnected at the time you re-install the product.

 

chamaeleon

Member
can I just get a refund? how do I get a refund?
5.2. Refunds. If you would like to request a refund for any YYG Property or Publisher Property, please contact us at help.yoyogames.com. Please note though that all refund requests will be determined at YoYo Games' sole discretion and if a refund is offered then usually you will be required to delete/destroy all copies of the YYG Property and/or Publisher Property in question and all your rights to it will terminate.
 

Non.A

Member
still waiting for a response from Helpdesk, but here's what I found through trial and error in case anyone else has this problem

I unplugged everything from my MacBook, USB C to HDMI cable, Flepow USB C Hub (for mouse and keyboard).
performed a clean install.

I was able to install and open the program, however, if I try to open the program on my larger secondary screen, the program crashes. I have to open it on the Mac and then drag the window to the second screen.

in short, in my case, GMS2 will only install if nothing is plugged in my MacBook, and it will only open if I open it on the MacBook, not the secondary screen.

although now I'm getting this error when I try to run anything.
WARNING: The Carbon driver has not been ported to 64bits, and very few parts of Windows.Forms will work properly, or at all
 

Toque

Member
Sorry your struggling with it. I’ve used GM with different MacBooks and a old imac and never had install problems.

How old is your macbook?
 
Top