Feedback GMS2 Sprite editor bugs

Discussion in 'GameMaker Studio 2 Community Tech Support' started by emicarra, Jun 30, 2019.

  1. emicarra

    emicarra Member

    Joined:
    Jul 2, 2017
    Posts:
    39
    Hello, here are some bugs i've noticed but i don't know what causes them since they happen randomly.

    1- After deleting a selection by pressing "supr", the pixels inside that deleted selection start re-appearing when they become in contact with a line im drawing while holding the mouse.

    2- After using CTRL+Z, the last pixel i've drawn on gets "locked", i can't draw on it, it gets unlocked once i draw on another pixel.

    3- Copying frames sometimes doesn't work, i right click>copy frame to make sure i copy the frame, and when i right click>paste in another sprite, nothing happens. For some reason the only safe way i can get it to work guaranteed that it will copy/paste it is by keeping both sprite windows opened while copying and pasting.

    4- GMS2 crashes when i close the sprite editor, sometimes it gets to save the sprite, and sometimes it doesn't, it shows a message saying it couldn't load 1 frame or something like that.
     
  2. Nocturne

    Nocturne Friendly Tyrant Forum Staff Admin

    Joined:
    Apr 13, 2016
    Posts:
    6,892
    Are you on the latest version of the software? I use the sprite editor quite a bit and haven't had any of the issues you describe...
     
  3. emicarra

    emicarra Member

    Joined:
    Jul 2, 2017
    Posts:
    39
    I'm on v2.2.2.413
     
  4. Nocturne

    Nocturne Friendly Tyrant Forum Staff Admin

    Joined:
    Apr 13, 2016
    Posts:
    6,892
  5. emicarra

    emicarra Member

    Joined:
    Jul 2, 2017
    Posts:
    39
    It doesn't happen everytime, it happens randomly and i don't know what triggers them. Thanks for your help
     
  6. emicarra

    emicarra Member

    Joined:
    Jul 2, 2017
    Posts:
    39
    Sorry for bringing this up again, i just wanted to show you one of the bugs, i was able to record it
    https://streamable.com/g3lri
     
  7. Toque

    Toque Member

    Joined:
    May 25, 2017
    Posts:
    1,040
    This is a bug with the line tool? Or the cmnd z Bug?
     
  8. emicarra

    emicarra Member

    Joined:
    Jul 2, 2017
    Posts:
    39
    after using ctrl+z to erase part of the guy's arm, i started drawing it again with the line tool, and as i moved the line while holding mouse button, the erased arm started appearing again. A big part of the arm reappeared before i could record it, so that's why you only see like 3 pixels reappear, but at least you can see it
     
    Cloaked Games likes this.
  9. Toque

    Toque Member

    Joined:
    May 25, 2017
    Posts:
    1,040
    Oh I see it now. The editor could use a little love.
     
  10. Cloaked Games

    Cloaked Games Member

    Joined:
    Jul 4, 2016
    Posts:
    796
    I have had this happen to me before a few times. Didn't post anything because I had no idea how to reproduce it...
     
  11. EvanSki

    EvanSki King of Raccoons

    Joined:
    Apr 17, 2018
    Posts:
    580
    Ive had the copy paste bug a lot
    I'll record it the next time im in the editor, it just happens randomly theres no way to force it to happen that i know of
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice