1. Hey! Guest! The 35th GMC Jam will take place between November 28th, 12:00 UTC - December 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice

Question - IDE GMS2 sound not working in preview

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Rocketman5, Jul 23, 2019.

  1. Rocketman5

    Rocketman5 Member

    Joined:
    Mar 19, 2019
    Posts:
    16
    For some reason when I installed GameMaker Studio 2 on my Windows 10 computer, the sound doesn't work in my preview.

    And yes, I know there are already tons of threads about this, but unfortunately I can't really solve this problem by what people suggested, because the default setting for me is "SAMSUNG (Intel(R) Display Audio)" and that's the only one in the Audio Device settings.

    I can't select any other audio device because of that, can you help me out please?
    yep thats it.png
     
  2. Rocketman5

    Rocketman5 Member

    Joined:
    Mar 19, 2019
    Posts:
    16
    Bumping this so it can get noticed.
     
  3. TheSly

    TheSly Member

    Joined:
    Jan 16, 2017
    Posts:
    996
    It happens to me sometimes too. Haven't done anything to fix it, yet today it's working. Don't have a suggestion, but indeed the sound preview does seem buggy.
     
  4. Rocketman5

    Rocketman5 Member

    Joined:
    Mar 19, 2019
    Posts:
    16
    Glad it did for you. Tried again recently and it does work on a project I only started today, but not with my other projects which were made with a previous version (that was when I noticed the issue).

    Funnily enough, it always worked fine on my laptop (which is also a Windows 10).
     
  5. Rocketman5

    Rocketman5 Member

    Joined:
    Mar 19, 2019
    Posts:
    16
    So I ran another project (which is based on one I had months ago) and the sound only works in standard window mode. It doesn't work in fullscreen mode. That could be the problem I was talking about.
     
  6. Rocketman5

    Rocketman5 Member

    Joined:
    Mar 19, 2019
    Posts:
    16
    Apologies for bumping a really old thread, but after updating GMS2 and testing it in fullscreen (and non-fullscreen first to be on the same side), the sound seems to work.
     
  7. Rocketman5

    Rocketman5 Member

    Joined:
    Mar 19, 2019
    Posts:
    16
    Made a new project and the bug is back! :( (again, fullscreen only).
     
  8. Rocketman5

    Rocketman5 Member

    Joined:
    Mar 19, 2019
    Posts:
    16
    Bumping again because I realised that it may've been my computer's fault and not GMS2's. You can still help me if you like. Remember, the default audio setting on GMS2 is "SAMSUNG (Intel(R) Display Audio" and it's the only one.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice