• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Discussion GMS2 Resolution support and workspaces

T

Toomuchbob

Guest
I've recently switched over to GMS2 and was playing with it on my desktop, I was enjoying it but found some navigation of the UI clunky and awkward. Then I switched over to using it on my laptop, and it is almost...unuseable.

I've spent the past 10 hours trying to wrap my head around where some things are and it all just seems so counter intuitive.

I'm editing a sprite, I finish editing it and looking for the "green checkmark" is nowhere to be found. THat's okay. I click the X. It then brings me to my room tab, opens up all the room controls I had just closed, and now I feel like my workspace is inside a pokebal or something, completely surrounded by monstrous tabs on all sides, none of which pertain to what I'm trying to accomplish.

my laptop res is 1366x768, and the UI is so invasive that there seems to be no way to control how much of my workspace is being taken over by things that open on their own. Am I missing something? Is there a way to make EVERYTHING smaller?
 

Mick

Member
There is a DPI override setting you can change ( somewhere under settings, I don't remember the exact path).
 

Mike

nobody important
GMC Elder
you can also hide the tabs either by clicking on the side of them, or by pressing F12 (or the icon at the top) to hide/restore whenever you need to.
 

hdarren

Member
I would like a option so when opening a resource it doesn't fling you across the workspace. So it instead it opens it on the screen overlapping existing resources like in GM1. I think this will help with people like me with small desktops.
 
G

Guest User

Guest
tbh I feel the same TC, on my desktop gms2 is "bearable" but on my laptop it's pretty much unusable which is really not good as I used that a lot, spare 10 mins here, 10 mins there etc.

Gms 1.4.x is fine on my laptop, gms2 is not. and yes, I miss the green tick also :)
 
M

Michael Taylor

Guest
I agree. The new GMS2 interface is innovative, but it's very aggravating on my laptop, too. Even when using laptop mode. There should be an option to switch to some sort of tabbed mode.

My issues with the new interface are:
  • Locating other windows in the workspace is difficult
  • Sometimes I'll be using a window which is only being "half shown" and I have to find and click the maximize icon each time I switch back to that window
  • It would be nice to have more keyboard friendly navigation
  • The zooming in laptop mode makes the text look fuzzy
However, it is an innovative workspace and I can see it being helpful with a very large monitor after some of the kinks get worked out.
 
G

Guest User

Guest
I've been so frustrated with gms2 on my laptop now that today I decided to simply use gms2 on my desktop and stick to 1.4 on my laptop.
(which obviously causes a world of issues, but as it stands now, gms2 is simply not usable on my laptop, I hope YYG do something to fix the issue)
 

hdarren

Member
@AncientPaul

I have found it still usable by doing 2 things.

Change the setting so all scripts open in fullscreen mode.

If I want to go to one of the objects that is open somewhere then I go to workspace tab, press right click somewhere on the workspace and select the object from the drop down.

I admit I work in GM1 far more efficient but at least I can do work until it's fixed.
 
M

Michael Taylor

Guest
@AncientPaul
Change the setting so all scripts open in fullscreen mode.
Am I the only one where that setting doesn't seem to work? The scripts seem to be opening in "full-screen-ish" mode where the maximize button is hidden behind the resource view. That causes me to pan to the right to hit the maximize button so the script is now truly full-screen. Also, the output window sometimes hides the bottom of the script editing window. I wish the output windows had an auto-hide option, or even a stay-hidden option. I'll search the bug reports for these issues.
 

hdarren

Member
They open fullscreen here. I checked new version.

I agree I want the output had auto-popup and auto-hide when compiling like GM1.
 
G

Guest User

Guest
@AncientPaul

I have found it still usable by doing 2 things.

Change the setting so all scripts open in fullscreen mode.

If I want to go to one of the objects that is open somewhere then I go to workspace tab, press right click somewhere on the workspace and select the object from the drop down.

I admit I work in GM1 far more efficient but at least I can do work until it's fixed.
Thanks, I just changed the setting so it opens in fullscreen mode however it doesn't seem to work for some reason?
 

Kios

Member
I think the real change that they need to make is that when you change the dpi, the windows size of each item should be resized to fit the given view now.
One of the problems, say when i open a sprite is that it takes a lot of screen space, beyond what visible, instead of resizing to fit the appropriate available space.
Like here:
GameMakerStudio_2017-03-01_16-46-34.png

VS
here:
GameMakerStudio_2017-03-01_16-47-08.png


I find myself having to lower the dpi too much just to make the windows fit, or resize every window, every-single-time-I-open-them.

Beyond that, i think the dpi setting solves the "font" part of the problem, mostly anyways.
 

Kios

Member
Thanks, I just changed the setting so it opens in fullscreen mode however it doesn't seem to work for some reason?
There are 3 options there, open scripts, shaders, and object events in fullscreen. You wanna make sure all of them are checked. Works great for me.
I think the standard way is fine for the most part, but for bigger projects going full screen will probably be better.
 

Kios

Member
Guys, recently i have found a good solution for my screen.
What I did was i moved both resources and the room editor tab to the left, making it a single column. I also minimized the output at the bottom, overall this opens up a lot of space for the main screen(workspace and co.). With that I kept the dpi on 91, down from 96(100%). And activated fullscreen coding.

With this layout and settings, my lappy with 1366x768 is finally usable and feels great. I suggest you guys give this a shot.
 
Top