• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Mac OSX GMS2 problems on the Mac. IDE possible error/glitch?

1) Does anyone else have problems updating their IDE on the MAC? GMS2 keeps resetting itself everytime I want to update to the newest version. (Use the image below as a reference to this question.)

Screen Shot 2017-09-25 at 12.14.28 AM.png
 

gnysek

Member
I have an issue in Windows version, that if you download a new runner, and open a new ide using "File > New IDE" it will switch back to previous one, so this issue may be connected. I've already reported it.
 
H

herrmartell

Guest
I also have this problem, and another one:
  • Preferences > Runtime Feeds > Master > Double click on 2.1.0.144 > IDE restart > Version No. still on 2.1.0.136.
  • Whenever the mouse pointer goes over anything that looks/is an image, the pointer freezes (but the real pointer keeps moving, until I move it out of the image zone)
What I've tried so far:
  • Restarting GMS2
  • Rebooting
  • Delete new runtime > Download again
My specs:
  • macOS High Sierra
  • MacBook Air 2015
  • 8 GB RAM
 
Last edited by a moderator:

codemouse

Member
Yeah I filed as bug in my own thread, could not get new runtime at all, always stuck on 136. Everyone in this thread should file a proper bug with log info, just to help YYG push this one up. :)
 
T

Tinjaw

Guest
Whenever the mouse pointer goes over anything that looks/is an image, the pointer freezes (but the real pointer keeps moving, until I move it out of the image zone)
I have seen the same thing since switching to High Sierra. It was not a problem in Sierra.
 

rwkay

YoYo Games Staff
YYG Staff
This mouse pointer thing, it appears to be a feature in High Sierra.... not sure if you can switch it off though...

Russell
 
H

herrmartell

Guest
I have seen the same thing since switching to High Sierra. It was not a problem in Sierra.
That is correct. I remember it clearly because I updated to High Sierra just a couple of minutes after I made a fresh install of GMS2. And that was not happening.

This mouse pointer thing, it appears to be a feature in High Sierra.... not sure if you can switch it off though...

Russell
How could that be a feature? Could you point me as to where do you get that information? I've been trying to Google it but haven't seen anything related to it. Thanks.
 
H

herrmartell

Guest
Maybe, but that particular issue comes from 2007, and since this was not happening a week ago, I'm inclined to think it's not.

I guess it is expected since the macOS IDE is so new, but I'm going to stay away from it until it's properly working.
 
R

RobbSnow

Guest
I also have this problem, and another one:
  • Preferences > Runtime Feeds > Master > Double click on 2.1.0.144 > IDE restart > Version No. still on 2.1.0.136.
  • Whenever the mouse pointer goes over anything that looks/is an image, the pointer freezes (but the real pointer keeps moving, until I move it out of the image zone)
What I've tried so far:
  • Restarting GMS2
  • Rebooting
  • Delete new runtime > Download again
My specs:
  • macOS High Sierra
  • MacBook Air 2015
  • 8 GB RAM
I edited the runtime JSON file by hand to set the newer version as the active version. Problem solved.
 
H

herrmartell

Guest
I edited the runtime JSON file by hand to set the newer version as the active version. Problem solved.
Just to confirm: is this solving the mouse pointer issue described earlier in another answer? Thanks for the tip!
 
Another having the mouse pointer freeze here. No solution found as yet.

Biggest problem I've found is that you con't resize workspace windows.
 
Last edited:
S

SpecTre

Guest
I edited the runtime JSON file by hand to set the newer version as the active version. Problem solved.
I also have this problem on my MacBook Pro and have reported it to YoYo. I also tried editing the JSON file but this does nothing and still loads .136 changing the JSON file back to what it was so not sure how you have managed this?
 
S

SpecTre

Guest
OK I have received word from Yoyo support and this issue was solved for me so for those still having the problem, do this to sort it:
(Oh and it seems it is from a corrupt runtime download.)

1 - Go into the folder - Users/Shared/GameMakerStudio2/Cache/runtimes
2 - Now delete both folders in there for runtimes .136 and .144
3 - Start GMS2 and it will install .136 again
4 - Go into the runtime preferences and now double click for .144 runtime
5 - .144 will now download and install
6 - GMS2 will now restart with .144

Great :)

Hope this helps.
 
Top