Windows GMS2 now suddenly taking much longer to launch a game

Discussion in 'GameMaker Studio 2 Community Tech Support' started by DoricDream, Jan 7, 2019.

Tags:
  1. DoricDream

    DoricDream Member

    Joined:
    Jan 7, 2019
    Posts:
    9
    I was working on my game the other day, and all of a sudden for seemingly no reason the project would take upwards of a minute to launch. The saving and compiling times are all the same - they're very quick. However, there's a 1-2 minute pause between when the compiler text displays all the text and when the project actually launches. I can't think of any reason this would be the case, my runtime has not changed at all (I am using the most current version) and this is the case with ALL of my projects.

    What is going on? Has anyone else had this issue? If possible, how do I fix? Should I just reinstall?
     
    LamePower448 likes this.
  2. FrostyCat

    FrostyCat Member

    Joined:
    Jun 26, 2016
    Posts:
    3,695
    I've never had this issue. The only reasons I could think of are overzealous antivirus software, Windows Update running a job in the background, or excessive HDD fragmentation.
     
    chirpy and LamePower448 like this.
  3. LamePower448

    LamePower448 Member

    Joined:
    Jan 2, 2019
    Posts:
    7
    First of all, I had this exact same problem and I did post a thread here too but since I didn't get a useful answer from anyone I tried fixing the problem myself and I did!

    So, first of all, uninstall your anti-virus program completely, especially if it's something like 360 total security or avast, go to your windows update settings and make sure to press check for updates and install them (do this after you have uninstalled the anti-virus) then restart your PC and everything will be fine.

    And please reply and tell me if it works with you too!
     
  4. chirpy

    chirpy Member

    Joined:
    Oct 6, 2016
    Posts:
    107
    I also had similar issues before; windows 10 task manager also told me it's something about windows defender getting nervous on gms2 folders and files (high disk operations, high cpu on antimalware service). I remember that I disabled things like Firewall / SmartScreen or excluded gms folders from them, but now I can't find any record. The SmartScreen tool also does not look the same to me right now, so I'd assume Windows Update did something about it.
     
    LamePower448 likes this.
  5. DoricDream

    DoricDream Member

    Joined:
    Jan 7, 2019
    Posts:
    9
    LamePower448 likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice