• Hey! Guest! The 40th (!!!) GMC Jam will take place between February 25th, 12:00 UTC to March 1st 12:00 UTC. Why not join in this very special anniversary jam! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

 GMS2 ignores windows default audio output settings

M

McWolke

Guest
Hey there,
i've found a little Bug/have a suggestion in GMS2.
I wanted to preview my sounds in GMS2 but somehow GMS2 played it on my speakers, not on my headset (which is the default), so i looked into the GMS2 settings.
There is an option to change the audio output device, but my default device wasn't chosen (which should be, because it's default on windows), instead my speakers where chosen. so i clicked on "default audio device", but that somehow didn't choose the windows default, but the currently applied option in GMS (so basicly it goes back to the previous option). so i changed it manually.
but now if i change my settings in windows, i always have to change it in GMS2 manually again. there sould be a "use windows default" option.
here's a little gif to show the problem:
https://i.gyazo.com/7a2b662ecfe8d3fba09b0f4faee4477e.mp4
is this already known? should i file this as a bug?
 

Mike

nobody important
GMC Elder
Look in audio preferences, you can set the device there.

Later versions of windows have totally changed how all this stuff works - it's horrible now.
 
Top