• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

OFFICIAL GMS2 Font Update 2.2.2

rmanthorp

YoYo Games Staff
Admin
YYG Staff
Beta IDE Release Notes
Beta Runtime Release Notes
Beta Opt-In FAQ
 (How to get on the Beta Channel)

This topic is for the discussion of issues relating to Font Editor. However, this does not replace our normal bug reporting system and you should report all bugs as normal using https://www.yoyogames.com/bug


Goal: Send us feedback and sample projects for when things do not work as expected. Any critical font managers we should be considering?

• Fixed being able to type characters in the Add Range textbox and have the IDE determine the range automatically
• Changed Freetype from 2.8 to 2.9.1 to fix various issues with specific fonts and how they rendered
• Added a new Preview window so you can see your generated font inside the font editor
• Added a new Generate button to refresh a font if it is updated outside GMS2 (also used for refreshing the preview window)
• Added support for detecting fonts installed to Windows's registry via some third-party applications
• Added support for not automatically regenerating a font if it comes from a 1.4 project, and you also cannot regenerate a font which is not actually installed - both of which stop unwanted font changes
• Please note you need to use 2.2.2 IDEs with 2.2.2 runtimes, otherwise, your fonts may not generate as you expected!

FreeType library update

• All platforms now use v2.9.1 of FreeType. Fixes incompatibilities with some fonts and should improve the rendering quality of others - requires 2.2.2+ IDE also, otherwise, your font might not look as expected!
 

immortalx

Member
Font detection seems to work nicely. I installed an OpenType font without closing the IDE and got a popup asking me to refresh the font cache. They are now detected properly in font selection dropdowns. Thanks for the fix!
 

Dan

YoYo Games Staff
YYG Staff
There is an updated beta release out now, so please update when you can - https://forum.yoyogames.com/index.php?threads/gms2-version-2-2-2-beta-release.58932/ for further info.

It doesn't contain any specific fixes for font functionality, as (amazingly) none have been reported so far, but it does contain very important stability fixes to stop code editor crashes which might be impacting on your use of the beta version, so we would strongly advise you update.

If you do have any font issues with this 2.2.2 update, let us know asap, please!
 
Hi thank you . Its good news about font . I have problem with typing in arabic string its shown as very tiny words , in the future does game maker support typing from right to left nativly. Thank you
 

Dan

YoYo Games Staff
YYG Staff
Unfortunately, not. This is something we experimented with way back at the start of GMS2, but were not able to finish off in the IDE or implement in the runner. There are currently no plans to resume this work.
 

immortalx

Member
I believe I found a bug (unless it's only on my end): If you try to edit an existing or newly created font resource, the font editor doesn't open at all.
I only found out now, trying to edit a font that was created with a previous IDE version. Then I tried creating a new font (in a fresh project) and still no font editor window appears. Went back to IDE 2.2.1.375 and it's working as expected.
Could someone please test this on his/her machine?
 

immortalx

Member
@Dan, my previous post above yours still applies for IDEv2.2.2.399 which I installed just now. Since no one tested what I suggested should I file a bug?
 

Dan

YoYo Games Staff
YYG Staff
Yes, please - sorry, we missed your post until I made mine, but I just asked one of the guys to test that now. Send in the ticket and include steps to create the issue, and we'll get that sorted before the stable. Thanks.
 

rIKmAN

Member
@Dan, my previous post above yours still applies for IDEv2.2.2.399 which I installed just now. Since no one tested what I suggested should I file a bug?
Just tested this for you in the new version and it worked fine for me.

Right clicked 'Fonts' in Resource Tree > Create Font
Font Editor opened up as expected.
Closed the Font Editor Window.
Double clicked the new font in the Resource Tree.
Font Editor opened as expected.

Are those the correct steps to test it for you?

New beta release out now (IDE v2.2.2.399 and Runtime v2.2.2.312)
  • Fixed the code editor offsetting region start/ends by +1
YESSSS!
It was worse than just offsetting by +1 btw, but this is the biggest fix of this release for me - thanks!
 

immortalx

Member
Thanks @Dan, I'll do that now.
Thank you very much @rIKmAN. Yes, those are the exact same steps. At my end the font editor doesn't even pop-up after Right click->Create Font (a font with a default name is created though). And a double-click after that still doesn't open it. May I ask what platform are you're running GMS on?
 

rIKmAN

Member
Thanks @Dan, I'll do that now.
Thank you very much @rIKmAN. Yes, those are the exact same steps. At my end the font editor doesn't even pop-up after Right click->Create Font (a font with a default name is created though). And a double-click after that still doesn't open it. May I ask what platform are you're running GMS on?
Hmm yeah that works fine here then.

I'm running the latest beta that was just released on a Windows 10 machine which is also fully up to date via Windows Update.

Are you on Mac?
 
Last edited:

rIKmAN

Member
Thank again @rIKmAN, I'm on Windows 10 (1809) too. I went ahead and filed a bug report. Thanks for testing it!
No problem, might be worth trying it on another machine if you can to see if it's isolated to just that machine.
Also have a check of the UI.log to see if anything is logged in there regarding it?
 

Dan

YoYo Games Staff
YYG Staff
We got the ticket and can see a number of issues with layout files being wrong. We're also wondering if a custom IDE skin is being used, as that would now need to be updated to match 2.2.2 - in this situation, you'd need to contact the author of the skin and ask them to fix, then revert to the default skin while you wait for them to update the skin.

We're responding on the ticket as per normal, so this is just a public FYI in case anyone else has this same issue and so can check and fix their setup without needing to send us further tickets.
 

immortalx

Member
@Dan, that was it! It was a custom skin I've made. I feel terribly sorry for the inconvenience.
There seems to have been some changes in the files "font_edit.xml" and/or "font_edit_range.xml" in <skin folder>\Layouts. I replaced them with the default ones and now the font window is back. Once again thank you very much.
 

Dan

YoYo Games Staff
YYG Staff
Ahh, I have just sent you a reply on the ticket ;)

In short, can you send us your skin in the broken state, please?
 
S

SVG

Guest
I submitted a bug.
Custom font when drawing the number "9" acts as if it's spacing gets ignored with any other character that follows it, and draws right on top of that number 9. I included sample project in the bug report.
I just wanted to add that I don't know if this issue happens with any other characters, so far I only noticed it with the number 9 since my font only needed numbers and the "/" symbol.

EDIT: Seems that the latest update I did today fixed that number 9 customer font issue. However just for the fun of it I tried adding other characters, letters this time. The same problem persists with letters, maybe even all of them, I got impatient after testing a - d lol. Symbols and numbers mostly seem okay, but again I did not test all the symbols or even all the letters.

EDIT AGAIN: Now the number 9 is doing it again after adding more sprites, I have no clue. I've had issues with custom font since before the beta anyways.
 
Last edited by a moderator:
Top