• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android GMS Mobile compiler error.

I have a game I am working on for mobile. I have the mobile license and have all the SDK and other files linked properly and showing green. When I try compiling the game I keep getting this issue:

System.NotSupportedException: The given path's format is not supported.
at System.Security.Permissions.FileIOPermission.EmulateFileIOPermissionChecks(String fullPath)
at System.Security.Permissions.FileIOPermission.QuickDemand(FileIOPermissionAccess access, String fullPath, Boolean checkForDuplicates, Boolean needFullPath)
at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
at Igor.AndroidUtils.(String , String )
at Igor.AndroidUtils.(String , String )
at Igor.AndroidBuilder.Package()
Igor complete.

I checked every possible "path" for any form of invalid characters. I've looked through everything I can and this error gives no indication of where to even look. I've tried searching around for a fix. Google doesn't help. I find an old forum post here saying that it was fixed. I seen other Reddit posts saying the same issue and they magically fixed it but with no solution listed. I can't find anyone to help with this issue.

IT used to compile just fine before a recent update. Also Chrome is not allowing me to add a Prefix to this


How long is the path to the Android SDK? Not sure if that's it, but I do know there's a limit to how long that path can be.


Try to reimport your splash screens (Game Options -> Android -> Images).
Also your keystore path seems to be too long, maybe try to place it somewhere with shorter path.


I moved the keystone file, that didn't affect anything. I do not have any splash screen or art files set up yet so those are just default.
Even if they are default you should try to upload your own splash screens (just black pictures). There was a change in splash screens path and this could be a reason.


Try moving your keystore to a path that has no spaces in it, they can cause issues so try to stick to paths containing alphanumeric characters only (a-z, A-Z, 0-9 and underscores)

Remember to clean your cache before trying to recompile.