OFFICIAL GMS 2.3 Issues

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
Hello everyone! I'd just like to take a moment to suggest to users that are experiencing issues with the latest 2.3 update to GameMaker Studio to file bugs with YoYo Games instead of posting here on the forums. YYG does NOT check the forums for bugs, and as 2.3 is brand new the userbase does not have the knowledge yet to be able to help you debug your issues. When filing a bug report, and depending on the issue, please try to always include links to a zip of the bugged project and also (if it's a conversion issue) a link to the 2.2.5 project. Also try to give as much information as possible about when the issue occurs and even what you may suspect the issue is. This is a massive update to GMS and while YYG have thoroughly tested it and it's gone through a long beta process, everyone's project is different and there will always be edge cases that need extra attention, so PLEASE file bugs so they can get resolved.

You can file bug reports from the GMS2.3 IDE by going to the Help menu and using the "Report a bug" option, or by going to the following link: https://accounts.yoyogames.com/contact-us
 

EvanSki

Raccoon Jam Host
When converting a project to 2.3, it confuses bracket folding and region folding requiring you to rewrite all your #region 's

-Bug reported-
 
Last edited:
  • Like
Reactions: GDS
I've just sent a report on the "questionable" new folding. It's not a bug, it's a reported feature. And it can't be turned off.
Have fun having every single if statement be folded into a region.

Also, If anyone else is having trouble with save / load scripts? Scripts are now loaded globally at the start of the game,
and it completely messed up my save systems.
 

Attachments

EvanSki

Raccoon Jam Host
I've just sent a report on the "questionable" new folding. It's not a bug, it's a reported feature. And it can't be turned off.
Have fun having every single if statement be folded into a region.

Also, If anyone else is having trouble with save / load scripts? Scripts are now loaded globally at the start of the game,
and it completely messed up my save systems.
It should really have an option to be turned off,
as for the scripts make your old scripts a function and they run like they used to, basically just add function (name of script) { at the start then close it with a }

edit: the function () should already be added by default when converting your project.
 
Last edited:
I think I'm also going to send in a report on certain object functionality.
I don't know why, but in so many cases
Object.Variable
completely crashes my game.

Can this no longer be used?
 

GapingPixel

Member
As I reported from the beta, 2.3 is still failing to convert some larger projects, even tho gms shouts "conversion successful", the new project folder will only have an empty options folder. Already send a ticket.
 

curato

Member
It should really have an option to be turned off, as for the scripts make your old scripts a function and they run like they used to, basiclly just add function (name of script) { at the start then close it with a }
I am glad you said that it will save me a lot of time when I get home. I would have assumed it would convert those automatically.
 

EvanSki

Raccoon Jam Host
I think I'm also going to send in a report on certain object functionality.
I don't know why, but in so many cases
Object.Variable
completely crashes my game.

Can this no longer be used?
accessing a variable through an object is still being used, they even use it in an example for the new functions, I'd check your project

I am glad you said that it will save me a lot of time when I get home. I would have assumed it would convert those automatically.
It should by default
 

Sinryuko

Member
Did they make changes to Included Files? I had ini files there for dialogs and save data. I couldn't find anything about them in the official changes post, but they are non-existent in my resource tree. Even tried searching for the files in the tree. It did crash on me while converting my project, but opened afterwards and everything else seems okay. Without the Included Files, my file paths are no longer correct so my game just gives my default error values. Was just gearing up to release a demo =/

Edit: Okay, found a Reddit post that directed me to the triple bar expand button where they are located. Still not sure why the paths are not working anymore. I reference the file locations as:
working_directory + "txt_if\\txt_if_dia\\txt_if_dia_bed\\txt_if_dia_bed_matt_0.ini"

Edit2: Hmm, seems like the pathing is correct, but something else is mucking up some of my reads as some parts are being read. It's the weirdest thing. I've checked the files, and they seem fine. Even redid the conversion process, getting it to finish without crashing the second time. I made a debug draw message that looks at one of the ini files, and only certain key values are returning my default error message (all of which worked before 2.3). Also, certain sections are not working.
For example, it's reading a section named "Repeatable_1_1",but not the section named "Repeatable_1". (tested using the strings themselves in the draw event in the following code). It's also not reading "Response_1", but reads "Response_1_Chosen".
// Notes: statement_target is a variable I fill with the section it's looking at. That still fills correctly, so it seems like a ini_read_string problem.

ini_open(working_directory + "txt_if\\txt_if_dia\\txt_if_dia_bed\\txt_if_dia_bed_elo_0.ini");
draw_text(view_x+450,view_y+80,statement_target);
draw_text(view_x+450,view_y+100,ini_read_string("Repeatable_1_1","Statement","Error"));
draw_text(view_x+450,view_y+120,ini_read_string("Repeatable_1_1","Target_Emotion_0","Error"));
draw_text(view_x+450,view_y+140,ini_read_string("Repeatable_1_1","Response_1_Chosen","Error"));
draw_text(view_x+450,view_y+160,ini_read_string("Repeatable_1_1","Response_1","Error"));
draw_text(view_x+450,view_y+180,ini_read_string("Repeatable_1_1","Player_Emotion_1","Error"));
ini_close();

I'm thinking maybe it has to do with the names being substrings of the other names. Gonna test it out and will post my findings/file a bug report if that's the case.

Edit3: Hmm, changed the keynames to be more unique (not substrings of others) and the same ones are still giving me problems. I know I've updated the sandboxed files properly because it reads changes to other keynames that were also working before (despite the changes in the code would of made those fail if it was reading an old file. I have no idea, gonna keep poking around, maybe even just try JSON files instead.

Edit4: Found one interesting thing that leads me to think its a bug. I noticed that everything messed up is preceded by a real variable. So to test that theory, I found that adding an empty string variable or an extra space after the line after my reals and it fixed all of them. Submitted a bug report.
 
Last edited:

RujiK

Member
Some of my code is inaccessible due to a scrolling bug. No matter how small I scroll, the IDE just skips over 1200 lines of code. You can see in this gif:


This is very annoying :mad: Why are my 1200 lines of code being skipped? (I filed a report. EDIT: Bug was reported and yoyo confirmed it. Probably fixed in the next update. )

Also my game FPS dropped big time from 100 > 60 FPS. I think this has to due with vertex buffers and possibly shaders.

(Also please make auto code-folding OPTIONAL)
 
Last edited:

EvanSki

Raccoon Jam Host
Some of my code is inaccessible due to a scrolling bug. No matter how small I scroll, the IDE just skips over 1200 lines of code. You can see in this gif:


This is very annoying :mad: Why are my 1200 lines of code being skipped? (I filed a report)

Also my game FPS dropped big time from 100 > 60 FPS. I think this has to due with vertex buffers and possibly shaders.
I had an issue where it just wouldn't scroll at all, exiting the project and reopening fixed it for me
 
Some of my code is inaccessible due to a scrolling bug. No matter how small I scroll, the IDE just skips over 1200 lines of code. You can see in this gif:


This is very annoying :mad: Why are my 1200 lines of code being skipped? (I filed a report)

Also my game FPS dropped big time from 100 > 60 FPS. I think this has to due with vertex buffers and possibly shaders.
Same here, I used to run my game at very good framerates, on laptops of variable degrees of power. Now, it only runs smoothly on higher end laptops.
I really don't need a powerful gaming laptop to run a 2D top down GMS2.3 game... There's definitely issues there.
 
I only briefly looked through the settings, but is there a way to make middle-clicking a function open the manual within GMS2 again instead of opening up a tab in my browser?
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
I only briefly looked through the settings, but is there a way to make middle-clicking a function open the manual within GMS2 again instead of opening up a tab in my browser?
Nope. The old way relied on Google CEF And that's being removed from GM as it causes multiple issues elsewhere. So, sorry, the manual will now always open in the default browser.
 
I know that 2.3 has only just released, but is there an ETA on when the online docs will be updated to the new version: http://docs2.yoyogames.com/
Just wondering as I use that whenever I am away from my dev machine, and especially when confirming my responses to people when they raise issues on the forum.
 

Gunner

Member
Just file a bug report as you would any other issue with GM. :)
Hmm when doing a Ctrl + T search, the result doesn't appear spontaneously like in 2.2 somehow? There's like a 500 ms delay after each key press for the result to appear.

Also with included files, gone is the ability of being able to delete/open included files like it used to?
1597863373969.png
Like this
 

Samuel Venable

Time Killer
I would like to point out half of my extensions that imported from the marketplace correctly in GMS 2.2 now I'm seeing missing dylib and so libraries in 2.3, which is weird because the windows dll's are importing, just not the Mac or Linux libraries for certain assets. Really odd.

Only seems to be a problem with my libraries that have the "lib" prefix in their filename.
 

rIKmAN

Member
Also with included files, gone is the ability of being able to delete/open included files like it used to?
In 2.3 you are meant to use the standard OS filesystem, so just open the folder in explorer and delete / open from there and the IDE will update automatically.
 

clee2005

Member
I'm finding our games broken in 2.3 for iOS. Did the FileSystem change in some way? It seems to be unable to open files that were delivered in the Included Files (they are in the bundle - I checked in Xcode, so they are still actually included by GMS2). The code that was working in 2.2 to read the these .json files or .txt files no longer works in iOS. It works ok in Windows and Android, but broken in iOS.

It says unable to open... so I guess it is finding it... The files are fine, and this is production code that's been running for years.

GML:
2020-08-20 08:09:00.265936-0400 WordWow[1335:604281] ERROR!!! :: Failed to open file: /var/containers/Bundle/Application/B1E01CE8-C97E-4E84-B51D-5CA10BB0C098/WordWow.app/games/WordWow.json
Triggered from :
Code:
f = file_text_open_read(working_directory + csvFile);
I tried removing the working_directory as well and just referencing the filename directly, but that made no difference.

EDIT : Ok, it seems that 2.3 requires that "datafiles/" preface any folder and filename that you wish to access in iOS. eg. file_text_open_read(working_directory + "datafiles/" + csvFile); Specifically for iOS, I think if you leave that in for other Exports it might fail. Reporting bug.

Thanks,
Chris
 
Last edited:

MikiManoj

Member
I import my (big) project into 2.3 without any issues during importing. When I run the game it runs fine (might seems like few fps are lost but have to confirm). However, when my player dies and restarts all physical properties for all objects in the game are lost. I never experienced this issue before. This happens for both objects that have in code physical properties set and those that have it through UI. To go around it I would reset physical properties during room start which works as a temp solution but then it seems like the project gets corrupted. I'm reporting a bug as we speak.

Has anybody else experienced issues with physical objects?
 

EvanSki

Raccoon Jam Host
Middle clicking asset_has_any_tag() just takes me to the default page in the Manuel, looking even more, it doesnt even have a page
 

RizbIT

Member
The old GameMaker resource tree and its fixed “by resource” layout has been removed and now GMS2 has the Asset Browser. You can now create any resource type at any place in the tree, create multiple resources at once using the new Create Assets menu at the top, add Tags to your resources, and sort the tree A>Z/Z>A or your own custom order.
Oh come on...no

why this had to be changed
 

Samuel Venable

Time Killer
Oh come on...no

why this had to be changed
They copycatted a copycat product, as someone else put it. You see this sort of thing happen a lot. Apple copies features the open source community came up with, and vise versa. I don't want to be any more specific than that. The rest is up to your interpretation.
 

RizbIT

Member
on a plus note i like the sound of Sequences but looks like will take some time to learn to use, i hope theres some good videos on it
 

AivanF.com

Member
I have a bought full version of GMS2, I waiting for a year this brand new version with new cool GML features (though most of other languages have these features since 90s), and now, after installing and converting my project to the RunTime of _release_ version 2.3 I cannot compile my project because of "System.IO.IOException: Too many open files" error. This is really annoying!! Thus, I have a couple of Qs:

1. How can I track the issue progress? I only see the "Reported" status on the "Contact us" page, which is not enough at all. I cannot find it on the Issue tracker: https://bugs.yoyogames.com/view_all_bug_page.php
2. What are the plans for this problem? Any expectation date?? It's not a beta version, and such huge problems aren't acceptable for production "ready" software which is promoted on all your pages and always suggested in older versions of the IDE.
3. It also would be great to have a link on your website to download older versions. For now, I have to extract URL of the current version and substitute numbers from the change log page. It's not cool, especially when so many bugs are known and expected.
 

Lukan

Gay Wizard Freak
Is there a way to turn off the nag screen for updating? I need to stay on 2.2 for my project as it's quite old. I'd rather stay on 2.2 for the duration of development, and not be yelled at about it by the IDE.
 

AivanF.com

Member
I'm having the exact same issue. How are you accessing the URL of the current version to swap it?
Hi, Andrew! As I said, the link can be obtained in a quite simple way, just substitute the last stable version number (which is 2.2.5.481 by the change log page) into the URL of new version (gms.yoyogames.com/GameMakerStudio2-2.3.0.529.pkg), so you get this: http://gms.yoyogames.com/GameMakerStudio2-2.2.5.481.pkg
It's worth to mention that I use MacOSX, but I'm sure it's the same easy to find a link for Windows version if you need. Though I guess the Mac version is much more buggy and popular for rolling back.
 

clee2005

Member
You can rollback to previous versions from the Release Notes page. At the bottom you'll see "Older Versions".... you can then just click on the header which will download the .exe of that version : http://gms.yoyogames.com/ReleaseNotes.html

I'm doing this now, as iOS is completely broken. All my previous code for checking for existing files, and reading them from the filesystem no longer work. I tried to work around it, but it seems that the file_exists and file_read functions are not in sync and it's too much work to try and figure out exactly what's not working. I'm hoping YoYo looks at the ticket I filed and figure out what's gone wrong with it, because it's VERY broken.
 
I'm not sure if this has been reported or not, but I recently tried the marketplace. Pressing on the "I've read and agree to this EULA" doesn't respond (doesn't go to next step). Tried from inside v.2.3 stable IDE's marketplace, which opens in Chrome. Same case with apps marked for v.2 and v.2.3 (didn't try with those for v.1.4).

edit:
Somehow it was not possible when using Chrome, even when download via yoyogames.com instead from IDE v.2.3 as my IDE will open the site from Chrome. Didn't occur in v.2.25. When tried on Edge, it works fine. Something is causing this blockage on Chrome, but I haven't manage to find the cause. Site and IDE have all the clearance it needed. 🤔🤔🤔
 
Last edited:
I am importing a lot of sprites. Being able to stretch out frames of animation for them is awesome! However, all of that data gets destroyed when i re-import sprites. Would it be possible to preserve the timing?
 

Feronar

Member
When I open my project, I get a whole bunch of "Blank IdReference found - could be that the project is corrupt." warnings, but my project opens, builds, and runs just fine. Is there a way to fix those?
 

Biscotto

Member
Is it normal that every time I reopen my project, I have to manually close all the #regions I previously closed?
I don't remember if this problem was also present in version 2.2.x, but keeping the regions closed after saving would be very useful.
 
Does switching of Spine animations work properly for anyone? It always flips back to the first frame of the first animation when trying to switch animations. That happens in a new project as well as a converted one, so I'm assuming it's reproducible but I'm not sure if I'm not just missing something.
 

Sinryuko

Member
Does anyone know from past major updates about how long it takes for a patch to come out? Will they release bug fixes sooner on the beta versions? I'm sure they have a lot to fix right now. I encountered four bugs myself that I reported or found were already reported. Just debating on whether I should just go back to a previous version temporarily while it's all being figured out.
 

Ultigonio

Member
I've had a couple of confusing issues crop up

One is that the auto-tile code I've been using for walls in my game is now completely broken:
GML:
    // GM efficient Auto-tile sprite script
// Original script by Taylor Lopez
// See the original script on Git Hub: https://github.com/iAmMortos/autotile


    img_height = sprite_height;
    img_width = sprite_width;

    u = 0;  // up
    r = 0;  // right
    d = 0;  // down
    l = 0;  // left
    ul = 0; // up-left
    ur = 0; // up-right
    dr = 0; // down-right
    dl = 0; // down-left

    // Check adjacent side existence
    if (position_meeting(x,              y - img_height, object_index))  u = 1;
    if (position_meeting(x + img_width,  y,              object_index))  r = 2;
    if (position_meeting(x,              y + img_height, object_index))  d = 4;
    if (position_meeting(x - img_width,  y,              object_index))  l = 8;

    // Check corner existence
    if (position_meeting(x - img_height, y - img_width,  object_index))  ul = 1;
    if (position_meeting(x + img_height, y - img_width,  object_index))  ur = 2;
    if (position_meeting(x + img_height, y + img_width,  object_index))  dr = 4;
    if (position_meeting(x - img_height, y + img_width,  object_index))  dl = 8;

    edges = u + r + d + l;
    corners = 0;

    if (u && l) corners += ul;  
    if (u && r) corners += ur;
    if (d && r) corners += dr;
    if (d && l) corners += dl;

    switch(edges)
    {
        case 0: image_index = 0; break;
        case 1: image_index = 1; break;
        case 2: image_index = 2; break;
        case 3:
            switch(corners)
            {
                case 0: image_index = 3; break;
                case 2: image_index = 4; break;
            }
        break;
        case 4: image_index = 5; break;
        case 5: image_index = 6; break;
        case 6:
            switch(corners)
            {
                case 0: image_index = 7; break;
                case 4: image_index = 8; break;
            }
        break;
        case 7:
            switch(corners)
            {
                case 0: image_index = 9; break;
                case 2: image_index = 10; break;
                case 4: image_index = 11; break;
                case 6: image_index = 12; break;
            }
        break;
        case 8: image_index = 13; break;
        case 9:
            switch(corners)
            {
                case 0: image_index = 14; break;
                case 1: image_index = 15; break;
            }
        break;
        case 10: image_index = 16; break;
        case 11:
            switch(corners)
            {
                case 0: image_index = 17; break;
                case 1: image_index = 18; break;
                case 2: image_index = 19; break;
                case 3: image_index = 20; break;
            }
        break;
        case 12:
            switch(corners)
            {
                case 0: image_index = 21; break;
                case 8: image_index = 22; break;
            }
        break;
        case 13:
            switch(corners)
            {
                case 0: image_index = 23; break;
                case 1: image_index = 24; break;
                case 8: image_index = 25; break;
                case 9: image_index = 26; break;
            }
        break;
        case 14:
            switch(corners)
            {
                case 0: image_index = 27; break;
                case 4: image_index = 28; break;
                case 8: image_index = 29; break;
                case 12: image_index = 30; break;
            }
        break;
        case 15:
            switch(corners)
            {
                case 0: image_index = 31; break;
                case 1: image_index = 32; break;
                case 2: image_index = 33; break;
                case 3: image_index = 34; break;
                case 4: image_index = 35; break;
                case 5: image_index = 36; break;
                case 6: image_index = 37; break;
                case 7: image_index = 38; break;
                case 8: image_index = 39; break;
                case 9: image_index = 40; break;
                case 10: image_index = 41; break;
                case 11: image_index = 42; break;
                case 12: image_index = 43; break;
                case 13: image_index = 44; break;
                case 14: image_index = 45; break;
                case 15: image_index = 46; break;
            }
        break;
    }

The other is that, after importing my project to 2.3, one specific asset layer I was using for this "dither" effect has had many (but not all) of the contained sprites "shift" slightly, making for a visible seam between the dither sprite and the solid color sprite
1598382629315.png

This is made more confusing by the fact that, when I select one of the "misaligned" sprites, the guide seems to indicate that they're already in the right place. And no, this has nothing to do with the origin being off, as far as I can tell - again, only a portion of the dither sprites seem to be affected by this bug

1598382942931.png
 
Last edited:

red0r

Member
I think I'm also going to send in a report on certain object functionality.
I don't know why, but in so many cases
Object.Variable
completely crashes my game.

Can this no longer be used?
Hmm, I'm experiencing something similar. Going to debug but having major issues with calling .object_index once having it under the breakpoint. Instant crash.

Also unable to modify variables, even after a fresh install of 2.3. Hmmm, will investigate more before a bug report.
 
Top