1. Hey! Guest! The 36th GMC Jam will take place between February 27th, 12:00 UTC - March 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice
  2. NOTICE: We will be applying a Xenforo update on Tuesday 25th of February. This means that from approximately 10:00 to 14:00 BST the forums will be offline (or possibly longer). Sorry for the inconvenience! Official Announcement here.

Android GMS 1.4 has a BIG problem with fps

Discussion in 'Legacy GameMaker Community Tech Support' started by Blual, Mar 30, 2017.

  1. Blual

    Blual Guest

    To sum things up: I'm working together with a friend on a mobile game for Android. I'm a designer, he is a coder, and we're working with gms 1.4.
    I still own gm8 and I've noticed some bull****:
    -a project imported from gm8 and then compiled with GMS1.4 runs fine on android 6 devices
    -a blank room made from scrap only with GMS 1.4 runs less than half fps (our target fps is 60, a blank room has 22-23 top)

    How is a project converted from gm8 to gms 1.4 much better than a new project created with gms 1.4? We've been going through optimization at first, then we noticed gms 1.4 cannot run a freaking BLANK, EMPTY ROOM on android 6 devices, but a project that was converted from gm8 and then packed for android in gms 1.4 runs JUST FINE.

    Is there some passages we're missing during compilation? We've tried countless combinations (I'm not the coder though, I only know so far about coding and even less about android packages) but nothing seems to work so far. And this whole thing doesn't make any sense at all to me.

    Suggestions? I don't really have much more info except that we used the same configurations for both new and imported projects, and new projects, even if blank, do not run well on Android 6 devices.
     

Share This Page