• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GMS 1.4. executables suddenly all run much slower

I tested earlier this week, and all was fine, at least so it seemed.
Tonight as i tested my projects, they were all running slower than usual. Much slower in fact.
Can it be that a recent Windows Update caused this? I cant think of anything else that might have directly caused an issue such as this...
A huge chunk of my C: drive space has suddenly disappeared in the past day, so I assume its the Windows update, or can it be a memory leak...?
Gets me paranoid! Maybe Ill try and de-install the most recent windows update and see if it changes GMS 1.4. behavior... Unless you guys can think of any other reasons for GM behaving like this?
thanks beforehand!
 

TsukaYuriko

šŸŒ 
Forum Staff
Moderator
Did you perform a Windows update recently? If so, the most recent Windows 10 update (2004) is known to cause massive slowdown in all sorts of games. Turn off the new "Game Mode" feature to hopefully resolve this, or alternatively roll back to the version you were previously using.
 
Did you perform a Windows update recently? If so, the most recent Windows 10 update (2004) is known to cause massive slowdown in all sorts of games. Turn off the new "Game Mode" feature to hopefully resolve this, or alternatively roll back to the version you were previously using.
Hi, I tried both of these, but it didn't help. I turned off Game mode but I cant roll back the most recent update any longer since the Windows.old file is missing. (i deleted it since I thought it took so much space it might help?) I did try a restore point, and also I uninstalled the most recent updates. That didn't help either.
I do have the Windows 10 2004 and can't roll back. Can this really be causing it all of a sudden, although the 2004 update is already older, right?
Is there any other ways to resolve this, either Windows or GameMaker-wise?
 
I found a relevant post: https://forum.yoyogames.com/index.p...ndows-update-on-both-gms-1-4-and-gms-2.79322/
If its really caused by this, a Windows update, should I wait for another update to fix it (apparently happened earlier, last year was similar issues for some GMS users, and the next update fixed em) ?
EDIT: I found out about the whole 'Sleep margin' thing in GMS Settings. So if I change the value of that, it should fix the issue, but one thing bugs me: even if it does and my games again run with the correct speed, does it make the games run in hyper-speed on anyone else's machines?
 
Last edited:
Top