HTML5 GMS 1.4.9999: HTML5 errors with empty room project

Discussion in 'Legacy GameMaker Community Tech Support' started by fedeali, Aug 24, 2019.

Tags:
  1. fedeali

    fedeali Member

    Joined:
    Apr 11, 2017
    Posts:
    11
    Using last version, GMS 1.4.9999, creating a new project with only an empty room and running as HTML5:
    - When the game loads, the following error logs to web console:
    Call Stack contains only:
    - After the game is loaded, when the user clicks for the first time on the canvas, the following error logs:
    Call Stack:
    Is someone achieving to make HTML5 games with GMS 1.4.9999? I remember I had (almost) no problems with older versions.
     
  2. FrostyCat

    FrostyCat Member

    Joined:
    Jun 26, 2016
    Posts:
    4,455
    The HTML5 export worked just fine the last time I tried it. Unless the error is from a blank-room project, it's probably something in your code. Even then, you should expect to work around it yourself as GMS 1.4 is well past sunset.

    If you want to know where the error is from, run your project under debug mode (F6). Any errors from outside the runner's core will show its unobfuscated name in the stack trace. Be it GMS 1.4 or GMS 2, it's normal for the HTML5 export to be intolerant to some code that native exports forgive.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice