1. Hey! Guest! The 36th GMC Jam will take place between February 27th, 12:00 UTC - March 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice

GML run this game in debug mode does anyone know?

Discussion in 'Programming' started by barshems, Jan 31, 2017.

  1. barshems

    barshems Member

    Joined:
    Oct 7, 2016
    Posts:
    78
    hi I don't know if there was recently an update to game maker that I missed the notes for but recently when I click the debug mode it checks to connect to a server. it never did this before, in addition my game now runs at 20 megabytes of ram higher than it did before and all I did was add 1 object!

    anyone know anything about this?
     
  2. Jabbers

    Jabbers Member

    Joined:
    Jun 21, 2016
    Posts:
    213
    Not really a programming issue which is probably why you aren't getting many replies.

    What version of GameMaker are you using? The debug module has been in GMS 1.x.x for years now. The connection window is normal, is it possible you just never noticed it before?

    As for the memory usage, I wouldn't worry. Blank GameMaker projects aren't really blank. There is a lot of "engine stuff" going on in the background. As long as you are using the latest stable version of GameMaker, you should be fine.
     
  3. CoderJoe

    CoderJoe Member

    Joined:
    Jun 22, 2016
    Posts:
    166
    Plus, I think when you compile your game for release, it should (I think) use less memory as well.
     

Share This Page