• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GML 1.4.9999 not compiling ANYTHING.

Previously installed GML 1.4.9999 off of the beta channel and I'm having strange issues that my friend certainly is not having.

I am trying to create a very simple baseline for a project and I'm trying to get it to run and I noticed that it was failing to compile. The main thing that confused me was the fact that it had no error code visible.

This is the window it gave me, for reference.
GMLError1.png

I found this strange so I dug around and messed with some files, used the sweeper neurotically and nothing worked. I uninstalled and reinstalled GML twice and still the problem persists.

After theorizing that the game's files weren't the issue and was rather the install, considering that I'd ruled it out much earlier after I had uninstalled and reinstalled twice, I asked a friend for the files of their game and tried to see if I could compile it. Surprise surprise, the same thing happened.

This has me firmly believing that GML either is installed incorrectly somehow, there is a problem with GML and my computer itself, or God hates me. Potentially all of the above.

Any and all help is appreciated. I'm very new to this and am trying to figure it out as I'm writing. Thank you.
 
I'll attempt that right now.

Update: No. I absolutely can not. After making a basic room and nothing else, I literally can not compile just that.
 

FrostyCat

Member
Copy everything from the Compile Messages > Compile tab at the bottom, and look for anything that says "error" or the like. That will tell you what's wrong.

You should also be more specific about which export you are using.
 
This is the message I get

Compile started: 4:51:26 PM
"C:\Users\Super\AppData\Roaming\GameMaker-Studio\GMAssetCompiler.exe" /c /m=win /config="Default" /tgt=64 /obob=True /obpp=False /obru=True /obes=False /i=3 /j=4 /cvm /tp=2048 /mv=1 /iv=0 /rv=0 /bv=9999 /gn="Test" /td="G:\" /cd="G:\Documents\GameMaker\Cache" /sh=True /dbgp="6502" /hip="192.168.1.200" /hprt="51268" /o="G:\\gm_ttt_63728\gm_ttt_55031" "G:\Documents\GameMaker\Projects\Test.gmx\Test.project.gmx"

Asset Compile finished: 4:51:28 PM
Compile finished: 4:51:28 PM

There isn't a single mention of an error here anywhere, in fact it looks like it succeeded? I could be totally wrong, but after skimming over it once or twice, nothing looks wrong.

Also, if you could tell me where I could find which export I'm using, I'll get the info.
 
I'll try it out, thanks.

Update: No, downgrading did not work. It is still giving me the same problems.

GMLError1.png
Here's a screenshot with the version number in view.
 
Last edited:

gnysek

Member
Bump. Problem still isn't solved.
/td= param is set to G:\, causing output path to be G:\\, maybe try without backslash, only G: ?

I also found that every time you go into preferences one wrong backslash is removed from settings, so when opening preferences you might actally not see it anymore, but still press OK instead Cancel, as it seems it's removed from input not from real setting, so need to be saved.
 
Top