GM:S 1.4 GMDebug.exe won't open

Discussion in 'Legacy GameMaker Community Tech Support' started by marshallguy, Nov 24, 2019.

  1. marshallguy

    marshallguy Member

    Joined:
    Mar 24, 2017
    Posts:
    2
    Hi, I'm using the Steam version of GM:S1.4 (v1.4.1804) on windows 10, and the debugger won't start with the game. The runner application starts as normal, but the debugger window itself never opens.
    Code:
    Attempting to set gamepadcount to 12
    Start debug server
    Creating Debugger server port:6502
    [DbgServer]6502
    Sound_Init()
    Wave_Init()
    Unable to find output device "null" defaulting to "BenQ GL2250H (NVIDIA High Definition Audio) via DirectSound"
    Total memory used = 879823(0x000d6ccf) bytes
    ...Waiting for debugger to connect...
    I've tried:
    -reinstalling GM:S
    -restarting computer
    -disabling firewall
    -disconnecting ethernet
    -adding an exception in Avast for GMDebug.exe
    -opening a different project
    -opening the same project on a different pc (which worked, debugger started as usual)
    -copying the GMDebug folder from my laptop (where it works) to my pc
    -deleting the GMDebug folder and having steam validate files

    As best I can figure, something is stopping GMDebug.exe from opening, but it's not Avast or Windows Defender.

    Has anyone else had (and fixed?) this?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice