• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows GM2 2.3.2.556. Project takes ages to compile, all the is RAM used and, at the end, white screen.

IICIIEII

Member
Hello!

I have just updated to the last Game Maker version and I am experimenting a bizarre problem. Our project has quite a lot of sprites of very big size that, in previous versions, were rescaled without problems. Compiler was throwing the usual warnings but everything was fine. Moreover, until the update the project was compiling in one minute and a half when not in the cache and RAM usage was totally normal.

Now, when I try to compile GM2 uses more than 55GB of RAM, lots of CPU, takes 22 minutes and, at the end, it gives a white screen with some red lines. I managed to rescue my Windows session, but it was a very close call. Any idea of why is this happening? I saw that it is when rescaling textures and asigning them to groups.

Thanks!
 

Attachments

gnysek

Member
And that's why it's good to test beta and it's separate to stable version :p

This seems like something that need to be reported trough helpdesk, with project attached/linked (they are discrete about your project).
 

IICIIEII

Member
Thanks!, Yes, I will do that. Uploading the whole project is actually not a problem, even if it is more than 1GB. I am afraid that I will have to upload everything, since it is the safest way to replicate the problem...
 

rwkay

YoYo Games Staff
YYG Staff
Please file issues with us so we can analyse what is going on - I would advise you to clean the cache first and check AV settings (as sometimes the update process appears to confuse AV in various ways that causes problems)

Russell
 

IICIIEII

Member
Thanks! I was filling a ticket yesterday night with a link to the problematic project :). In the meantime, I uninstalled GM, stopped Karspersky, reinstalled and, after AV reactivation, I added Igor.exe to the exclusion list. I will be cleaning the cache now and try to recompile as soon as the computer finishes some other tasks it is doing.
 

IICIIEII

Member
So, I tried again and nothing... still stays the same. I stopped compilation when it was above 30GB of RAM, since I have the machine working in something else and I am afraid I may eventually get a crash. What I observed is that every time a texture is resized, the RAM is not freed, but the computer keeps allocating more and more for each new one.
 

Attachments

IICIIEII

Member
Hello! I just wanted to mention that the bug has been confirmed and it will be fixed in the future :) I guess I will be rolling back to the previous version in the meantime!
 

rwkay

YoYo Games Staff
YYG Staff
I did find an issue but it was not stopping the game from running just taking extra time - nothing that would cause the white screens that you are seeing. We are using the bug as a place holder just now to track the compiler slow down issues. I would check your Anti Virus settings to ensure that Igor and the Asset compiler have all the permissions that are required - I cannot see anything wrong with memory handling either so I have no idea why your are seeing astronomical memory usage (again please check Anti Virus settings).

Ensure that you have cleared the cache (using the broom icon) if that still does not work then please ensure that the GMS2CACHE directory has actually been cleared and there is nothing preventing that from happening - the cache directory should be in the Preferences -> Paths section (use Explorer to check that the directory is actually clear rather than relying on the Delete Cache buttons in preferences)

Russell
 

IICIIEII

Member
Hi! I will have a look tonight after work (sadly, I don't develop games for a living). In principle, I think the AV should be fine, since Igor is added to the exception list and, also, I tried installing the new GM version and compiling with the AV completely disabled and nothing changed. Clearing the cache did not solve the issue either but I did not manually check that the directory was clear, I just pressed the Broom. We have resized the problematic assets by now, but I still did not test the new build. It will be useful to see if it compiles with the new GM version :).
 
Last edited:

IICIIEII

Member
Hello! I reinstalled the last version again and I was manually cleaning the cache folders, as you mentioned. I found that there was a huuuuge amount of files and folders inside, no less than 50GB! Sadly, things did not improve when compiling in my machine: still lots of RAM used (I stopped Game Maker when it was above 55GB) and taking ages. I did not wait to see if I was getting the white screens or not, though. I can also confirm that the previous version works totally fine in my hands :). It is worth mentioning that some of the large assets were not erased from the project files by mistake, even if they are not used in the game, and the compiler was resizing them anyway. I will try a build without these tomorrow.
 

Attachments

Last edited:

IICIIEII

Member
Another update... I tried everything but no luck. I totally uninstalled my AV, cleaned everything, etc., but nothing, same problems with RAM and speed. I currently have some things running and therefore I won't be able to reboot the machine in the next 4 days, but I will try again as soon as I can do it.
 

Elevory

Member
Another update... I tried everything but no luck. I totally uninstalled my AV, cleaned everything, etc., but nothing, same problems with RAM and speed. I currently have some things running and therefore I won't be able to reboot the machine in the next 4 days, but I will try again as soon as I can do it.
Hey, I was having similar issues compiling for Android recently. Windows compile never gave me trouble though. For what it's worth, upgrading to GameMaker IDE v2.3.2.556, runtime v2.3.2.420, fixed the problem for me.

I also updated the firmware and drivers for my Samsung SSD. Any chance you're using a similar disk?
 

IICIIEII

Member
Hello! I have a few Samsung SSDs but the game files are in a Firecuda, so in principle I don't think that is the problem :D.

However, I rebooted the machine and managed to compile after the clean boot. That is very good news! It still took around 7 minutes the first time and used 27GB of RAM, though. RAM usage now is more in line with the previous versions but certainly is still very slow the first time compared with before, it takes around 2.5 times longer. Once the project is in the cache, compilation takes just 15 seconds, though.
 
Top