• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Linux GM:S v1.4.1763 Ubuntu Export Not Working

B

BabyDukaCPH

Guest
Hey forum

I have a bad case of :eek: regarding GM:S's Ubuntu build of my game Urban Pirate. I wonder if any Linux users/devs might know about this problem, or maybe you have experienced it yourself?

The export:


Recently our team ported an Ubuntu build of our game Urban Pirate. At first we tried porting the game with Ubuntu 16 but experienced some errors (unfortunately I did not keep the error logs) and decided to follow the instructions in the GM:S documentation exactly as written. So we made the build on a Linux comp running Ubuntu 14.04 and after the Linux package was done compiling we successfully launched and played almost the entire Linux version and it was smooth and flawless.
We didn't test it (our bad) on newer versions which we should've, of course.

I then uploaded and released the Linux build of Urban Pirate on Itch.io and Steam.

Itch and Steam:

1st problem: A user had downloaded the game from Itch.io but was unable to run it on his Ubuntu 16 system. He tried running the different sh-files and the runner and the install-file but the game wouldn't launch. The package he downloaded contains exactly the same files as the ones we just used on Ubuntu 14.04 with no problems. At that moment we thought the error could be related to graphics but when I heard users on Steam using Ubuntu 16 had issues launching the game, I became suspicious.
SOLVED: 2nd problem: Some Steam users reported that they had bought the game but had received an empty folder. No files at all. When I check the Builds-tab in Steamworks it's clear that the build containing the right depots (both the Windows and Linux depots)is the default folder. What's even more strange is that when I go to the traffic analyzer in Steamworks I can see multiple Linux users are active simultaneously on Steam meaning that those users have bought, downloaded and installed the game and are not experiencing errors. These users could be using Ubuntu 14.04 but I am currently unable to analyze whether that's true or not.

I hope someone might have stumbled upon this problem (I mean, of course I hope not but... you get it) and perhaps can tell me if this build is incompatible with Ubuntu > 14 ?? Where is the problem? How come the game is running on Ubuntu 14.04 and not on Ubuntu 16.

Here's a link to my Steam page and website.

Thanks a lot for reading! :banana:

Best,

Jakob
Baby Duka & Co.
 
Last edited by a moderator:
Top