Android "glMatrixMode:1560 GL err 0x502" errors with AVD

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Justice, Jan 8, 2019.

  1. Justice

    Justice Member

    Joined:
    May 8, 2017
    Posts:
    451
    When I run any GMS2 project (including a blank project) in an Android Virtual Device, it spams an error, "glMatrixMode:1560 GL err 0x502." I get this on both my laptop (Intel UHD Graphics 620) and desktop (AMD Radeon Pro WX3100). Both have Intel processors and have the latest version of haxm, Google's Android Emulator SDK, and the other SDKs. Except for the constant spamming of this error, it seems to work okay. I don't get this error until I run a GMS2 project. My AVDs' graphics settings are set to "automatic," which seems to mean "hardware-based graphics emulation." If I force software emulation, I don't get that error, but my game also does not display at all correctly. I've googled this, haven't found anything GM-specific, but people with similar areas in other contexts have resolved it by forcing software emulation, which won't work here.

    Any ideas what this error is about?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice