• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Linux Gampads not mapped under Ubuntu

A

AdamJ

Guest
I've been working on getting gamepads running under Ubuntu, but I've hit an odd problem. The gamepads are being detected but most are not usable due to an "Unable to find mapping for device" error. They appear in a slot, and show up in the terminal (with the mapping error) but I can't get any data from them. They are all identified under GMS2 in Windows, though. So far only one controller has been identified out of six attempted.

I've installed both jtest-gdk and joystick.

Running jstest shows that they are loading. I've calibrated each one, and jstest shows that the axes are being identified.
  • If Ubuntu is recognising the controllers, should GMS2 be able to recognise the mapping?
  • Can the mapping be fixed in Ubuntu? I'm happy to play with settings if this is possible, although it might cause issues with distribution.
  • Is there a way of detecting if the joystick in a slot failed to be mapped in GMS2?
  • Is it possible to manually handle the mapping in code with GMS2?
Thanks for any help. This looks like the last significant problem for a Linux port, but it is an ugly one so far.
 
C

CleanWater

Guest
Hi there!

Which controllers you used on your tests? I'm having a similar problem, but with GM:S 1.4.
I tried everything I could to make my controllers work, but nothing solved the issue. :bash:
 
Top