• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Gamepad support, Xbox One R-Trigger

A

Aero88

Guest
Hi, I am a long time user of Game Maker and I am running GM Studio. I joined the old forum probably back in 2007 or sooner, but apparently that old account wasn't carried over to the new forum.

Anyhow. I am running Game Maker Studio and have made my game compatible with Game-Pad support. My xBox 360 controller works flawlessly, however my play tester informs me that the xBox-One controller only partly works. He says the right trigger doesn't shoot or register at all. Of course as I mentioned it works great on the 360 controller so I am not sure if this is simply a case of Game Maker needing to be updated to support the Xbox One or if there is anything I can do programming wise. I am calling the R-trigger directly using the gamepad_button_check() functions. Any ideas how to resolve this? Thanks.
 

Roa

Member
directXinpute is universal. All devices that accept it work the same. If there is an error, its in the controller driver or gamemaker's interpretation of the device. I would file a bug report.

Are you sure the controller is fully functioning? Did you test its input in windows hardware settings from the control panel? I have a windows controller, a 360 controller, and an Xbone controller and they all seem to work as designed.
 
A

Aero88

Guest
Thanks for the feedback. All I have is a wireless 360 controller and as I mentioned it works great with the game. I will check to make sure my play testers controllers are indeed fully functional. I am wondering if drivers are somehow the culprit as he mentioned just recently that he tried a 360 controller now as well and it's right trigger didn't work for him either.

Strange. I'll have him test it in the windows hardware. If its working there I will submit a bug report.

One other point of note is that I am testing in windows 7 and he is using windows 10 so perhaps there is a driver difference there.
 
Top