• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GameMaker v1.4.1804 crashing and cannot compile

gdesign

Member
On Windows 10 4/27/2020 GameMaker started crashing multiple times.


Started the software today and while editing a basic object it started crashing.
GameMaker wound autosave and shut down. After 4 times of this, I finally finished editing the keyboard up, down, left, right object options.
Restarted the computer and tried to create a test room basic background and add walls.
Crashing started again before I could finish the top wall.
I added a controller object with basic ESC, next room, previous room options, and the charter object over 4 more crashes.

Then tried to compile and got the error could not compile check compile readout.

I tried to open and an old project from a book that was known to be working in v1.4.1804 and got the same message with this read out:

Compile started: 3:20:28 PM
"C:\Users\X\AppData\Roaming\GameMaker-Studio\GMAssetCompiler.exe" /c /m=win /config="Default" /tgt=64 /obob=True /obpp=False /obru=True /obes=False /i=3 /j=4 /cvm /tp=2048 /mv=1 /iv=0 /rv=0 /bv=1804 /gn="Bouncing Starfish" /td="C:\Users\X\AppData\Local" /cd="C:\Users\X\Documents\GameMaker\Cache" /sh=True /dbgp="6502" /hip="127.0.0.1" /hprt="51268" /o="C:\Users\X\AppData\Local\gm_ttt_69644\gm_ttt_88504" "C:\Users\X\Documents\GameMaker\Projects\Bouncing Starfish.gmx\Bouncing Starfish.project.gmx"

Asset Compile finished: 3:20:34 PM
Compile finished: 3:20:34 PM

After trying to recompile again it gave me the same error message and told me it could not find the win.exe file.

I am not sure what to do as nothing change between days and testing but Gamemaker started shutting its self-down and now the error messages.

Does anyone know how to fix the issue or have these same basic issues with GameMaker?

Thank you in advance for your time and help on this I am trying to
teach disabled students on the version of the software I own and
this just killed our teaching time.
 
Last edited:
Top