• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GameMaker:Studio Runner has stopped working

DukeSoft

Member
upload_2017-6-6_1-36-42.png

Since a couple of days this error pops up. Randomly. I'm running on the Windows target and it happens in both debug and regular mode. I do use git so I'll see what code I've changed recently and see if reverting bits helps...

As for now - any clue as to why this might be happening..? I get 0 feedback from the debugger or game maker itself..

I'm going to try to run on the Windows YYC now, and I'll try some exported executables as well.

EDIT: Also happens on the YYC runner builds.
 
Last edited:

DukeSoft

Member
Okay.. crap. It seems to be happening on a lot of older builds as well. Good that I havent noticed it yet, but bad that its in there. Its happening on multiple PC's.

Is there some way I could be able to find out whats going wrong..?
 
N

_nedR

Guest
I am getting this error on 1.4 too (ever since the recent update). Have you managed to fix it?
 

DukeSoft

Member
Get ready to grab your wallet again :)

I solved it by using GMS2. But be aware - I bought the HTML5 module for GMS2 but thats broken too, so I had to convert a bit of my project back to GM:S 1.4 and create the HTML5 project there (Spine is basically useless in GMS2 HTML5).

Overall its pretty ****. Paid 800$ for 1.4 which is no longer supported and has a crappy UI, paid another 300 for GMS2 + HTML5 which has a hidious interface, but at least its not laggy. Its erm. ****e :)
 

Startoz

Member
I have the same issue since version 1.4.1772 or 1.4.1767 (not sure because I updated directly to the last one).
The game crashes any time I pause it from the debugger or I hit a breakpoint. It never crashes when NOT in debug mode.
The only way I could get to pause the game without it crashing was to put a
Code:
show_message("whatever");
instead of a breakpoint, and then pausing the game from the debugger without closing the popup message. However this doesn't work in every situation...
 

klys

Member
You way to solve problems is crazy.

GMS2 is not the solution for GMS1. Its just a marketing product.

My GMS is working correctly.

If you want a YoyoGames Staff to reply you i recommend using the help desk https://help.yoyogames.com/

This is for user forum.
 

Adhiesc

Member
Excuse me, I just had this problem now btw.
And I switched my "Use Fast Collision System" Off in Global Game Configurations.
It works perfectly then.
Maybe this is what your problem was. But I'm not sure. just in case. :)
 
P

Paul Iloilo

Guest
I found a solution too. I had the same error and for me it turned out that the version was the issue.

I was trying to open my project on a computer where GameMaker:Studio had been updated to v1.4.18~ and it never worked. When I ran my project in version v1.4.1567 the game worked again with no errors.

So I decided to reinstall GameMaker:Studio, to restore it to the older version. The trouble is, during installation, it was automatically installing updates. I found out that I could quickly cancel the dialog box while it was installing updates and voila! It worked again!

Hope this helps someone else!
 
Top