• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows GameMaker: Studio is blurry in 1920x1080 Resolution

I bought a new laptop which has 1920x1080 resolution, which is different from the 1366x768 on my old laptop. I put GameMaker: Studio on my new laptop, and everything works fine, but the whole program is blurry. I've tried a few things already, and nothing seems to work. Can anyone help me?
 

rIKmAN

Member
I run 1920x1080 and don't have a problem, so it's almost 100% something specific to your laptop - drivers / setting / scaling etc.
 

GMWolf

aka fel666
Do you mean the IDE?
Its perfectly sharp on my 1080p laptop. Both on Intel and NVIDIA.
Are you using windows scaling? (If so... Its probably the problem)
 
Do you mean the IDE?
Its perfectly sharp on my 1080p laptop. Both on Intel and NVIDIA.
Are you using windows scaling? (If so... Its probably the problem)
My problem is I was able to fix the scaling for Steam and iTunes by going into the properties of the applications by right-clicking the icons and changing the scaling settings in the Compatibility tab, but when I go to the properties in GameMaker, there's no Compatibility tab, so I don't know what to do.

Maybe It's because I have GameMaker installed on my external hard drive...
 

rIKmAN

Member
Maybe It's because I have GameMaker installed on my external hard drive...
It isn't.

It sounds like you have global scaling set within Windows and are fixing it on a per app basis (Steam, iTunes).
Turn off Windows scaling and it will look normal - you won't need to use scaling now your default resolution is 1920x1080.
 
It isn't.

It sounds like you have global scaling set within Windows and are fixing it on a per app basis (Steam, iTunes).
Turn off Windows scaling and it will look normal - you won't need to use scaling now your default resolution is 1920x1080.
How do I turn off Windows Scaling??
 

rIKmAN

Member
No idea, never used it and I don't know what version of Windows you are using - try Google.
I would guess in your display settings in Control Panel, or your GPU driver settings.

However I just right clicked my GM shortcut and I have a compatibility tab where I can disable scaling, so not sure why you are saying GM doesn't have that option?
 

GMWolf

aka fel666
Its somewhere in the display options in the control panel.
As usual, its better to google things first before asking: you get better, more accurate answers faster that way. (And you save us some tping :) )
By default windows like to set scaling at 120~150% on 1080p laptops...
I dont like it. So i turn it off. You get smaller icons, but unless you have poor eyesight it should be ok
 
Its somewhere in the display options in the control panel.
As usual, its better to google things first before asking: you get better, more accurate answers faster that way. (And you save us some tping :) )
By default windows like to set scaling at 120~150% on 1080p laptops...
I dont like it. So i turn it off. You get smaller icons, but unless you have poor eyesight it should be ok
Thank you so much! I'm using Windows 10, so I went to the Settings app. Under System > Display, I set "Change the size of text, apps, and other items:" to 100%.
Here's a screenshot:



Hopefully this will help anyone else who has this problem! :D
 
Top