OFFICIAL GameMaker: Studio 1.4.9999 Released - FEEDBACK

Dan

YoYo Games Staff
YYG Staff
Android YYC gives following error when the game tries to run on the device:
"unable to find library for this devices architecture, which is armv7i, ensure you have included the correct architecture in your APK"

am I missing some install?

target:26, min:14, compile:26
build tools: 26.0.0
support lib: 26.0.0

ndk: 16b
jdk: 1.8.0_102

tried downgrading jdk and a number of sdk settings to no avail, android phone and tablet, same result.
All worked fine in 1804.
Is an issue with specific versions of Android (API 23 / Android 6.0 - Marshmallow) did not include all their architecture support files on the device, and instead relied on the build tools to provide them. Google no longer provide support for these files in current NDK build tools, and so you have the issue you describe. This is https://bugs.yoyogames.com/view.php?id=29323 which we have mitigated in GMS2 ahead of the next GMS2 release, but substantially changes the Android build tools and drops support for several Android architectures, so this change is currently not intended to come to 1.4.
 

Dan

YoYo Games Staff
YYG Staff
I have a big issue. Every, and I mean every, version after 1773 has caused problems with my audio stuttering/distorting, and none of the updates have fixed the issue (including the last one). So I stuck with version 1773.
Please send us the project in question and detailed info on your issue and we will fix the problem before we do the Stable release. Thanks.

We're not putting the old versions back on Steam, sorry - we're much more interested in fixing the current issue than supporting super-old releases with major IDE project saving bugs in... ;)
 

Dr. Wolf

Member
With further investigation, I have been able to narrow down the problem further. Seems to have to do specifically with when a sound played on an emitter is stopped.

When I run the following code:
Code:
time++;

if time == 10 snd = audio_play_sound_on(emitter, snd_coacoabeachproductions_rocket_loop, 0, 0);
else if time == 600 audio_stop_sound(snd);
else if time == 720 audio_play_sound(snd_foad_lightning, 0, 0);
else if time == 840 game_end();
The sound "snd_coacoabeachproductions_rocket_loop" plays a second time at time 720, instead of "snd_foad_lightning".

Quick project
 
B

BlackCobra

Guest
I have a problem with custom fonts. If I use ord() to get the index at which the font characters at which the sprites are starting my index is 2 high. Only occured since upgrade to 1.4.9999.
Its easy to work around by just adding "-2" but I figured I should let you know.
Code:
global.BitTextWhite = font_add_sprite(spr_fnt8BitWhite, ord("!")-2, true, 2);
 
Please send us the project in question and detailed info on your issue and we will fix the problem before we do the Stable release. Thanks.

We're not putting the old versions back on Steam, sorry - we're much more interested in fixing the current issue than supporting super-old releases with major IDE project saving bugs in... ;)
Okay, who do I send that to and what do I send? (I've never uploaded my project file to anyone)
 

lolslayer

Member
MRT doesn't seem to work anymore, my project suddenly gives this error:
Code:
Unbalanced surface stack. You MUST use surface_reset_target() for each set.
Small important note:
I call the two Surfaces in the draw begin even using this code:
Code:
shader_set(shd_depth);
surface_set_target_ext(0,application_surface);
surface_set_target_ext(1,global.surf_depth);
And I reset it in the draw end even using this code:
Code:
shader_reset();
surface_reset_target();
Thought it might make an important difference if the reset function wasn't called in the same event

PS: I tried to duplicate the reset function, but it gives me the same error
 
Okay, who do I send that to and what do I send? (I've never uploaded my project file to anyone)
Nevermind. I didn't exactly fix the problem, but I came up with a new way of doing things, so now my problem isn't really a problem anymore. Basically, I had a dialogue system where it would beep each time a character displayed (like a typewriter). The new updates were causing these beeps to be inconsistent(stutter). So instead of fixing the problem, I simply modified the sound itself to repeat itself until the text stops displaying. So instead of playing the beep for each letter, it plays the repetitive sound file for the whole text box and STOPS when the text stops typing or the text box is closed.
 

amysgames

Member
I have a problem with custom fonts. If I use ord() to get the index at which the font characters at which the sprites are starting my index is 2 high. Only occured since upgrade to 1.4.9999.
Its easy to work around by just adding "-2" but I figured I should let you know.
Code:
global.BitTextWhite = font_add_sprite(spr_fnt8BitWhite, ord("!")-2, true, 2);
Having this problem too. What's extra weird is it seems to vary between projects; my "font test" project requires no offset at all, but on one of my actual game projects, I had to add -6.

EDIT: Did some additional testing and it seems to be a problem specifically with font_add_sprite, as ord still seems to be working correctly.
 
Last edited:
L

Latisha

Guest
Can you open a Helpdesk ticket and send us your %AppData%\GameMaker-Studio\TraceIDE.log file, please. Right now, I'd suggest it's likely to be a firewall or other networking issue on your PC, seeing as other people can update and license fine, but we won't know until we see the log. Thanks.


EDIT: I have been told we have answered a couple of support questions about this issue already, and in each case the person had not accepted the current YoYo Account terms adn updated their account for GDPR compliance. Log in to accounts.yoyogames.com and accept the terms and update your account details. Then try GM: S again.
Thanks for the help but I do not see any updated Yoyo Account Terms when I log into accounts.yoyogames.com(As in the Account dashboard, looked at other tabs as well) Btw I'm using Gamemaker free.
Also heres the log
**************************************************************************************
GameMaker:Studio IDE v1.4.9999.45024
**************************************************************************************
Stacktrace/Exception handling - Enabled
Init #1
Init #2
Init #3
Init #6
Init #7
Init #7.01
Init #7.02
Init #7.03
Init #7.04
Init #7.05
Init #7.06
Init #7.07
Init #7.08
Init #7.09
Init #7.10
Init #7.11
Init #7.12
Init #7.13
Init #7.14
Init #7.15
Init #7.16
Init #7.17
Init #7.18
Init #7.19
Init #7.20
Init #7.21
Init #7.22
Init #7.23
Init #7.24
Init #7.25
Init #7.26
Init #7.27
Init #7.28
Init #7.29
Init #7.30
Init #7.31
Init #7.32
Init #7.33
Init #7.34
Init #7.35
Init #7.36
Init #7.37
Init #7.38
Init #7.40
Init #7.42
Init #7.43
Init #7.44
Init #7.45
Init #7.46
Init #7.47
Init #7.48
Init #7.49
Init #7.50
Init #7.51
Init #7.52
Init #7.53
Init #7.54
Init #7.55
Init #7.56
Init #7.57
Init #7.58
Init #7.59
Init #7.60
Init #7.61
Init #7.62
Init #7.63
Init #7.64
Init #7.65
Run
Analytics Thread Start
demo task closing state = 0
demo task started
remote tutorial task started
NewProject - FormOpen
Tips initialise started
Tips initialise finished
tutorial task finished
demo task finished
attempting login
attempting login
attempting login
attempting login
attempting login
attempting login
attempting login
attempting login
attempting login
attempting login
attempting login
Form closed - #1
Close button clicked on Welcome Screen - shutting down
Exiting
g_closing = -1
save achievements
killProcesses
HTML_Help_Close
CloseAll1Click
CheckChanged
Finished Form Close Query
g_closing = -1
save achievements
killProcesses
HTML_Help_Close
CloseAll1Click
CheckChanged
Finished Form Close Query
Quit_Steam
JclStopExceptiontracking
Finish GM:Studio
Preferences_Save
Reg_WriteBoolean
Finished Maker_Preferences_finalization
DestroyTempDir
Analytics thread end
Finish Support_File finalization
Sound_DirectX - CoUnitialize
finalization of Sound_DirectX finished
DirectSound - finalize start
DirectSound - finalize end
GDIAPI - finalize start
GDIAPI - finalize end
**************************************************************************************
GameMaker:Studio IDE v1.4.9999.45024
**************************************************************************************
Preferences_Save
Reg_WriteBoolean
Finished Maker_Preferences_finalization
DestroyTempDir
Finish Support_File finalization
Sound_DirectX - CoUnitialize
finalization of Sound_DirectX finished
DirectSound - finalize start
DirectSound - finalize end
GDIAPI - finalize start
GDIAPI - finalize end
**************************************************************************************
GameMaker:Studio IDE v1.4.9999.45024
**************************************************************************************
Stacktrace/Exception handling - Enabled
Init #1
Init #2
Init #3
Init #6
Init #7
Init #7.01
Init #7.02
Init #7.03
Init #7.04
Init #7.05
Init #7.06
Init #7.07
Init #7.08
Init #7.09
Init #7.10
Init #7.11
Init #7.12
Init #7.13
Init #7.14
Init #7.15
Init #7.16
Init #7.17
Init #7.18
Init #7.19
Init #7.20
Init #7.21
Init #7.22
Init #7.23
Init #7.24
Init #7.25
Init #7.26
Init #7.27
Init #7.28
Init #7.29
Init #7.30
Init #7.31
Init #7.32
Init #7.33
Init #7.34
Init #7.35
Init #7.36
Init #7.37
Init #7.38
Init #7.40
Init #7.42
Init #7.43
Init #7.44
Init #7.45
Init #7.46
Init #7.47
Init #7.48
Init #7.49
Init #7.50
Init #7.51
Init #7.52
Init #7.53
Init #7.54
Init #7.55
Init #7.56
Init #7.57
Init #7.58
Init #7.59
Init #7.60
Init #7.61
Init #7.62
Init #7.63
Init #7.64
Init #7.65
Run
Analytics Thread Start
demo task closing state = 0
demo task started
remote tutorial task started
opening studio with paramater
initialising tips - studio was opened with paramater
Tips initialise started
Tips initialise finished
NewProject - FormOpen
Tips initialise started
Tips initialise finished
tutorial task finished
demo task finished
attempting login
Form closed - #1
Close button clicked on Welcome Screen - shutting down
Exiting
g_closing = -1
save achievements
killProcesses
HTML_Help_Close
CloseAll1Click
CheckChanged
Finished Form Close Query
g_closing = -1
save achievements
killProcesses
HTML_Help_Close
CloseAll1Click
CheckChanged
Finished Form Close Query
Quit_Steam
JclStopExceptiontracking
Finish GM:Studio
Analytics thread end
Preferences_Save
Reg_WriteBoolean
Finished Maker_Preferences_finalization
DestroyTempDir
Finish Support_File finalization
Sound_DirectX - CoUnitialize
finalization of Sound_DirectX finished
DirectSound - finalize start
DirectSound - finalize end
GDIAPI - finalize start
GDIAPI - finalize end
**************************************************************************************
GameMaker:Studio IDE v1.4.9999.45024
**************************************************************************************
Preferences_Save
Reg_WriteBoolean
Finished Maker_Preferences_finalization
DestroyTempDir
Finish Support_File finalization
Sound_DirectX - CoUnitialize
finalization of Sound_DirectX finished
DirectSound - finalize start
DirectSound - finalize end
GDIAPI - finalize start
GDIAPI - finalize end
**************************************************************************************
GameMaker:Studio IDE v1.4.9999.45024
**************************************************************************************
Stacktrace/Exception handling - Enabled
Init #1
Init #2
Init #3
Init #6
Init #7
Init #7.01
Init #7.02
Init #7.03
Init #7.04
Init #7.05
Init #7.06
Init #7.07
Init #7.08
Init #7.09
Init #7.10
Init #7.11
Init #7.12
Init #7.13
Init #7.14
Init #7.15
Init #7.16
Init #7.17
Init #7.18
Init #7.19
Init #7.20
Init #7.21
Init #7.22
Init #7.23
Init #7.24
Init #7.25
Init #7.26
Init #7.27
Init #7.28
Init #7.29
Init #7.30
Init #7.31
Init #7.32
Init #7.33
Init #7.34
Init #7.35
Init #7.36
Init #7.37
Init #7.38
Init #7.40
Init #7.42
Init #7.43
Init #7.44
Init #7.45
Init #7.46
Init #7.47
Init #7.48
Init #7.49
Init #7.50
Init #7.51
Init #7.52
Init #7.53
Init #7.54
Init #7.55
Init #7.56
Init #7.57
Init #7.58
Init #7.59
Init #7.60
Init #7.61
Init #7.62
Init #7.63
Init #7.64
Init #7.65
Run
Analytics Thread Start
demo task closing state = 0
demo task started
remote tutorial task started
opening studio with paramater
initialising tips - studio was opened with paramater
Tips initialise started
Tips initialise finished
NewProject - FormOpen
Tips initialise started
Tips initialise finished
tutorial task finished
demo task finished
Form closed - #1
Close button clicked on Welcome Screen - shutting down
Exiting
g_closing = -1
save achievements
killProcesses
HTML_Help_Close
CloseAll1Click
CheckChanged
Finished Form Close Query
g_closing = -1
save achievements
killProcesses
HTML_Help_Close
CloseAll1Click
CheckChanged
Finished Form Close Query
Analytics thread end
Quit_Steam
JclStopExceptiontracking
Finish GM:Studio
Preferences_Save
Reg_WriteBoolean
Finished Maker_Preferences_finalization
DestroyTempDir
Finish Support_File finalization
Sound_DirectX - CoUnitialize
finalization of Sound_DirectX finished
DirectSound - finalize start
DirectSound - finalize end
GDIAPI - finalize start
GDIAPI - finalize end
 

Appsurd

Member
Compiling for Android with in the GGS Run Lint Code Analysis enabled and bluetooth permission produces a build failed. When looking at the lint, it says:

Note that I have GooglePlayServices and GooglePlayServiceIAP as extensions, and they do not require a bluetooth permission.

When I enable Bluetooth permission, the project is compiled correctly.

When I disable Bluetooth permission and also disable Run Lint Code Analysis, the code complies fine as well.

It looks like a bug to me..
 

Keepa

Member
Audio emitters loop sounds even after stopping them in same room. Also, after a room change when emitter is destroyed & freed memory-wise, wrong sounds play and eventually my game crashes (a windows program 'stopped working' crash, not gamemaker error message). Was working fine until now...
Code to play:
emitter_index = audio_play_sound_on(audio_emitter1, emit_snd, true, 1);
Code to stop:
audio_stop_sound(emitter_index);
 
Last edited:

CleanWater

Member
Hi there, can you please fix the gamepad issues on Linux?

A quote from this post, from things I discovered messing around with the code:

So, after some trials and errors, I discovered three things!

1 - On Linux, the values of the buttons starts from 0 instead of 32769 (i.e.: The A button maps as 32769 on Windows, but 0 on Linux, and so goes on);
2 - All the code to check game pad inputs is working fine, but only in the Draw Events.
3 - On Windows, you can map to A button (and onward) with both 0's and 32769's values.

I didn't managed to get the values for the Axis Sticks on Linux.

I feel I'm getting close to solving this problem, so I still would like to get any clues from anyone interested in seeing the game pads working on Linux smoothly.
 
N

NeonBits

Guest
I'm on GM1.4.1772. Maybe this was fixed? I've lost the .wav files twice in a month, when saving the project. The saving box % freezes, then returns to life; the project is saved in less time; the gmx files are there in the sound folder but not the wav.

There's also the cache and temporary files that don't seem to go right sometimes.
I could not open the manual. I use a shortcut linked to the file instead.
 

lolslayer

Member
About the MRT bug (surface_set_target_ext), together with @Bingdom we investigated the bug, what causes it and how to recreate it.

If you use the application_surface in surface_set_target_ext function you'll get this error:
Code:
Unbalanced surface stack. You MUST use surface_reset_target() for each set.
But if you only use user-defined Surfaces in the surface_set_target_ext function there won't be any problem

Here's a project that recreates the bug:
http://www.mediafire.com/file/m41a08ibcwa812d/MRT_bug_recreation.gmz/file
 

Simon Gust

Member
I am glad that my GM got a forced update to the stable channel even though I wanted to keep using 1.4.1773 (which I can't download anymore).
The first major problem I notice is that the yyc doesn't work at all, hence the downgrade from 1.4.1788 a while back.
upload_2018-9-2_15-57-1.png
The Console doesn't give any additional information except that the compile has finished.
This is yyc only.
 

Dude902

Member
Edited: This post was pretty reactionary. I just wanted to say that I've backed up previous version installers up until the first 1.4 release because it seems the links to previous versions are being removed from the release notes page. That said, there are files that require downloading from yoyo servers even after installation so I don't know how useful this will be. I don't think yoyo intends to break anyone's workflow just to force them to update, and I understand consolidating 1.4 into a final version is a good decision. I just think there are some valid use-cases for having older versions available, and there is still the possibility Yoyo could preserve them for such cases. If not, older installers are still available on the waybackmachine at archive.org (again, with the caveat that they may not work without additional files from yoyo's end).

To the above poster: You could try this link for 1773 and see if it still works/find a way to prevent the forced update. For the record, I had an issue with YYC just like that, it was related to anti-virus, and it's not an issue for me anymore.

Confirmed, Yoyo made the mistake that every software company does when they want to force people to "upgrade" to a new version of their software. In addition to forcing the above poster to update, they deleted most of the older build downloads on the release notes page. Lost a lot of good will from me.

Edit: I've backed up the installers, they are still on the yoyo servers by typing links manually in my browser (listed up to 1.4.1749). Not sure how much good that will do me, if it can force-update/depend on yoyo's servers, but it might be worth doing so if there are versions that don't have auto-update functionality and don't require anything from their end.
 
Last edited:

Dan

YoYo Games Staff
YYG Staff
I am glad that my GM got a forced update to the stable channel even though I wanted to keep using 1.4.1773 (which I can't download anymore).
The first major problem I notice is that the yyc doesn't work at all, hence the downgrade from 1.4.1788 a while back.
View attachment 20453
The Console doesn't give any additional information except that the compile has finished.
This is yyc only.
Create a helpdesk ticket and send us your full compiler log when trying to build for YYC and getting that error. We might need the project attached as a gmz also, if the log doesn't give us much info. Thanks.
 

Dan

YoYo Games Staff
YYG Staff
I'm on GM1.4.1772. Maybe this was fixed? I've lost the .wav files twice in a month, when saving the project. The saving box % freezes, then returns to life; the project is saved in less time; the gmx files are there in the sound folder but not the wav.

There's also the cache and temporary files that don't seem to go right sometimes.
I could not open the manual. I use a shortcut linked to the file instead.
That is an extremely old release and there have been LOTS of IDE and project-saving changes since then, so it's very likely your issue was fixed a while back. See the 1.4 release notes page for all versions since 1772. We would not recommend sticking with 1772 (!).
 

Dan

YoYo Games Staff
YYG Staff
Audio emitters loop sounds even after stopping them in same room. Also, after a room change when emitter is destroyed & freed memory-wise, wrong sounds play and eventually my game crashes (a windows program 'stopped working' crash, not gamemaker error message). Was working fine until now...
Code to play:
emitter_index = audio_play_sound_on(audio_emitter1, emit_snd, true, 1);
Code to stop:
audio_stop_sound(emitter_index);
If you can send us a sample project which reproduces this, then we will look into it.
 

Dan

YoYo Games Staff
YYG Staff
Compiling for Android with in the GGS Run Lint Code Analysis enabled and bluetooth permission produces a build failed. When looking at the lint, it says:

Note that I have GooglePlayServices and GooglePlayServiceIAP as extensions, and they do not require a bluetooth permission.

When I enable Bluetooth permission, the project is compiled correctly.

When I disable Bluetooth permission and also disable Run Lint Code Analysis, the code complies fine as well.

It looks like a bug to me..
Yes, this is a bug and is already in the database. It has been fixed recently for the next GMS2 release, so will see about getting this added into the 1.4 release before it goes Stable also. Thanks.
 

Dan

YoYo Games Staff
YYG Staff
Thanks for the help but I do not see any updated Yoyo Account Terms when I log into accounts.yoyogames.com(As in the Account dashboard, looked at other tabs as well) Btw I'm using Gamemaker free.
You're not getting any error messages there, which says it's not an issue with GM: S 1.4 itself..

Just so we're clear, what do you mean by "GameMaker free"?

Could you send us a ticket via https://accounts.yoyogames.com/contact-us#purchasing and say you're unable to log-in to GM: S 1.4 and can someone check your account is able to license okay.. Please explain that you have already provided a log here, and I have asked you to send the ticket. Obviously, send this ticket using the same email address you're trying to sign-into 1.4 using.
 

chmod777

Member
There's a bug that seems to affect all projects in HTML5 (event those with just an empty room) when using Firefox and when the page has lost focus. Other browsers might be affected as well but desktop Chrome is ok.
TypeError: _Ju2 is undefined (error in debug mode)

Steps to reproduce:
- Run the game in Firefox.
- Open the browser console.
- Click somewhere in the game. The error appears.
- Click somewhere in the console and again in the game. The error appears one more time.
 

obscene

Member
I'm having lots of random issues, especially with sound. Hearing sounds that I've stopped. audio_is_playing returns false yet I still hear them faintly. The audio overlay reveals a huge list of sounds in red which I had never seen before this update.

Also game_restart(); seems to just end the game.
 
Last edited:
M

Mark

Guest
Hello, looks like there bug with image_blend.
image_blend = make_color_rgb(255, 0, 0) or c_red => sprite became blue
image_blend = make_color_rgb(0, 0, 255) or c_blue => sprite became red
Green has no issues though.
Reproducibility tip: this occurs when you DON'T have a draw event (RGB becomes BGR), if you do have a draw event then it behaves as intended.
 

Simon Gust

Member
Ok, worst case scenario:
first, I have GMS on steam so I have no licence key, I can't download prior versions. I need to select them in steam.
second, I need Visual Studio 2013 for the required SKDs but I only have 2010, 2011, 2012 and 2014
I can't download it because my school where I went made the Microsoft account login go over their site (when trying to download) and it doesn't accept my original login data.
The MS account I got from school is most likely expired, I don't even remember my password for it.
I can log in to MS but it doesn't matter, the download always goes over the school site. I tried login out of my Gmail, but they seem to have hacked my personal info so I can't get around it.
What a ****ty day.
 
A

Andy

Guest
This update fixed the constant SSL errors that would popup at launch. :)
 

Kenshiro

Member
The "Display Splash Screen" switch is missing for the GNU/Linux and OS X targets.

[MOD EDIT: Image removed as linked site is flagged for hosting malware]
 
Last edited by a moderator:

Kabcorp

Member
Really good update! BUT sounds on windows still have a huge latency, near to 90ms
-I'm using new audio engine
-classic sound uses (no emiters)
-no white on sound starts
-tryed all combinaisons on GM:S using WAV & OGG
 
L

Latisha

Guest
You're not getting any error messages there, which says it's not an issue with GM: S 1.4 itself..

Just so we're clear, what do you mean by "GameMaker free"?

Could you send us a ticket via https://accounts.yoyogames.com/contact-us#purchasing and say you're unable to log-in to GM: S 1.4 and can someone check your account is able to license okay.. Please explain that you have already provided a log here, and I have asked you to send the ticket. Obviously, send this ticket using the same email address you're trying to sign-into 1.4 using.
GameMaker free as in the free download one that can only export as a exe to windows pc. I also didn't have a transaction ID because I didn't purchase it(at accounts.yoyogames.com/downloads#undefined)
 

Kenshiro

Member
It would be really nice if you guys could update the run_runner.sh script so it works on Ubuntu 18.04. It helps when testing with actual machines instead of VMs, since they usually have the latest Ubuntu LTS.
If you guys need any help testing the scripts, just ask.
 

Dan

YoYo Games Staff
YYG Staff
We have now reproduced the font_add_sprite() offset issue. Using font_add_sprite_ext() and listing the characters in your font is a workaround just now (as mentioned on the first page of this thread), but we will fix for Stable.
 

Dan

YoYo Games Staff
YYG Staff
GameMaker free as in the free download one that can only export as a exe to windows pc. I also didn't have a transaction ID because I didn't purchase it(at accounts.yoyogames.com/downloads#undefined)
The old Free license stopped being available a very long time ago (years). We offered a free Standard license when you registered a YoYo Account for quite a while, but obviously this has now stopped also. If you log in to your account on the website just now, does it say you have a Standard license and can you retrieve the key for this, etc? If not, I suspect you do not have a valid license on your account at the moment.

We have now reproduced the "Acquiring License" issue with an account which has not filled in all of its profile information correctly, but you say you have already checked your account and believe all is okay, so we are confirming our licensing server at the moment to see if this situation can be gained for any other reason.

EDIT: We have determined the cause for this "Acquiring License" issue and are fixing at the moment. A new 9999 version will come out soon to address this.
 
Last edited:

Dan

YoYo Games Staff
YYG Staff
It would be really nice if you guys could update the run_runner.sh script so it works on Ubuntu 18.04. It helps when testing with actual machines instead of VMs, since they usually have the latest Ubuntu LTS.
If you guys need any help testing the scripts, just ask.
I'm afraid adding in support for a different OS does not count as a small issue we can fix before the release goes Stable. This work has been done for GMS2 already ahead of the 2.2.1 release, but will not be added for 1.4.
 

Dan

YoYo Games Staff
YYG Staff
Really good update! BUT sounds on windows still have a huge latency, near to 90ms
-I'm using new audio engine
-classic sound uses (no emiters)
-no white on sound starts
-tryed all combinaisons on GM:S using WAV & OGG
We'd need a sample to see if this is something we're yet to fix.
 

Dan

YoYo Games Staff
YYG Staff
The "Display Splash Screen" switch is missing for the GNU/Linux and OS X targets.
Won't be added now, I'm afraid. This isn't a new issue, and has been closed in the bug database a little while back.
 

Dan

YoYo Games Staff
YYG Staff
We now confirmed the image_blend issue also, so will get that GMS2 fix brought over.
 

Dan

YoYo Games Staff
YYG Staff
I'm having lots of random issues, especially with sound. Hearing sounds that I've stopped. audio_is_playing returns false yet I still hear them faintly. The audio overlay reveals a huge list of sounds in red which I had never seen before this update.

Also game_restart(); seems to just end the game.
The sound stuff is possibly fixed internally already, but we'd need a sample to confirm.

Not sure what the issue is with game_restart() for you - not seen other reports about this. Is this on Windows?


EDIT: Perhaps, when I'm not replying to a new issue ;)
 
L

Latisha

Guest
The old Free license stopped being available a very long time ago (years). We offered a free Standard license when you registered a YoYo Account for quite a while, but obviously this has now stopped also. If you log in to your account on the website just now, does it say you have a Standard license and can you retrieve the key for this, etc? If not, I suspect you do not have a valid license on your account at the moment.

We have now reproduced the "Acquiring License" issue with an account which has not filled in all of its profile information correctly, but you say you have already checked your account and believe all is okay, so we are confirming our licensing server at the moment to see if this situation can be gained for any other reason.
No, it does not say it has a standard license and key retrieval for me.
 

CleanWater

Member
More bugs.

1 - When you Alt+Enter, or Alt+Tab the game on Windows, the screen starts to flicker.
2 - On Linux, when you use the game_end() command, the OS always crash, then I have to force a restart on the PC.
3 - Any insight about the game pad issues I mentioned before on Linux?
 
Noticed a ton of weird bugs when upgrading to this version:
  • Sound effects are broken in-game and use random sounds.
  • Fonts seem to be several characteristics off for no reason.
  • Games randomly freeze without an error message and require ending the test through the IDE.
They made my project completely break, so I had to downgrade back to 1.4.1773.
 

Appsurd

Member
1 - When you Alt+Enter, or Alt+Tab the game on Windows, the screen starts to flicker.
On Windows, in 1 project, I have the same issue. I thought clearing cache might help, but using the cleanup button and/or manually deleting the cache files didn't resolve the problem.
Some more remarks:
- other projects do not show this
- when I change room (i.e. from menu to game) the flikkering stops, also when I return back to the menu, everything works fine
- it only happens on Windows (I develop for Android/iOS so I thought it wasn't that important to mention the "bug" here)
 

nihilblack

Member
I'm stuck forever on the "acquiring license" step.

I was using GM normally up until my hdd crashed a few weeks ago. Now that mi PC it's fixed, I've installed the latest GM downloaded from my account page at the YoYoGames website, and I can´t do anything because it doesn't acquire the license, even if I've filled all my account details, and changed my password just to be sure that It wasn't my fault.
 

Dan

YoYo Games Staff
YYG Staff
I'm stuck forever on the "acquiring license" step.

I was using GM normally up until my hdd crashed a few weeks ago. Now that mi PC it's fixed, I've installed the latest GM downloaded from my account page at the YoYoGames website, and I can´t do anything because it doesn't acquire the license, even if I've filled all my account details, and changed my password just to be sure that It wasn't my fault.
As mentioned above, we've realised this is a bug on our end and are putting out a new version which will fix.

Just FYI for anyone awaiting bug fixes I have said we're doing, you will need to download the new installer when it's available and overwrite your existing install, as the updater won't work with updating FROM 1.4.9999 (it does, of course work perfectly fine updating TO 9999).
 
Top