OFFICIAL GameMaker: Studio 1.4.9999 Released - FEEDBACK

Discussion in 'Announcements' started by rmanthorp, Aug 30, 2018.

  1. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    122
    https://www.yoyogames.com/blog/481/gamemaker-studio-1-4-9999-released

    http://store.yoyogames.com/downloads/gm-studio/release-notes-studio.html

    Hey everyone, we’re happy to announce that version 1.4.9999 has been released to the Beta channel today! Please read the blog/release note carefully and while version 1.4.9999 is in the Beta channel we will be reviewing your feedback on this GMC thread to see whether further fixes are required before the release is moved to the Stable branch. Be aware that your issue will need to be a new and severe one which will affect many people (e.g. a very easy-to-get crash from usage of the IDE) for us to consider addressing the issue. If you do have a major new issue, please let us know via this GMC thread, rather than sending a Helpdesk ticket or any other form of contacting us (unless your issues related to console development - in this case, please use the helpdesk), as we are past the end of support and so we can keep everything for this release in one place.

    A massive thank you from all of us at YoYo Games to you for using GameMaker: Studio 1!
     
    Last edited: Aug 31, 2018
    Latisha, Cpaz, Andy and 14 others like this.
  2. True Valhalla

    True Valhalla Full-Time Developer GMC Elder

    Joined:
    Jun 20, 2016
    Posts:
    257
    The end of an era!
     
    Andy, Jobo, GMWolf and 1 other person like this.
  3. GMWolf

    GMWolf aka fel666

    Joined:
    Jun 21, 2016
    Posts:
    2,971
    I like the version number xD
    What's wrong with the help desk? Could it be YYG recognises there is a serious issue with the help desk? Shock!

    The end of an era indeed! Thanks for providing us with such a great product! Probably the game dev product I have been most satisfied with so far!
    I mean this in a good way, I'm not trying to be passive aggressive against GMS2.
     
  4. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    122
    This is simply because our official support for 1.4 has ended and so our helpdesk can focus on the issues they currently have in.
     
    GMWolf likes this.
  5. GMWolf

    GMWolf aka fel666

    Joined:
    Jun 21, 2016
    Posts:
    2,971
    Oh, that makes sense.
     
  6. andev

    andev Member

    Joined:
    Jul 2, 2017
    Posts:
    444
    [​IMG]
     
    Lukan and 00.Archer like this.
  7. DjangoDurango

    DjangoDurango Member

    Joined:
    Aug 30, 2018
    Posts:
    2
    Is there any way we could get those script errors at startup fixed? Every machine I've installed it on gets them and I've polled friends who use it and they're getting them too. I've installed the update and it hasn't corrected them.
     
  8. zendraw

    zendraw Member

    Joined:
    Jun 20, 2016
    Posts:
    1,272
    what do you mean headline changes/fixes? are there more that are not listed?
     
  9. Dude902

    Dude902 Member

    Joined:
    Feb 9, 2017
    Posts:
    13
    Right off the bat, the way I had borders drawn behind the application surface in HTML5 doesn't work any more, so I'll have to figure out a better way to implement them.

    Pretty unhappy with that because I spent a full workday's worth of time trying to figure it out in the first place. :D
     
  10. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    122
    That should be fixed with this update.
     
  11. BlueSlime

    BlueSlime Member

    Joined:
    Jun 21, 2016
    Posts:
    79
    Welp, I've moved on to Unity and C# but this makes me want to install GM again, but just got this email notice. This is a really nice last gesture guys thanks! :)
     
    rmanthorp likes this.
  12. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    If you're still getting some error message and you're definitely using 9999, then can we get a screenshot to confirm we're talking about the same error messages, please. 9999 does not do the checks which caused the startup errors seen in 1804 and older versions, so those are fixed, but that does not stop you from having a firewall or IE scripting issue which is giving you machine-specific errors outside of our control. Thanks.
     
  13. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    As mentioned in the release notes, this version contains all the fixes in the runner for GMS 2.1.5 plus the ones listed in the release notes. If you want to see this list, https://bugs.yoyogames.com/changelog_page.php?version_id=51

    Note: I said "fixes", not "fixes and new additions" so you can ignore anything on that page which is a new feature in GMS2 or 2.1.5 specifically ;)
     
    zendraw likes this.
  14. BlueBurn

    BlueBurn Member

    Joined:
    Jun 21, 2016
    Posts:
    53
    Last edited: Aug 30, 2018
  15. skyweiss

    skyweiss Member

    Joined:
    Aug 30, 2018
    Posts:
    1
    I know this is a common issue and it's been reported in the past, but I've been using the latest Early Access release for over a year (because I didn't know anything newer was released lol) and after downloading v1.4.9999, trying to sign in with my YoYo Account hangs on the "Acquiring licence" window. The only alternative are license keys but the "License Recovery" button only sends me a Windows-only key, which doesn't give me access to any of my modules.
     
  16. Dude902

    Dude902 Member

    Joined:
    Feb 9, 2017
    Posts:
    13
    This is my HTML5 issue with borders, sorry if this isn't a "bug" per se, but it was working in the last version. I really appreciate the long support you've offered for GMS 1.4 and not saying this is something wrong on the software side. If there's a standard way to add borders instead (that can be toggled on and off and lets you resize the window) please point me to an instructive resource.

    I have one surface for borders drawn in predraw, then the application surface (the 416x640 grey block in the middle, *INTENTIONALLY BLANK IN THIS EXAMPLE*) is drawn automatically.
    In the new version in HTML5 (works fine in windows export as an .exe) the part of the border after the application surface is cut off in any of the 416x640 rooms, it displays if I go back to the initial 1136x640 room.
    Other details:
    I have the initial room set to 1136x640 to run my controller object, then resize and recenter the application surface to 416x640, which is how I coded everything in the game (i.e. all the rooms except the initial one are 416x640). This way I found I could make the loading screen appear properly centered and fill the whole canvas when I hosted it on itch.io. I manually recenter the game window and application surface when I want to toggle the borders.

    Am I not supposed to draw the application surface smaller than the canvas? How can I make optional borders in a fixed-sized itch.io canvas window then?
     
    Last edited: Aug 30, 2018
  17. DjangoDurango

    DjangoDurango Member

    Joined:
    Aug 30, 2018
    Posts:
    2
    I was incorrect; I was still on the previous version. It ran the updater and everything, but I was on the stable channel so it was still out of date. I've switched to the Beta channel, updated again, and now the errors are gone. Thank you!
     
  18. Zuurix

    Zuurix Member

    Joined:
    Jun 20, 2016
    Posts:
    247
    Something is wrong with font_add_sprite() in 9999 - this is how my custom font looks in there:

    [​IMG]

    [​IMG]

    ^ This part should say "ABCDEFGHI"

    Code:

    fnt_medium = font_add_sprite(spr_medium_font, ord("!"), true, 2);

    This fixes it:

    fnt_medium = font_add_sprite_ext(spr_medium_font, "!'#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz", true, 2);

    Resource:

    upload_2018-8-30_21-51-46.png
     
  19. Dr. Wolf

    Dr. Wolf Member

    Joined:
    Jan 17, 2017
    Posts:
    52
    Can confirm problems with audio; for example, in my GMC Jam 7 entry, "DriftWar", the firing sound now only plays when the tank is facing certain directions (although, the drifting makes it hard to tell exactly which directions in a quick test). The problem also manifests in many other projects, as I'm usually using the positional audio system for something, even in 2D games.

    I'm currently running more tests and may have additional bugs to report shortly.

    EDIT1: Can also confirm font_add_sprite() problems, as my custom font loader uses font_add_sprite() as part of itself, resulting in:
    [​IMG]

    EDIT2: The sound thing also seems to break my system for managing certain kinds of looped sounds (in particular things like engine thrust sounds), though I have not yet identified exactly which function(s) are responsible.

    EDIT3: No luck with fix for the font thing suggested by Zuurix. Here's an example...press the button to load a custom font (yes, it's incomplete, but the font loading itself, at least, was working in the previous version).(slight post edit to get the correct version in there)

    EDIT4: To demonstrate the audio looping issue, here's a quick test project, including the project file, .1804 build, and .9999 build. If you spam the single sound (space), it is easy to cause the looped rocket sound (control) to become glitched in the .9999 build, causing it to keep playing after the key is released. This does not happen in the .1804 build.
     
    Last edited: Aug 30, 2018
  20. Appsurd

    Appsurd Member

    Joined:
    Jun 20, 2016
    Posts:
    161
    I tried to compile two projects for Android (non-YYC) using the new 1.4.9999 release. Both did not compile at first go.

    The first required me to switch off the Run Lint Code Analysis in the GGS Android tab. Then it compiled fine. Is this intended behaviour?

    The second gave another error:
    Task 'assembleRelease' not found in root project
    Until now, I cannot find a solution for this error. Anyone ideas? I'm using NDK 16b, SDK 27, Min SDK 14, GooglePlayServices 3.0.1, GooglePlayServicesIAP 1.0.2.


    EDIT: The latter is resolved for no real reason. Restarting PC seemed to solve it. Still wondering about the first item though...

    EDIT 2: Just reviewed the Lint, and it said it was required to enable Bluetooth permission. Is this a bug?
     
    Last edited: Aug 31, 2018
  21. Dude902

    Dude902 Member

    Joined:
    Feb 9, 2017
    Posts:
    13
    I've read of another html5 surfaces bug not fixed in this build on the subreddit, so I'm wondering, should I export a sample project with a reproducible bug at this point or are surface issues off the table, and you guys/gals just focused on other issues?

    Edit: Here's a project file that displays nicely exported to HTML5 in 1.4.1804 and breaks in 1.4.9999
    https://drive.google.com/open?id=1dze8UwgSG9aLTzKvE1h-1R8Owa7_STKt
    Sorry if it has some leftover code from my project.
     
    Last edited: Aug 30, 2018
  22. Threxx

    Threxx Member

    Joined:
    Jan 29, 2017
    Posts:
    7
    When compiling our project we get the following error:

    https://i.imgur.com/svrHkEX.png

    When one navigates to the line in question, the script giving the error has the appropriate number of arguments. This code compiled without issue in 1.4.1773, and now refuses to compile in 1.4.9999:

    https://i.imgur.com/8v6WNAB.png

    The script being used is a public domain script from GMLscripts.com, for further reference: http://www.gmlscripts.com/script/collision_rectangle_list

    EDIT 1: It seems the name of the script is causing the problems - after renaming the script it functions correctly.

    I can also corroborate that font_add_sprite() is broken; all of the text in our project has broken after this new update.

    EDIT 2: If you're looking to use font_add_sprite(), subtract 2 from the ord value that you give as the start of the font. It seems the font table is off by 2 in this update.
     
    Last edited: Aug 31, 2018
  23. wamingo

    wamingo Member

    Joined:
    Jun 21, 2016
    Posts:
    56
    Android YYC gives following error when the game tries to run on the device:
    "unable to find library for this devices architecture, which is armv7i, ensure you have included the correct architecture in your APK"

    am I missing some install?

    target:26, min:14, compile:26
    build tools: 26.0.0
    support lib: 26.0.0

    ndk: 16b
    jdk: 1.8.0_102

    tried downgrading jdk and a number of sdk settings to no avail, android phone and tablet, same result.
    All worked fine in 1804.
     
  24. chmod777

    chmod777 Member

    Joined:
    Aug 26, 2016
    Posts:
    136
    GMS2 has now a built-in function called like this.
    https://docs2.yoyogames.com/source/_build/3_scripting/4_gml_reference/movement and collisions/collisions/collision_rectangle_list.html

    So maybe it's also the same in GMS1 (but this would be very unexpected to get new functions in the last release) and you should just try to rename your function.
     
  25. Threxx

    Threxx Member

    Joined:
    Jan 29, 2017
    Posts:
    7
    I did further testing, it seems the IDE is (probably correctly) saying that this function does not exist if I try to call it, but the COMPILER is treating it as a real GM function and attempting to parse it with the official function's number of arguments. Either way, there's an inconsistency here and a bug.
     
  26. RizbIT

    RizbIT Member

    Joined:
    Jun 24, 2016
    Posts:
    326
    yeh!

    The url Open now works great on UWP

    But the http post and post string etc.. still dont seem to work. cam other confirm?


    Edit: now i get a response but it seems the post string parameters are not received by the PHP file

    so for example on UWP:
    post=http_post_string("http://rizbit.uk/myapp/myphpfile.php?test=big","key=123&name=rizbit")

    in the PHP file we can pull the test value using $_GET but cant get the values of key and name with $_POST
     
    Last edited: Aug 31, 2018
  27. Latisha

    Latisha Member

    Joined:
    Aug 31, 2018
    Posts:
    5
    Hey guys, I just downloaded 1.4.9999. When I started the program, I was sent to the start page where it prompted me to log in.
    [​IMG]
    I heard that this version no longer has online shtuffs, but I am unable to access the program until I can actually log in. When I input my account credentials, the login
    bar freezes halfway, before disappearing and I am unable to click the Log In button again. Is there any way to fix this?
    [​IMG]
    Game maker was what got me into games development, and to this day, I still use 1.4's sprite editor for all my sprites.
    Game Maker studio 2 just didn't work for me - especially the sprite editor. And since I spent many years making sprites in 1.4's sprite editor, I can no longer get used to any other program.
    Any help with this would be appreciated. Thanks.
     

    Attached Files:

  28. RizbIT

    RizbIT Member

    Joined:
    Jun 24, 2016
    Posts:
    326
    ON UWP

    I have mic plugged in on pc and its working, setup right

    but
    var count = audio_get_recorder_count();

    always returns zero
     
    heatbox likes this.
  29. 00.Archer

    00.Archer Member

    Joined:
    Jul 24, 2018
    Posts:
    19
    Did you guys changed something related to building? Compiling the game is much faster (Windows target).
     
    Appsurd likes this.
  30. csanyk

    csanyk Member

    Joined:
    Jun 20, 2016
    Posts:
    806
    Is there a direct download link? I'd like to have the installer so I can archive it, instead of just running it through the updater.
     
  31. FrostyCat

    FrostyCat Member

    Joined:
    Jun 26, 2016
    Posts:
    2,918
    See: Release Notes
     
    csanyk likes this.
  32. TheDreik

    TheDreik Member

    Joined:
    Aug 31, 2018
    Posts:
    1
    Hello, looks like there bug with image_blend.
    image_blend = make_color_rgb(255, 0, 0) or c_red => sprite became blue
    image_blend = make_color_rgb(0, 0, 255) or c_blue => sprite became red
    Green has no issues though.
     
    Mark and Keepa like this.
  33. OblivionSkull21

    OblivionSkull21 Member

    Joined:
    Sep 26, 2017
    Posts:
    131
    I have a big issue. Every, and I mean every, version after 1773 has caused problems with my audio stuttering/distorting, and none of the updates have fixed the issue (including the last one). So I stuck with version 1773.

    But hey, look! Steam auto-updated me to the final version. No big deal, I'll just go revert back to 1773...

    NOPE. It's gone.

    Thanks, yoyo. My game is permanently broke now with no option to rollback to the stable version I was using. :\


    I don't have the money for GMS 2 right now, not to mention the hassle it would be to convert my year's worth of development from 1.4 to 2.

    Please, yoyo. I beg of you. Put the other versions back on steam.
     
    CleanWater and Dan1 like this.
  34. GMWolf

    GMWolf aka fel666

    Joined:
    Jun 21, 2016
    Posts:
    2,971
    Are you on the beta channel? (Sounds like it) if you go back to the stable channel you should get old version back. (Unless YYG accidentally released it on both channels, but I doubt that's the case)
     
  35. OblivionSkull21

    OblivionSkull21 Member

    Joined:
    Sep 26, 2017
    Posts:
    131
    No. On Steam, in the properties window under betas, the only options I can choose from are 1804 and 1999. I used to be able to switch between like 6 different versions but now I can't go back to the one I used to use.

    Unless I am not understanding correctly. Am I looking in the wrong place? This is how I've always rolled back on updates.
     
  36. GMWolf

    GMWolf aka fel666

    Joined:
    Jun 21, 2016
    Posts:
    2,971
    Oh! Strange! (Can't verify as i don't have steam version)
     
  37. Appsurd

    Appsurd Member

    Joined:
    Jun 20, 2016
    Posts:
    161
    Usually, the Non-Steam version can be reverted back easily by going to the Release Notes and simply clicking on an older version, which starts downloading immediately. However, it seems Yoyo deleted these hyperlinks for 1788 and below...
    On the other hand,if you look at the hyperlink of 1804 and try 1773 instead of 1804, it seems http://store.yoyogames.com/downloads/gm-studio/GMStudio-Installer-1.4.1773.exe can be used to download it. Not sure if this is illegal, but Yoyo will probably remove this somewhere soon, so I suggest hurrying up (if you don't mind switching to the standalone version)
     
    Last edited: Aug 31, 2018
  38. Ouren

    Ouren Member

    Joined:
    Jan 10, 2017
    Posts:
    8
    PS4 SDK Error still present (culled for obvious reasons)
    Code:
    SDK version (proc_param) = 05.008.001.
    The eboot file must use SDK 5.5 at this point.

    Additionally, this page is out of date for this and the publishing tools version:
    https://help.yoyogames.com/hc/en-us/articles/216756258-PS4-SDK-Version-Support

    Was the Vita trophy API fix from the dev branch rolled into this update as well?

    Cheers
     
    Last edited: Aug 31, 2018
  39. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    Not going to talk about console stuff on this public thread, other than to say you're correct I forgot to update that FAQ, so I will do that now. Send us a ticket with your first PS4 question and the Vita question. Thanks.
     
  40. rmanthorp

    rmanthorp YoYo Games Staff Admin YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    122
    Have added a note to the OP to mention console support should still go through the helpdesk - sorry for not making that clear
     
  41. Ludorverr

    Ludorverr Member

    Joined:
    Jun 20, 2016
    Posts:
    24
    Same issue as Dark_Shadows549. I'm not sure whether yoyogames realizes this but Steam works a bit differently than the non-steam install, they've actually force updated us. We previously had a bunch of different version options but now that they've been removed Steam automatically installed 1.4.1804 with no way to go back.

    As Appsurd said you can still download non-steam version by manually entering the URL. Be sure to take some screenshots of your preferences tabs as you'll want to re-configure those preferences again to be like your Steam version. I moved to non-steam version earlier today.
    Are these versions allowed to be hosted elsewhere? (if the direct URL links get removed) I hope YYG doesn't think that these old versions are completely worthless. For many of us as the versions ticked by eventually you get tired of your game breaking with every update so you end up staying on an old version when there's so many changes and bugs in the next version which you can't always be bothered sorting out for yoyogames, I'm not entirely lazy I submitted 12 bugs so I've done my fair share.

    It's not cool to force-update old version users who have very large work-in-progress games that have so many dependencies.
     
  42. Size43

    Size43 Member

    Joined:
    Dec 3, 2016
    Posts:
    1
    There's an issue where network_connect_raw isn't working properly for non-blocking sockets on Windows (both YYC and non-YYC). It seems to sometimes try to do the GM handshake, which it should only do when you use network_connect.

    Some code to reproduce the issue:

    Code:
    network_set_config(network_config_use_non_blocking_socket, true)
    repeat irandom_range(2, 100) // repeat is just here to make the issue more frequent, I've had this happen with a single socket too
    {
        var s = network_create_socket(network_socket_tcp)
        network_connect_raw(s, "51.68.190.45", 41001)
    }
    After putting that in a create/room start event and running the game a few times I get this:

     
    00.Archer likes this.
  43. Appsurd

    Appsurd Member

    Joined:
    Jun 20, 2016
    Posts:
    161
    Pressing Right Mouse Button on Extensions and selecting Import Extension from Library prompts a YoYo Account Login, which is (I think) incorrect, as you said to have removed it.

    NB: When filling in my details, and pressing Login, it did correctly say "No Marketplace connection"
     
  44. Dr. Wolf

    Dr. Wolf Member

    Joined:
    Jan 17, 2017
    Posts:
    52
    Works, thanks!

    Meanwhile, I've played around a little more with the audio test from my last post. It seems that, sometimes, .9999 will actually play the wrong sound-- that is, sometimes, it will play the rocket sound upon pressing space, even though that key is hard-coded to the lightning sound. It's worth repeating that the code for interruptible looping sounds in the test project is something I've been reusing for a long time, including in several Jam projects, with no users reporting any problems. As for the non-looping sound, the code is just:
    Code:
    if keyboard_check_pressed(vk_space)
    {
        audio_play_sound_on(ship_audio_emitter, snd_foad_lightning, 0, 0);
    };
    
    ...but it is playing the other sound instead under certain circumstances.

    EDIT1: If it helps you to narrow down the problem, the issue does not reproduce in GMS2, nor in 1.4.1804-- it seems to be specific to 1.4.9999.
     
    Last edited: Aug 31, 2018
  45. Keepa

    Keepa Member

    Joined:
    Aug 31, 2018
    Posts:
    3
    Good job on the fixes, but there's a bug with the image_blend colour. My torches are drawn with:
    my_torch.light_alpha = 0.6;
    my_torch.image_blend = make_colour_rgb(221, 175, 58);



    and all torches are drawn like so onto this dark surface
    surface_set_target(global.dark_surface);

    draw_clear_alpha(c_black,global.ggdark_finalalpha);
    draw_set_blend_mode(bm_add);

    //Draw all the Lights ------------------
    with(obj_base_light)
    {
    draw torches here....
     

    Attached Files:

  46. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    There was an issue with the falloff model, which 9999 has fixed, however your sample is using incorrect code and is not demonstrating that falloff bug.

    You don't pass the falloff mode into the audio_play_sound_at(), instead you have to give this function a falloff value appropriate to the model also in effect.

    So, in your sample:

    sndFalloff = audio_falloff_exponent_distance;//audio_falloff_exponent_distance;
    audio_play_sound_at(sndIndex, x, y, 0, sndStart, sndEnd, sndFalloff, true, 1);

    becomes:

    //sndFalloff = audio_falloff_exponent_distance;//audio_falloff_exponent_distance;

    audio_falloff_set_model(audio_falloff_exponent_distance);
    audio_play_sound_at(sndIndex, x, y, 0, sndStart, sndEnd, 1, true, 1);

    and then your sample works as expected.
     
    BlueBurn likes this.
  47. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    Yup, we have now fixed this ahead of the Stable release.
     
  48. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    Yup, we have now fixed this ahead of the Stable release.
     
  49. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    Can you open a Helpdesk ticket and send us your %AppData%\GameMaker-Studio\TraceIDE.log file, please. Right now, I'd suggest it's likely to be a firewall or other networking issue on your PC, seeing as other people can update and license fine, but we won't know until we see the log. Thanks.


    EDIT: I have been told we have answered a couple of support questions about this issue already, and in each case the person had not accepted the current YoYo Account terms adn updated their account for GDPR compliance. Log in to accounts.yoyogames.com and accept the terms and update your account details. Then try GM: S again.
     
    Last edited: Aug 31, 2018
    Latisha likes this.
  50. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    120
    We've determined this is the same as https://bugs.yoyogames.com/view.php?id=29763 and https://bugs.yoyogames.com/view.php?id=29817 , so we've brought the fix for this into 1.4 ahead of the Stable release.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice