Question - IDE GameMaker 2 IDE versions above 2.0.7 crash upon launch

Hi so I'm trying to get GameMaker Studio 2 to actually run on my mac, and preferably at least 2.1.4 because that IDE version is required to even log in. I can't use the versions that open because, my project I'm working on I started developing in 2.2 and these older versions have no way for logging in. So can someone tell me why somewhere along the 2.1 update causes GMS2 to crash instantly? I'm using macOS 10.11.6 and I feel like I should be able to run newer updates of GMS2 just fine.

Here is a ui.log: https://drive.google.com/file/d/1tibHNmlWmtSEA42CilBnZWSrHkiXqneW/view?usp=sharing

This one might not have 2.2.5 details in it, but I can try to find an post one of that after I try to install it again.
 
If you haven't already, the first thing I would do is log a ticket with the Helpdesk, they should have a better idea of what the error codes in your log mean. https://accounts.yoyogames.com/contact-us

In the mean time, double check you've followed all the setup instructions for macOS here : https://help.yoyogames.com/hc/en-us/articles/227860547-GMS2-Required-SDKs

I'm not sure if this will affect the crashing, but they recommend using mono framework 5.20 (link for download is on the page above). Maybe it hasn't installed properly for you can you can try reinstalling it. It says on the guide page above that mono is just used for building project, so it might not be related to the crashing, but worth I try I think.

I've read some forum posts some time ago that some people had some luck with installing the latest version of mono (6.8 at the time of this post). But that would be at your own risk to try, if you are comfortable with installing/uninstalling the framework yourself. You can get that here : https://www.mono-project.com/download/stable/
 
I'm trying CrossOver to use the Windows version, I got farther and it kept prompting me to install MESA (opengl.dll or something) but its not going past there.
 
Top