1. Hey! Guest! The 35th GMC Jam will take place between November 28th, 12:00 UTC - December 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice

Android GameMaker 2 Android custom icons are not being displayed!

Discussion in 'GameMaker Studio 2 Community Tech Support' started by MadRabbit, Jan 26, 2019.

  1. MadRabbit

    MadRabbit Member

    Joined:
    Jan 26, 2019
    Posts:
    4
    I am using GameMaker 2. I have android export set up and working using VM. (YYC doesn't work for me) My app works but the icon is the default gamemaker icon. I have added a custom icon for all icon sizes in General settings -> Android -> icons. When I create an executable .apk file and install it on my phone the icon is the default GameMaker icon. This is very frustrating because I paid $400 dollars for GameMaker 2 Mobile and cannot even get rid of the default icon. WHAT DID I PAY FOR??

    Edit: Some possible solutions I have tried are cleaning the solution via the brush button, and compiling using YYC instead of VM. I have now successfully compile with YYC but the icon is still the default.
     
    Last edited: Jan 27, 2019
  2. Nocturne

    Nocturne Friendly Tyrant Forum Staff Admin

    Joined:
    Apr 13, 2016
    Posts:
    6,953
    Hi there! I've not seen this issue before, so I'd suggest first of all that you file a bug with a link to the project showing the issue... then there are a few things that you can try to fix this. The first is to simply clear the asset cache (clicking the "broom" icon at the top of the IDE) and seeing if that refreshes the icons. The next thing to do is go into the Project directory and check the Icons are actually saved correctly. You can open the project from the Help > Open In Explorer option, and then browse to the section of the project: options\android\icons

    If the icons are all saved correctly in that location then it might be worth checking your icon formats against those of the official runtime. You can get the base icons used to build all your projects from the current runtime Android folder. On my PC this is located at: &programdata%\GameMakerStudio2\Cache\runtimes\runtime-2.2.2.297\android\runner\ProjectFiles\src\main\res\ Check your own icons against the ones found there to make sure they are the same format. You could back those up too and then edit them directly in that folder, but note that this will affect ALL builds of ALL projects!!!! So only do this if you really must export with icons now and can't wait for a few days until support gets back to you.
     
  3. MarceloP

    MarceloP Member

    Joined:
    Apr 11, 2018
    Posts:
    254
    I'm facing the same problem.

    When exporting to Android, using API 28, after setting all icons from ldpi to xxxdpi, I still get the default icon of GMS2 in all of our test devices. I'm compiling with YYC and have also tried VM.
    In fact, I've not set any of the adaptive icons but, as far as I know, they're not strictly necessary to be set, right? There should be a checkbox in the adaptive icons configuration labeled as "Use adaptive Icons".

    It really seems that it's using the adaptive one, ignoring my dpi based icons.

    ----- Edited -----
    "&programdata%\GameMakerStudio2\Cache\runtimes\runtime-.2.2.297\android\runner\ProjectFiles\src\main\res\"

    This folder only shows those adaptive icons from GMS2
     
  4. MarceloP

    MarceloP Member

    Joined:
    Apr 11, 2018
    Posts:
    254
    Sorry for the double post. I tried everything by cleaning, re-setting all icons in the dpi based icon tab, cleaning the cache, uninstalling the game from the device and re-installing it, YYC and VM. Everything I can think of.

    It's pretty frustrating to need something so simple working as expected. "No Adaptive Icons? Fine, use the normal ones."
    As always that had to be "work-arounded", since something so simple will probably take ages to be changed/fixed.

    @MadRabbit to fix for a specific deploy, do as follows:

    1 - Go to the path: "%programdata%\GameMakerStudio2\Cache\runtimes\runtime-.2.2.297\android\runner\ProjectFiles\src\main\res\", as suggested by @Nocturne
    2 - Copy the following folders to a backup folder of yours: https://imgur.com/a/5HsNgHV
    3 - In GMS2, select the deploy platform and click in the clear button (confirm the cleaning in console).
    4 - Back in that path's folder, enter each one of those folders and delete everything (6 of them should have 3 files, and 1 should have only one file).
    5 - Copy for each dpi folder, the corresponding dpi image you want, changing it's name to icon.png
    6 - The "drawable-hdpi" folder can receive the same image as on "drawable-hdpi-v26"
    7 - Deploy your apk
    8 - Roll back you backup, if you whish.

    Hope this helps those other helpless people trying to reach their deadlines and facing such inexplicable problems that come from nowhere in GMS2.
    Thanks @Nocturne for the leading folder.
     
    Nocturne likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice